aboutsummaryrefslogtreecommitdiff
path: root/net/tcpview
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /net/tcpview
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'net/tcpview')
-rw-r--r--net/tcpview/Makefile2
-rw-r--r--net/tcpview/files/patch-Makefile4
-rw-r--r--net/tcpview/pkg-plist1
3 files changed, 3 insertions, 4 deletions
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index 5facb70d168f..0d339c6b2d33 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -26,6 +26,6 @@ post-patch:
.endfor
post-install:
- ${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${X11BASE}/lib/X11/app-defaults/
+ ${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${LOCALBASE}/lib/X11/app-defaults/
.include <bsd.port.mk>
diff --git a/net/tcpview/files/patch-Makefile b/net/tcpview/files/patch-Makefile
index d83a34d70748..403254edc6bc 100644
--- a/net/tcpview/files/patch-Makefile
+++ b/net/tcpview/files/patch-Makefile
@@ -10,7 +10,7 @@
-LIB =
+DEFINES = -DCSLIP -DPPP
+CCOPT = -O0
-+INCLUDES = -I.. -I$(X11BASE)/include
++INCLUDES = -I.. -I$(LOCALBASE)/include
+LIB =-ll
# These are for the Sun4 version
@@ -68,7 +68,7 @@
tcpview: $(TCPVIEW_OBJ)
- $(CC) $(CFLAGS) -o $@ $(TCPVIEW_OBJ) $(XLIB) $(LIB)
-+ $(CC) $(CFLAGS) -o $@ $(TCPVIEW_OBJ) -L${X11BASE}/lib $(XLIB) $(LIB)
++ $(CC) $(CFLAGS) -o $@ $(TCPVIEW_OBJ) -L${LOCALBASE}/lib $(XLIB) $(LIB)
tcpslice: $(TCPSLICE_OBJ)
$(CC) $(CFLAGS) -o $@ $(TCPSLICE_OBJ)
diff --git a/net/tcpview/pkg-plist b/net/tcpview/pkg-plist
index 5d32a20d72bf..b7ecafba2833 100644
--- a/net/tcpview/pkg-plist
+++ b/net/tcpview/pkg-plist
@@ -6,5 +6,4 @@ lib/tcpview/hosts
lib/tcpview/manuf
@dirrm lib/tcpview/filters
@dirrm lib/tcpview
-@cwd %%X11BASE%%
lib/X11/app-defaults/Tcpview