aboutsummaryrefslogtreecommitdiff
path: root/net/tigervnc-devel/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-07-08 01:04:00 +0000
committerCy Schubert <cy@FreeBSD.org>2016-07-08 01:04:00 +0000
commit262ac152b2a6e48e6078cafb9489fb47bd5d0c21 (patch)
tree2f4262d4a0db6086cf9e96063790ef4ba4146dbe /net/tigervnc-devel/Makefile
parent1c76791eb4a78a3878de9d26ac3e639c52c263df (diff)
downloadports-262ac152b2a6e48e6078cafb9489fb47bd5d0c21.tar.gz
ports-262ac152b2a6e48e6078cafb9489fb47bd5d0c21.zip
Welcome tigervnc-devel 1.7.0 Beta (actual version number is 1.6.90).
Updates from the tigervnc 1.6.0 base port include: - Multi-threaded decoder in the FLTK viewer - Improved SSH integration in the Java viewer - Fine grained lock down of Xvnc parameters - Compatibility with Xorg 1.18 - Lots of packaging fixes - Better compatibility with Vino, both in the FLTK and Java viewer
Notes
Notes: svn path=/head/; revision=418208
Diffstat (limited to 'net/tigervnc-devel/Makefile')
-rw-r--r--net/tigervnc-devel/Makefile145
1 files changed, 145 insertions, 0 deletions
diff --git a/net/tigervnc-devel/Makefile b/net/tigervnc-devel/Makefile
new file mode 100644
index 000000000000..1df600a93943
--- /dev/null
+++ b/net/tigervnc-devel/Makefile
@@ -0,0 +1,145 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= tigervnc
+PORTVERSION= 1.6.90
+DISTVERSIONPREFIX= v
+CATEGORIES= net x11-servers
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= High-performance, platform-neutral implementation of VNC
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENCE.TXT
+
+PATCH_DEPENDS= ${NONEXISTENT}:x11-servers/xorg-server:patch
+BUILD_DEPENDS= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/dri \
+ ${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
+ bash:shells/bash
+# almost equivalent to x11-servers/xorg-server's
+RUN_DEPENDS= ${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
+ xkbcomp:x11/xkbcomp
+
+CONFLICTS= tridiavnc-[0-9]* \
+ tightvnc-[0-9]* \
+ tigervnc-devel-[0-9]* \
+ vnc-[0-9]*
+
+USES= autoreconf:build cmake cpe gmake jpeg libtool pkgconfig \
+ python ssl iconv
+USE_GL= gl
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= TigerVNC
+
+USE_XORG+= bigreqsproto compositeproto damageproto fixesproto fontsproto glproto \
+ inputproto kbproto pixman randrproto renderproto resourceproto \
+ scrnsaverproto videoproto xau xdmcp xext xkbfile xcmiscproto xextproto \
+ xfont xproto xrandr xtrans xtst xorg-macros presentproto \
+ x11 sm ice xrender xdamage
+
+LIB_DEPENDS= libunwind.so:devel/libunwind \
+ libxshmfence.so:x11/libxshmfence \
+ libfontconfig.so:x11-fonts/fontconfig
+
+CFLAGS+= -fPIC
+
+OPTIONS_DEFINE= GNUTLS NLS PAM VIEWER DOCS
+OPTIONS_DEFAULT= GNUTLS PAM VIEWER
+VIEWER_DESC= Build vncviewer
+
+.include <bsd.port.options.mk>
+
+CMAKE_ARGS= -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=${STAGE}${PREFIX}
+
+.if ${PORT_OPTIONS:MGNUTLS}
+LIB_DEPENDS+= libtasn1.so:security/libtasn1 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libgnutls.so:security/gnutls
+CONFIGURE_ARGS+= --enable-glx-tls
+CMAKE_ARGS+= -DENABLE_GNUTLS=1
+.else
+CMAKE_ARGS+= -DENABLE_GNUTLS=0
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CMAKE_ARGS+= -DENABLE_NLS=1
+PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DENABLE_NLS=0
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPAM}
+CMAKE_ARGS+= -DENABLE_PAM=1
+.else
+CMAKE_ARGS+= -DENABLE_PAM=0
+.endif
+
+.if ${PORT_OPTIONS:MVIEWER}
+CMAKE_ARGS+= -DBUILD_VIEWER=1
+LIB_DEPENDS+= libpng.so:graphics/png \
+ libfltk.so:x11-toolkits/fltk
+# ImageMagick is required to generate icons during build process
+BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:graphics/ImageMagick
+USE_XORG+= xcursor xfixes xft xinerama
+PLIST_SUB+= VIEWER=""
+INSTALLS_ICONS= yes
+DESKTOP_ENTRIES= "TigerVNC viewer" "Connect to VNC server and display remote desktop" \
+ "${PORTNAME}" "vncviewer" "Network;" false
+.else
+CMAKE_ARGS+= -DBUILD_VIEWER=0
+PLIST_SUB+= VIEWER="@comment "
+.endif
+
+MAKE_ARGS+= TIGERVNC_SRCDIR=${WRKSRC}
+CONFIGURE_ARGS+= \
+ --prefix=${PREFIX} --mandir=${PREFIX}/man/ \
+ --docdir=${PREFIX}/share/doc/${PORTNAME}/ --with-pic --without-dtrace \
+ --disable-static --disable-dri --disable-unit-tests \
+ --disable-xinerama --disable-xvfb --disable-xnest --disable-xorg \
+ --disable-dmx --disable-xwin --disable-xephyr --disable-kdrive \
+ --disable-config-dbus --disable-config-hal \
+ --disable-dri2 --enable-install-libxf86config --enable-glx \
+ --with-default-font-path="catalogue:${LOCALBASE}/share/fonts,built-ins" \
+ --with-xkb-path=${LOCALBASE}/share/X11/xkb \
+ --with-xkb-bin-directory=${LOCALBASE}/bin \
+ --with-serverconfig-path=${LOCALBASE}/lib/X11 \
+ --disable-selective-werror \
+ --with-fontrootdir=${LOCALBASE}/share/fonts
+
+.include <bsd.port.pre.mk>
+
+TIGERVNC_XORG_PATCH_VER= 117
+
+# import from x11-server/xorg-server/Makefile
+.if ${SSL_DEFAULT} == base
+# The reason why I use this is cause openssl from base doesn't
+# install a .pc file and configure will fail trying to find it.
+# Setting both of those variables to a *non-empty* value by-passes
+# the pkg-config check.
+CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
+.endif
+
+XORG_WRKDIR= ${MAKE} -C ${PORTSDIR}/x11-servers/xorg-server -VWRKSRC
+
+pre-patch:
+ @${CP} -R `${XORG_WRKDIR}`/ ${WRKSRC}/unix/xserver/
+
+post-patch:
+ @cd ${WRKSRC}/unix/xserver/ && ${PATCH} -p1 < ${WRKSRC}/unix/xserver${TIGERVNC_XORG_PATCH_VER}.patch
+
+post-configure:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${AUTORECONF} -fiv
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ./configure ${CONFIGURE_ARGS}
+
+post-build:
+ @cd ${WRKSRC}/unix/xserver/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} SHELL=${LOCALBASE}/bin/bash
+
+post-install:
+ @cd ${WRKSRC}/unix/xserver/hw/vnc/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install
+
+.include <bsd.port.post.mk>