aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-24 03:58:10 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-24 03:58:10 +0000
commit23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2 (patch)
treebf902918ea7c3c799ea9697638ba106fe555520d /net/tintin++/Makefile
parent55eb53803480fa9e826b0dccbe9fcc7fa76d27d0 (diff)
downloadports-23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2.tar.gz
ports-23de3e1b7385c6f49e92eb9f3cbe537d5f36aeb2.zip
- Add back net/tintin++, I was intended to delete net/tintin++-devel
Notes
Notes: svn path=/head/; revision=259885
Diffstat (limited to 'net/tintin++/Makefile')
-rw-r--r--net/tintin++/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
new file mode 100644
index 000000000000..c51b12ad8baf
--- /dev/null
+++ b/net/tintin++/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: tintin++
+# Date created: 15 Nov 1994
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME= tintin++
+PORTVERSION= 2.00.1
+CATEGORIES+= net games
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= tintin-${PORTVERSION}
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A client program to help playing MUDs
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+CONFIGURE_ARGS+=--includedir=${LOCALBASE}/include --libdir=${LOCALBASE}/lib \
+ --prefix=${PREFIX}
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/tt++
+PORTDOCS= ${DOCS:T}
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/tt/src
+
+DOCS= CREDITS FAQ README SCRIPTS TODO \
+ docs/chat_protocol.txt docs/tintin19.txt
+PROJECTHOST= tintin-mud-client
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC}/.. && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>