aboutsummaryrefslogtreecommitdiff
path: root/net/tintin++
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 13:11:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-10-07 13:11:20 +0000
commita01ce24d15441dd0b7baef1076666859f183dcb7 (patch)
tree906f4fb766ed2806968ad57c9f2ea72f1a20285a /net/tintin++
parentef3504f900526a2ba1235091d48e41f2ea8bd565 (diff)
downloadports-a01ce24d15441dd0b7baef1076666859f183dcb7.tar.gz
ports-a01ce24d15441dd0b7baef1076666859f183dcb7.zip
- Pet portlint: remove ABI version number from LIB_DEPENDS
- Convert to new options framework - Cleanup Makefile header
Notes
Notes: svn path=/head/; revision=305471
Diffstat (limited to 'net/tintin++')
-rw-r--r--net/tintin++/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index ea2da016cf7d..e4466a22ddf9 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tintin++
-# Date created: 15 Nov 1994
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= tintin++
PORTVERSION= 2.00.8
@@ -17,9 +13,10 @@ COMMENT= A client program to help playing MUDs
LICENSE= GPLv2
-LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-OPTIONS= BIG5 "Big5 support" off
+OPTIONS_DEFINE= BIG5 DOCS
+BIG5_DESC= Big5 support
CONFIGURE_ARGS= --includedir=${LOCALBASE}/include \
--libdir=${LOCALBASE}/lib \
@@ -37,7 +34,7 @@ PORTDOCS= ${DOCS:T}
.include <bsd.port.options.mk>
-.if defined(WITH_BIG5)
+.if ${PORT_OPTIONS:MBIG5}
CONFIGURE_ARGS+=--enable-big5
.endif
@@ -46,7 +43,7 @@ post-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d ${DOCSDIR}/
cd ${WRKSRC}/../ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
.endif