aboutsummaryrefslogtreecommitdiff
path: root/net/trafshow
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-11 22:26:38 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-11 22:26:38 +0000
commit4b372dfdbba4ba9c582a8b9cef51ed2cb7ac7e13 (patch)
treec945f70ac0db0278b6da655bec44deeaae2ee59b /net/trafshow
parent66586dd1ca2e6b8b7e67fac03e4db2e907c524fe (diff)
downloadports-4b372dfdbba4ba9c582a8b9cef51ed2cb7ac7e13.tar.gz
ports-4b372dfdbba4ba9c582a8b9cef51ed2cb7ac7e13.zip
Update to 5.2.3
Notes
Notes: svn path=/head/; revision=159352
Diffstat (limited to 'net/trafshow')
-rw-r--r--net/trafshow/Makefile3
-rw-r--r--net/trafshow/distinfo6
-rw-r--r--net/trafshow/files/patch-show_dump.c26
-rw-r--r--net/trafshow/files/patch-trafshow.c21
4 files changed, 30 insertions, 26 deletions
diff --git a/net/trafshow/Makefile b/net/trafshow/Makefile
index a707cabce798..538fabe017f9 100644
--- a/net/trafshow/Makefile
+++ b/net/trafshow/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= trafshow
-PORTVERSION= 5.2.2
+PORTVERSION= 5.2.3
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.nsk.su/pub/RinetSoftware/
@@ -15,7 +15,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@FreeBSD.org
COMMENT= Full screen visualization of network traffic
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= trafshow
diff --git a/net/trafshow/distinfo b/net/trafshow/distinfo
index f24ce555ad45..1c2646042314 100644
--- a/net/trafshow/distinfo
+++ b/net/trafshow/distinfo
@@ -1,3 +1,3 @@
-MD5 (trafshow-5.2.2.tgz) = 6fbf6668b87415ff0baa75021204a264
-SHA256 (trafshow-5.2.2.tgz) = 7b6b014d9e67c9a09e66caa002208071d603067782c3b86e1ddb9a6aefe5ff25
-SIZE (trafshow-5.2.2.tgz) = 124191
+MD5 (trafshow-5.2.3.tgz) = 0b2f0bb23b7832138b7d841437b9e182
+SHA256 (trafshow-5.2.3.tgz) = ea7e22674a66afcc7174779d0f803c1f25b42271973b4f75fab293b8d7db11fc
+SIZE (trafshow-5.2.3.tgz) = 142615
diff --git a/net/trafshow/files/patch-show_dump.c b/net/trafshow/files/patch-show_dump.c
index 6e7fc4bbfc35..a6426d831122 100644
--- a/net/trafshow/files/patch-show_dump.c
+++ b/net/trafshow/files/patch-show_dump.c
@@ -1,5 +1,5 @@
---- show_dump.c.orig Mon Jul 12 07:21:09 2004
-+++ show_dump.c Wed Feb 1 18:07:01 2006
+--- show_dump.c.orig Wed Apr 12 00:16:51 2006
++++ show_dump.c Wed Apr 12 00:18:21 2006
@@ -21,6 +21,7 @@
#include <sys/param.h>
#include <sys/types.h>
@@ -12,20 +12,26 @@
bpf_u_int32 net;
bpf_u_int32 mask;
char name[100], buf[256];
-+ u_int v;
++ int v = 1;
/* sanity check */
if (!ph || !ns) return -1;
-@@ -141,6 +143,12 @@
+@@ -139,13 +141,16 @@
+ if (buf[0] != '\0')
+ screen_status("%s: %s", ph->name, buf);
if (!live_pcap) return -1;
+-#ifdef notdef
if (pcap_setnonblock(live_pcap, 1, buf) < 0) {
screen_status("%s: %s", ph->name, buf);
-+ show_dump_close();
-+ return -1;
-+ }
-+ v = 1;
-+ if (ioctl(pcap_fileno(live_pcap), BIOCIMMEDIATE, &v) < 0) {
-+ screen_status("%s: %s", ph->name, strerror(errno));
show_dump_close();
return -1;
}
+-#endif
++ if (ioctl(pcap_fileno(live_pcap), BIOCIMMEDIATE, &v) < 0) {
++ screen_status("%s: %s", ph->name, strerror(errno));
++ show_dump_close();
++ return -1;
++ }
+ /* setup filter expression */
+ if (pcap_lookupnet(strcpy(name, ph->name), &net, &mask, buf) < 0) {
+ /* ignore error */
diff --git a/net/trafshow/files/patch-trafshow.c b/net/trafshow/files/patch-trafshow.c
index a797fa9409fc..a5a92eaf6118 100644
--- a/net/trafshow/files/patch-trafshow.c
+++ b/net/trafshow/files/patch-trafshow.c
@@ -1,22 +1,22 @@
---- trafshow.c.orig Sun Jan 8 08:05:29 2006
-+++ trafshow.c Wed Feb 1 18:07:33 2006
+--- trafshow.c.orig Wed Apr 12 00:10:18 2006
++++ trafshow.c Wed Apr 12 00:12:49 2006
@@ -20,6 +20,7 @@
#endif
#include <sys/types.h>
#include <sys/socket.h>
+#include <sys/ioctl.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <signal.h>
-@@ -281,6 +282,7 @@
- pcap_t *pd;
+ #ifdef HAVE_PCAP_GET_SELECTABLE_FD
+ #include <sys/select.h>
+ #endif
+@@ -307,6 +308,7 @@
+ const pcap_addr_t *ap;
PCAP_HANDLER *ph, *ph_prev = 0;
- char buf[256];
-+ u_int v;
+ char *cp, buf[256];
++ int v = 1;
if (!ph_list) return -1;
-@@ -307,6 +309,13 @@
+@@ -334,6 +336,12 @@
}
if (pcap_setnonblock(pd, 1, buf) < 0) {
fprintf(stderr, "%s: %s\n", dp->name, buf);
@@ -24,7 +24,6 @@
+ err++;
+ continue;
+ }
-+ v = 1;
+ if (ioctl(pcap_fileno(pd), BIOCIMMEDIATE, &v) < 0) {
+ fprintf(stderr, "%s: %s\n", dp->name, strerror(errno));
pcap_close(pd);