aboutsummaryrefslogtreecommitdiff
path: root/net/tridiavnc
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-18 03:15:35 +0000
committerCy Schubert <cy@FreeBSD.org>2014-06-18 03:15:35 +0000
commit37d140fd8c0bdfefde374f725d9c19cb56878b33 (patch)
tree3c6e7f371ef10a16b229a2372302437740c59919 /net/tridiavnc
parentf838bf9e414cd7e402189fabcd309f0b6ca60f6e (diff)
downloadports-37d140fd8c0bdfefde374f725d9c19cb56878b33.tar.gz
ports-37d140fd8c0bdfefde374f725d9c19cb56878b33.zip
Support stage.
Fix build under clang. Relinquish maintainership.
Notes
Notes: svn path=/head/; revision=358201
Diffstat (limited to 'net/tridiavnc')
-rw-r--r--net/tridiavnc/Makefile34
-rw-r--r--net/tridiavnc/files/patch-Xvnc-lib-Xau-AuUnlock.c11
-rw-r--r--net/tridiavnc/files/patch-Xvnc-lib-font-Type1-regions.c11
-rw-r--r--net/tridiavnc/files/patch-Xvnc-lib-font-Type1-t1malloc.c20
-rw-r--r--net/tridiavnc/files/patch-Xvnc-lib-font-Type1-type1.c29
-rw-r--r--net/tridiavnc/files/patch-Xvnc-lib-font-bitmap-fontink.c18
-rw-r--r--net/tridiavnc/files/patch-Xvnc-programs-Xserver-hw-vnc-corre.c19
-rw-r--r--net/tridiavnc/files/patch-unix-vnc_unixsrc-vncpasswd-vncpasswd.c11
-rw-r--r--net/tridiavnc/pkg-plist1
9 files changed, 139 insertions, 15 deletions
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
index 9ca6d89af9d9..db3b3f9419b2 100644
--- a/net/tridiavnc/Makefile
+++ b/net/tridiavnc/Makefile
@@ -10,7 +10,7 @@ MASTER_SITE_SUBDIR=dwcjr
DISTNAME= DevVNC_unix
EXTRACT_SUFX= .tgz
-MAINTAINER= cy@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Display X and Win32 desktops on remote X/Win32/Java displays
LICENSE= GPLv2
@@ -26,22 +26,23 @@ MAKE_JOBS_UNSAFE=yes
CONFLICTS= tightvnc-[0-9]* vnc-[0-9]*
-.ifdef(TRIDIAVNC_BASE)
-PREFIX=${TRIDIAVNC_BASE}
-MAKE_ENV+= DESTDIR=${TRIDIAVNC_BASE}
-.endif
+# .ifdef(TRIDIAVNC_BASE)
+# PREFIX=${TRIDIAVNC_BASE}
+# MAKE_ENV+= DESTDIR=${TRIDIAVNC_BASE}
+# .endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != i386
BROKEN= Does not compile on ${MACHINE_ARCH}
-NO_XVNC= yes
PLIST_SUB+= XVNC="@comment "
.else
PLIST_SUB+= XVNC=""
.endif
+# XXX Broken under clang
+NO_XVNC= yes
+
post-patch:
.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def Xvnc/config/cf/Imake.tmpl
${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/${file}
@@ -53,14 +54,19 @@ post-patch:
# to do the install ourselves.
post-install:
.if !defined(NO_XVNC)
- ${INSTALL_PROGRAM} ${WRKSRC}/Xvnc/programs/Xserver/Xvnc ${PREFIX}/bin/Xvnc
+ ${INSTALL_PROGRAM} ${WRKSRC}/Xvnc/programs/Xserver/Xvnc \
+ ${STAGEDIR}${PREFIX}/bin/Xvnc
.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/vncviewer/vncviewer ${PREFIX}/bin/vncviewer
- ${INSTALL_PROGRAM} ${WRKSRC}/vncpasswd/vncpasswd ${PREFIX}/bin/vncpasswd
- ${INSTALL_PROGRAM} ${WRKSRC}/vncconnect/vncconnect ${PREFIX}/bin/vncconnect
- ${INSTALL_SCRIPT} ${WRKSRC}/vncserver ${PREFIX}/bin/vncserver
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncviewer/vncviewer \
+ ${STAGEDIR}${PREFIX}/bin/vncviewer
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncpasswd/vncpasswd \
+ ${STAGEDIR}${PREFIX}/bin/vncpasswd
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncconnect/vncconnect \
+ ${STAGEDIR}${PREFIX}/bin/vncconnect
+ ${INSTALL_SCRIPT} ${WRKSRC}/vncserver \
+ ${STAGEDIR}${PREFIX}/bin/vncserver
# Go install Java classes
- ${MKDIR} ${PREFIX}/share/vnc
- ${CP} -R ${WRKSRC}/classes ${PREFIX}/share/vnc
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/vnc
+ ${CP} -R ${WRKSRC}/classes ${STAGEDIR}${PREFIX}/share/vnc
.include <bsd.port.post.mk>
diff --git a/net/tridiavnc/files/patch-Xvnc-lib-Xau-AuUnlock.c b/net/tridiavnc/files/patch-Xvnc-lib-Xau-AuUnlock.c
new file mode 100644
index 000000000000..126574d42dde
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-lib-Xau-AuUnlock.c
@@ -0,0 +1,11 @@
+--- Xvnc/lib/Xau/AuUnlock.c.orig 2000-04-12 11:18:27.000000000 -0700
++++ Xvnc/lib/Xau/AuUnlock.c 2013-10-30 23:24:19.000000000 -0700
+@@ -44,7 +44,7 @@
+ char link_name[1025];
+
+ if (strlen (file_name) > 1022)
+- return;
++ return(0);
+ #ifndef WIN32
+ (void) strcpy (creat_name, file_name);
+ (void) strcat (creat_name, "-c");
diff --git a/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-regions.c b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-regions.c
new file mode 100644
index 000000000000..b04c2d1594f6
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-regions.c
@@ -0,0 +1,11 @@
+--- Xvnc/lib/font/Type1/regions.c.orig 2000-04-12 11:18:28.000000000 -0700
++++ Xvnc/lib/font/Type1/regions.c 2013-10-30 23:15:05.000000000 -0700
+@@ -1355,7 +1355,7 @@
+
+ beg = left->link;
+ if (beg == right)
+- return;
++ return(0);
+
+ for (p = beg; p != right; p = p->link) {
+ if (p->link == NULL && right != NULL)
diff --git a/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-t1malloc.c b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-t1malloc.c
new file mode 100644
index 000000000000..bd71ee6a5476
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-t1malloc.c
@@ -0,0 +1,20 @@
+--- Xvnc/lib/font/Type1/t1malloc.c.orig 2000-04-12 11:18:28.000000000 -0700
++++ Xvnc/lib/font/Type1/t1malloc.c 2013-10-30 23:14:26.000000000 -0700
+@@ -286,7 +286,7 @@
+ */
+ addr[0] = addr[size - 1] = size;
+ firstcombined = (struct freeblock *) addr;
+- return;
++ return(0);
+ }
+ /*
+ Otherwise, we unhook this pointer from the chain:
+@@ -657,7 +657,7 @@
+ register struct freeblock *p; /* pointer to block */
+
+ if (area == NULL)
+- return;
++ return (0);
+ wholesize = - *area++;
+ wholesize -= 2;
+
diff --git a/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-type1.c b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-type1.c
new file mode 100644
index 000000000000..f5e9d77ce571
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-lib-font-Type1-type1.c
@@ -0,0 +1,29 @@
+--- Xvnc/lib/font/Type1/type1.c.orig 2000-04-12 11:18:29.000000000 -0700
++++ Xvnc/lib/font/Type1/type1.c 2013-10-30 23:48:25.000000000 -0700
+@@ -886,7 +886,7 @@
+ if (!DoRead(&Code4)) goto ended;
+ Push((double)((((((Code1<<8) + Code2)<<8) + Code3)<<8) + Code4));
+ }
+- return;
++ return(0);
+
+ ended: Error0("Decode: Premature end of Type 1 CharString");
+ }
+@@ -1321,7 +1321,7 @@
+ for (;;) {
+ if (!DoRead(&Code)) break;
+ Decode(Code);
+- if (errflag) return;
++ if (errflag) return(0);
+ }
+ /* Copy snapped path to mypath and set path to NULL as above. */
+ mypath = Snap(path);
+@@ -1344,7 +1344,7 @@
+ for (;;) {
+ if (!DoRead(&Code)) break;
+ Decode(Code);
+- if (errflag) return;
++ if (errflag) return(0);
+ }
+ path = Join(mypath, path);
+ }
diff --git a/net/tridiavnc/files/patch-Xvnc-lib-font-bitmap-fontink.c b/net/tridiavnc/files/patch-Xvnc-lib-font-bitmap-fontink.c
new file mode 100644
index 000000000000..aaf562659dbb
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-lib-font-bitmap-fontink.c
@@ -0,0 +1,18 @@
+--- Xvnc/lib/font/bitmap/fontink.c.orig 2000-04-12 11:18:29.000000000 -0700
++++ Xvnc/lib/font/bitmap/fontink.c 2013-10-30 23:18:04.000000000 -0700
+@@ -94,7 +94,7 @@
+ pInk->rightSideBearing = leftBearing;
+ pInk->ascent = 0;
+ pInk->descent = 0;
+- return;
++ return(0);
+ found_ascent:
+ pInk->ascent = vpos - descent + 1;
+
+@@ -215,5 +215,5 @@
+ out_line += out_bytes;
+ }
+ }
+- return;
++ return(0);
+ }
diff --git a/net/tridiavnc/files/patch-Xvnc-programs-Xserver-hw-vnc-corre.c b/net/tridiavnc/files/patch-Xvnc-programs-Xserver-hw-vnc-corre.c
new file mode 100644
index 000000000000..a2baf09ace8d
--- /dev/null
+++ b/net/tridiavnc/files/patch-Xvnc-programs-Xserver-hw-vnc-corre.c
@@ -0,0 +1,19 @@
+--- Xvnc/programs/Xserver/hw/vnc/corre.c.orig 2000-04-12 11:18:32.000000000 -0700
++++ Xvnc/programs/Xserver/hw/vnc/corre.c 2013-10-30 23:32:20.000000000 -0700
+@@ -63,14 +63,14 @@
+ rfbSendRectEncodingCoRRE(cl, x, y, w, cl->correMaxHeight );
+ rfbSendRectEncodingCoRRE(cl, x, y + cl->correMaxHeight, w,
+ h - cl->correMaxHeight);
+- return;
++ return(0);
+ }
+
+ if (w > cl->correMaxWidth) {
+ rfbSendRectEncodingCoRRE(cl, x, y, cl->correMaxWidth, h);
+ rfbSendRectEncodingCoRRE(cl, x + cl->correMaxWidth, y,
+ w - cl->correMaxWidth, h);
+- return;
++ return(0);
+ }
+
+ rfbSendSmallRectEncodingCoRRE(cl, x, y, w, h);
diff --git a/net/tridiavnc/files/patch-unix-vnc_unixsrc-vncpasswd-vncpasswd.c b/net/tridiavnc/files/patch-unix-vnc_unixsrc-vncpasswd-vncpasswd.c
new file mode 100644
index 000000000000..8a94047b5924
--- /dev/null
+++ b/net/tridiavnc/files/patch-unix-vnc_unixsrc-vncpasswd-vncpasswd.c
@@ -0,0 +1,11 @@
+--- vncpasswd/vncpasswd.c.orig 2000-04-12 11:18:36.000000000 -0700
++++ vncpasswd/vncpasswd.c 2013-10-30 22:56:22.000000000 -0700
+@@ -84,7 +84,7 @@
+ }
+ for (i = 0; i < strlen(passwd); i++)
+ passwd[i] = passwd1[i] = '\0';
+- return;
++ return (0);
+ }
+
+ fprintf(stderr,"They don't match. Try again.\n\n");
diff --git a/net/tridiavnc/pkg-plist b/net/tridiavnc/pkg-plist
index c4aff02ae775..3c31c96a0b20 100644
--- a/net/tridiavnc/pkg-plist
+++ b/net/tridiavnc/pkg-plist
@@ -1,4 +1,3 @@
-%%XVNC%%bin/Xvnc
bin/vncviewer
bin/vncpasswd
bin/vncserver