aboutsummaryrefslogtreecommitdiff
path: root/net/tsclient
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-12-11 19:22:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-12-11 19:22:26 +0000
commit81a6ee5f75d11c12e38234301aa29ff5cc512627 (patch)
tree8a82b42024fea3f31914bbc9cbef6c0e82bd52cb /net/tsclient
parenta74febde07aa3857620d5270567aa3561a47cbe3 (diff)
downloadports-81a6ee5f75d11c12e38234301aa29ff5cc512627.tar.gz
ports-81a6ee5f75d11c12e38234301aa29ff5cc512627.zip
- Update to 0.150
- Change MASTER_SITES and WWW to point to new project page at sourceforge - Add USE_GETTEXT since it installs intl files - OPTIONS'ify - Install some docs - Add an OPTION GNOME, on by default, adding the possibility to make tsclient without a lot of gnome dependencies, just depending of gtk20 - Remove some patches and use REINPLACE_CMD - Use autotools to fix a build problem on this version PR: ports/118042 Approved by: maintainer
Notes
Notes: svn path=/head/; revision=202956
Diffstat (limited to 'net/tsclient')
-rw-r--r--net/tsclient/Makefile55
-rw-r--r--net/tsclient/distinfo6
-rw-r--r--net/tsclient/files/patch-Makefile.in20
-rw-r--r--net/tsclient/files/patch-configure27
-rw-r--r--net/tsclient/pkg-descr2
-rw-r--r--net/tsclient/pkg-plist11
6 files changed, 49 insertions, 72 deletions
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index efb11d77288a..cd34add808cf 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -6,45 +6,64 @@
#
PORTNAME= tsclient
-PORTVERSION= 0.148
-PORTREVISION= 3
+PORTVERSION= 0.150
CATEGORIES= net gnome
-MASTER_SITES= http://www.gnomepro.com/tsclient/
+MASTER_SITES= SF
MAINTAINER= ports@thepentagon.org
COMMENT= A GNOME 2 frontend for rdesktop and vncviewer
RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
-.ifdef (WITH_TIGHTVNC)
-RUN_DEPENDS+= vncviewer:${PORTSDIR}/net/tightvnc
-.endif
-
-.ifdef (WITH_XNEST)
-RUN_DEPENDS+= Xnest:${X_NESTSERVER_PORT}
-.endif
+OPTIONS= GNOME "Build with gnome support" on \
+ TIGHTVNC "vncviewer support" off \
+ XNEST "X via Xnest support (experimental)" off
+USE_AUTOTOOLS= libtool:15 automake:19 autoconf:261
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui
+USE_GNOME= gtk20
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= tsclient.1
+PORTDOCS= COPYING NEWS README
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GNOME)
+USE_GNOME+= gnomeprefix gnomehack libgnomeui
+.else
+CONFIGURE_ARGS+= --disable-gnome
+.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " set WITH_TIGHTVNC for vncviewer support"
- @${ECHO_MSG} " set WITH_XNEST for X via Xnest support (experimental)"
- @${ECHO_MSG} ""
+.if defined(WITH_TIGHTVNC)
+RUN_DEPENDS+= vncviewer:${PORTSDIR}/net/tightvnc
+.endif
+
+.if defined(WITH_XNEST)
+RUN_DEPENDS+= Xnest:${X_NESTSERVER_PORT}
+.endif
post-patch:
+ @${REINPLACE_CMD} -e '/applet/d' \
+ ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/ s,applet ,,g' \
+ -e '/^man1dir *=/ s,datadir,prefix,g' \
+ ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/aclocal.m4
post-install:
@${LN} -sf ${PREFIX}/share/pixmaps/tsclient/tsclient.png \
${PREFIX}/share/pixmaps/tsclient.png
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+. endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tsclient/distinfo b/net/tsclient/distinfo
index ebcff784c44b..d4639de94845 100644
--- a/net/tsclient/distinfo
+++ b/net/tsclient/distinfo
@@ -1,3 +1,3 @@
-MD5 (tsclient-0.148.tar.gz) = 06a6ff59b7c8ca26d4ea37340ed77423
-SHA256 (tsclient-0.148.tar.gz) = 8d045530a5f1dd38e809162047a5806ad38c2e2d5d685d5b90b965780b4ffca6
-SIZE (tsclient-0.148.tar.gz) = 490745
+MD5 (tsclient-0.150.tar.gz) = 1dc95fbdbcf4344d05114e1f43bf32ea
+SHA256 (tsclient-0.150.tar.gz) = 7dbcad13d98c45a4365dffb3d775be89f49d4e27e139aeaf028e9cd4a41a3ae1
+SIZE (tsclient-0.150.tar.gz) = 495975
diff --git a/net/tsclient/files/patch-Makefile.in b/net/tsclient/files/patch-Makefile.in
deleted file mode 100644
index e2a24a67a239..000000000000
--- a/net/tsclient/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.bak Sun Oct 8 03:03:52 2006
-+++ Makefile.in Sun Oct 8 03:04:10 2006
-@@ -145,7 +145,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
-
--SUBDIRS = src applet po
-+SUBDIRS = src po
-
- appicondir = $(datadir)/pixmaps
- appicon_DATA = tsclient.png
-@@ -161,7 +161,7 @@
- mime_DATA = tsclient.mime tsclient.keys
-
- man1_MANS = tsclient.1
--man1dir = $(datadir)/man/man1
-+man1dir = $(prefix)/man/man1
-
- intlfiles = intltool-extract.in intltool-merge.in intltool-update.in
-
diff --git a/net/tsclient/files/patch-configure b/net/tsclient/files/patch-configure
deleted file mode 100644
index 546df4855eca..000000000000
--- a/net/tsclient/files/patch-configure
+++ /dev/null
@@ -1,27 +0,0 @@
---- configure. Fri Oct 13 03:55:18 2006
-+++ configure Fri Oct 13 03:55:40 2006
-@@ -4198,7 +4198,6 @@
-
-
- pkg_modules="libgnomeui-2.0"
--pkg_modules="libpanelapplet-2.0"
-
- succeeded=no
-
-@@ -5614,7 +5613,7 @@
- fi
-
-
-- ac_config_files="$ac_config_files Makefile src/Makefile applet/Makefile po/Makefile.in"
-+ ac_config_files="$ac_config_files Makefile src/Makefile po/Makefile.in"
- cat >confcache <<\_ACEOF
- # This file is a shell script that caches the results of configure
- # tests run on this system so they can be shared between configure
-@@ -6188,7 +6187,6 @@
- # Handling of arguments.
- "Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
- "src/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
-- "applet/Makefile" ) CONFIG_FILES="$CONFIG_FILES applet/Makefile" ;;
- "po/Makefile.in" ) CONFIG_FILES="$CONFIG_FILES po/Makefile.in" ;;
- "default-1" ) CONFIG_COMMANDS="$CONFIG_COMMANDS default-1" ;;
- "depfiles" ) CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
diff --git a/net/tsclient/pkg-descr b/net/tsclient/pkg-descr
index ec1c6d3ce5ea..8f9e943ccf8b 100644
--- a/net/tsclient/pkg-descr
+++ b/net/tsclient/pkg-descr
@@ -1,4 +1,4 @@
Tsclient is a GNOME 2 frontend for rdesktop, and also supports VNC clients,
Citrix ICA client (experimental) and X via Xnest (experimental).
-WWW: http://www.gnomepro.com/tsclient/
+WWW: http://sourceforge.net/projects/tsclient/
diff --git a/net/tsclient/pkg-plist b/net/tsclient/pkg-plist
index c4903907074f..07577d8a136e 100644
--- a/net/tsclient/pkg-plist
+++ b/net/tsclient/pkg-plist
@@ -7,6 +7,7 @@ share/pixmaps/tsclient.png
share/pixmaps/tsclient/banner-ar.png
share/pixmaps/tsclient/banner-en.png
share/pixmaps/tsclient/banner-es.png
+share/pixmaps/tsclient/banner-he.png
share/pixmaps/tsclient/banner-hu.png
share/pixmaps/tsclient/banner-ja.png
share/pixmaps/tsclient/banner-ms.png
@@ -34,6 +35,7 @@ share/locale/es/LC_MESSAGES/tsclient.mo
share/locale/fi/LC_MESSAGES/tsclient.mo
share/locale/fr/LC_MESSAGES/tsclient.mo
share/locale/gr/LC_MESSAGES/tsclient.mo
+share/locale/he/LC_MESSAGES/tsclient.mo
share/locale/hu/LC_MESSAGES/tsclient.mo
share/locale/id/LC_MESSAGES/tsclient.mo
share/locale/it/LC_MESSAGES/tsclient.mo
@@ -47,20 +49,23 @@ share/locale/pl_PL/LC_MESSAGES/tsclient.mo
share/locale/pt_BR/LC_MESSAGES/tsclient.mo
share/locale/pt_PT/LC_MESSAGES/tsclient.mo
share/locale/ru/LC_MESSAGES/tsclient.mo
-share/locale/se/LC_MESSAGES/tsclient.mo
+share/locale/sv/LC_MESSAGES/tsclient.mo
share/locale/tr/LC_MESSAGES/tsclient.mo
share/locale/xh/LC_MESSAGES/tsclient.mo
share/locale/zh_CN/LC_MESSAGES/tsclient.mo
+share/locale/zh_HK/LC_MESSAGES/tsclient.mo
share/locale/zh_TW/LC_MESSAGES/tsclient.mo
+@dirrmtry share/application-registry
@dirrmtry share/locale/gr/LC_MESSAGES
@dirrmtry share/locale/gr
@dirrmtry share/locale/nl_NL/LC_MESSAGES
@dirrmtry share/locale/nl_NL
@dirrmtry share/locale/pl_PL/LC_MESSAGES
@dirrmtry share/locale/pl_PL
-@dirrmtry share/locale/se/LC_MESSAGES
-@dirrmtry share/locale/se
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/mime-info
@dirrm share/pixmaps/tsclient
@dirrmtry share/applications