aboutsummaryrefslogtreecommitdiff
path: root/net/tsocks
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-05-30 16:31:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-05-30 16:31:38 +0000
commite9a96e42571219a010a4be078bb765d4ca446e17 (patch)
tree1771cb51992be4ce247f5d59649072c116201ab7 /net/tsocks
parentb79011506da6a00403697c4f69f8bac798a5932a (diff)
downloadports-e9a96e42571219a010a4be078bb765d4ca446e17.tar.gz
ports-e9a96e42571219a010a4be078bb765d4ca446e17.zip
tsocks(8) suggests the the following line (twice):
LD_PRELOAD=/usr/local/lib/tsocks/libtsocks.so This is wrong, because the library is installed under regular path, without the `tsocks' subdirectory. Fix the manpage accordingly. Notified by: danfe MFH: 2019Q2
Notes
Notes: svn path=/head/; revision=503074
Diffstat (limited to 'net/tsocks')
-rw-r--r--net/tsocks/Makefile5
-rw-r--r--net/tsocks/files/patch-tsocks.816
2 files changed, 11 insertions, 10 deletions
diff --git a/net/tsocks/Makefile b/net/tsocks/Makefile
index 137dd3b2b81a..1deeaa2d4c69 100644
--- a/net/tsocks/Makefile
+++ b/net/tsocks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tsocks
DISTVERSION= 1.8.b5
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.8%20beta%205 \
http://ftp1.sourceforge.net/tsocks/ \
@@ -15,10 +15,11 @@ COMMENT= Allow non SOCKS aware applications to use SOCKS without modification
LICENSE= GPLv2
-GNU_CONFIGURE= yes
USES= gmake
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b.*//}
CONFIGURE_ARGS= --with-conf=${PREFIX}/etc/tsocks.conf \
diff --git a/net/tsocks/files/patch-tsocks.8 b/net/tsocks/files/patch-tsocks.8
index 2cdedb0c75d0..ec1b8ae3ff1c 100644
--- a/net/tsocks/files/patch-tsocks.8
+++ b/net/tsocks/files/patch-tsocks.8
@@ -25,17 +25,17 @@
+Bash, Ksh and Bourne shell \-
-export LD_PRELOAD=/lib/libtsocks.so
-+export LD_PRELOAD=/usr/local/lib/tsocks/libtsocks.so
++export LD_PRELOAD=/usr/local/lib/libtsocks.so
-C Shell -
+C Shell \-
-setenv LD_PRELOAD=/lib/libtsocks.so
-+setenv LD_PRELOAD=/usr/local/lib/tsocks/libtsocks.so
++setenv LD_PRELOAD=/usr/local/lib/libtsocks.so
This process can be automated (for Bash, Bourne and Korn shell
users) for a single command or for all commands in a shell session
-@@ -30,13 +29,12 @@ automatically use it, a very useful conf
+@@ -30,13 +29,12 @@ automatically use it, a very useful configuration. For
information on this configuration see the CAVEATS section of this
manual page.
@@ -51,7 +51,7 @@
it is not, the library redirects the connection to a SOCKS server
specified in the configuration file. It then negotiates that connection
with the SOCKS server and passes the connection back to the calling
-@@ -52,42 +50,42 @@ the SOCKSified TCP/IP stacks seen on oth
+@@ -52,42 +50,42 @@ the SOCKSified TCP/IP stacks seen on other platforms.
Most arguments to
.BR tsocks
are provided in the configuration file (the location of which is defined
@@ -104,7 +104,7 @@
.I TSOCKS_USERNAME
This environment variable can be used to specify the username to be used when
version 5 SOCKS servers request username/password authentication. This
-@@ -95,7 +93,7 @@ overrides the default username that can
+@@ -95,7 +93,7 @@ overrides the default username that can be specified i
file using 'default_user', see tsocks.conf(8) for more information. This
variable is ignored for version 4 SOCKS servers.
@@ -113,7 +113,7 @@
.I TSOCKS_PASSWORD
This environment variable can be used to specify the password to be used when
version 5 SOCKS servers request username/password authentication. This
-@@ -115,11 +113,12 @@ consult the INSTALL file for more inform
+@@ -115,11 +113,12 @@ consult the INSTALL file for more information.
.BR tsocks
will generate error messages and print them to stderr when there are
problems with the configuration file or the SOCKS negotiation with the
@@ -128,7 +128,7 @@
.BR tsocks
will not in the above configuration be able to provide SOCKS proxying to
setuid applications or applications that are not run from a shell. You can
-@@ -132,8 +131,7 @@ the INSTALL file for more info). THIS I
+@@ -132,8 +131,7 @@ the INSTALL file for more info). THIS IS A ***WARNING
careful. Also be sure the library is in the root filesystem as all hell
will break loose if the directory it is in is not available at boot time.
@@ -138,7 +138,7 @@
.BR tsocks
can only proxy outgoing TCP connections
-@@ -157,21 +155,21 @@ not. This introduces overhead and should
+@@ -157,21 +155,21 @@ not. This introduces overhead and should only be used
.BR tsocks
uses ELF dynamic loader features to intercept dynamic function calls from
programs in which it is embedded. As a result, it cannot trace the