aboutsummaryrefslogtreecommitdiff
path: root/net/u6rd
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2017-10-09 17:25:02 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2017-10-09 17:25:02 +0000
commitd4c2a24ef8c9330228971b1e92499e38e9fbb1a7 (patch)
tree7a6330a0f2992cb36faec1e7ca58416f35c4b7fa /net/u6rd
parent0f3c68c4a0ffaa436f6e1382e1b3aa9e7ec3eca3 (diff)
downloadports-d4c2a24ef8c9330228971b1e92499e38e9fbb1a7.tar.gz
ports-d4c2a24ef8c9330228971b1e92499e38e9fbb1a7.zip
follow raw socket behaviour change on 11 and later.
Submitted by: guido
Notes
Notes: svn path=/head/; revision=451626
Diffstat (limited to 'net/u6rd')
-rw-r--r--net/u6rd/Makefile2
-rw-r--r--net/u6rd/files/patch-main.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/net/u6rd/Makefile b/net/u6rd/Makefile
index 203e24e500b4..c94f580033e9 100644
--- a/net/u6rd/Makefile
+++ b/net/u6rd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= u6rd
PORTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://ftp.scythe.jp/pub/u6rd/release/
diff --git a/net/u6rd/files/patch-main.c b/net/u6rd/files/patch-main.c
new file mode 100644
index 000000000000..c46e92bb392e
--- /dev/null
+++ b/net/u6rd/files/patch-main.c
@@ -0,0 +1,12 @@
+--- main.c.orig 2013-06-19 11:23:58 UTC
++++ main.c
+@@ -608,7 +608,8 @@ tun2raw(struct connection *c)
+ ip4 = (struct ipv4_header *)(buf - sizeof(*ip4));
+ ip4->ver_hlen = 4 << 4 | sizeof(*ip4) >> 2;
+ ip4->tos = ntohl(ip6->ver_class_label) >> 20 & 0xff;
+-#if defined(__OpenBSD__) || defined(__linux__)
++#if defined(__OpenBSD__) || defined(__linux__) || \
++ (defined(__FreeBSD__) && __FreeBSD_version >= 1100030)
+ ip4->len = htons(len + sizeof(*ip4));
+ #else
+ ip4->len = len + sizeof(*ip4);