aboutsummaryrefslogtreecommitdiff
path: root/net/ucarp/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-06 18:24:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-06 18:24:58 +0000
commit0e69d6c22d200466ebd5a22b3430ecb58c165b61 (patch)
tree1de73205a462489ce1b7ba3a9fcca45022ab2173 /net/ucarp/Makefile
parent96bbb5fd3012633e2f41e8fe1de5de6a1f6e8798 (diff)
downloadports-0e69d6c22d200466ebd5a22b3430ecb58c165b61.tar.gz
ports-0e69d6c22d200466ebd5a22b3430ecb58c165b61.zip
UCARP allows a couple of hosts to share common virtual IP addresses in order to
provide automatic failover. It is a portable userland implementation of the secure and patent-free Common Address Redundancy Protocol (CARP, OpenBSD's alternative to the VRRP). PR: ports/80696 Submitted by: Meno Abels <meno.abels@adviser.com>
Notes
Notes: svn path=/head/; revision=134725
Diffstat (limited to 'net/ucarp/Makefile')
-rw-r--r--net/ucarp/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/ucarp/Makefile b/net/ucarp/Makefile
new file mode 100644
index 000000000000..c08b91eba90b
--- /dev/null
+++ b/net/ucarp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ucarp
+# Date created: 2005-05-06
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucarp
+PORTVERSION= 1.1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.ucarp.org/pub/ucarp/
+
+MAINTAINER= meno.abels@adviser.com
+COMMENT= Userlevel Common Address Redundancy Protocol
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-nls
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= sbin/ucarp
+
+.include <bsd.port.mk>