aboutsummaryrefslogtreecommitdiff
path: root/net/udt
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-06-09 22:39:42 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-06-09 22:39:42 +0000
commit515b425fac63d3928f591f11c3007bd319567421 (patch)
tree1eb1b535963fc772461126c89c9f1203e0baf613 /net/udt
parent1159e936426eee4fe80b19af57829584261b16ce (diff)
downloadports-515b425fac63d3928f591f11c3007bd319567421.tar.gz
ports-515b425fac63d3928f591f11c3007bd319567421.zip
Support staging. Convert from NOPORTDOCS to the new way...
Notes
Notes: svn path=/head/; revision=357214
Diffstat (limited to 'net/udt')
-rw-r--r--net/udt/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net/udt/Makefile b/net/udt/Makefile
index a20f3f0a06fa..570eeaa3f0bd 100644
--- a/net/udt/Makefile
+++ b/net/udt/Makefile
@@ -18,8 +18,8 @@ EXTRACT_AFTER_ARGS= --exclude '*md5*' \
--exclude udt${PORTVERSION:R}/win
USE_LDCONFIG= yes
UDT_APPS= appclient appserver recvfile sendfile test
+USES= uidfix
-NO_STAGE= yes
post-build:
# Building sample applications:
.for a in ${UDT_APPS}
@@ -27,13 +27,15 @@ post-build:
-I${WRKSRC} -L${WRKSRC} -ludt
.endfor
+.include <bsd.port.options.mk>
+
post-install:
# Installing sample applications:
- ${INSTALL_PROGRAM} ${UDT_APPS:S|^|${WRKSRC:H}/app/udt-|} ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+ ${INSTALL_PROGRAM} ${UDT_APPS:S|^|${WRKSRC:H}/app/udt-|} ${STAGEDIR}${PREFIX}/bin/
+.if ${PORT_OPTIONS:MDOCS}
# Installing documentation tree into ${DOCSDIR}
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC:H}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
+ cd ${WRKSRC:H}/doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.else
EXTRACT_AFTER_ARGS+= --exclude udt${PORTVERSION:R}/doc
.endif