aboutsummaryrefslogtreecommitdiff
path: root/net/udt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-24 21:19:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-24 21:19:54 +0000
commiteacc1237d72afac2ffe53a01f1a8ee6b7386473d (patch)
tree95bf476c02b1e260fd8daaaedbfa3f32b31f6aae /net/udt
parente5ad754afb58c6c76cbeb5e1c084b218ce1d1d94 (diff)
downloadports-eacc1237d72afac2ffe53a01f1a8ee6b7386473d.tar.gz
ports-eacc1237d72afac2ffe53a01f1a8ee6b7386473d.zip
- Switch to options helpers
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=397766
Diffstat (limited to 'net/udt')
-rw-r--r--net/udt/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net/udt/Makefile b/net/udt/Makefile
index b2a5069ed8dc..0bc7b7182f32 100644
--- a/net/udt/Makefile
+++ b/net/udt/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= C++ library containing the UDT API implementation
PATCH_WRKSRC= ${WRKDIR}/udt${PORTVERSION:R}
-WRKSRC= ${PATCH_WRKSRC}/src
+WRKSRC= ${PATCH_WRKSRC}/src
MAKEFILE= ${FILESDIR}/BSDmakefile
EXTRACT_AFTER_ARGS= --exclude '*md5*' \
--exclude udt${PORTVERSION:R}/win
@@ -22,6 +22,8 @@ USES= uidfix
OPTIONS_DEFINE= DOCS
+DOCS_VARS_OFF= EXTRACT_AFTER_ARGS+="--exclude udt${PORTVERSION:R}/doc"
+
post-build:
# Building sample applications:
.for a in ${UDT_APPS}
@@ -29,17 +31,13 @@ post-build:
-I${WRKSRC} -L${WRKSRC} -ludt -pthread
.endfor
-.include <bsd.port.options.mk>
-
post-install:
# Installing sample applications:
${INSTALL_PROGRAM} ${UDT_APPS:S|^|${WRKSRC:H}/app/udt-|} ${STAGEDIR}${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
# Installing documentation tree into ${DOCSDIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC:H}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-.else
-EXTRACT_AFTER_ARGS+= --exclude udt${PORTVERSION:R}/doc
-.endif
.include <bsd.port.mk>