aboutsummaryrefslogtreecommitdiff
path: root/net/uhttpmock
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /net/uhttpmock
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'net/uhttpmock')
-rw-r--r--net/uhttpmock/Makefile26
-rw-r--r--net/uhttpmock/distinfo2
-rw-r--r--net/uhttpmock/pkg-descr5
-rw-r--r--net/uhttpmock/pkg-plist37
4 files changed, 70 insertions, 0 deletions
diff --git a/net/uhttpmock/Makefile b/net/uhttpmock/Makefile
new file mode 100644
index 000000000000..b8da40cec2e0
--- /dev/null
+++ b/net/uhttpmock/Makefile
@@ -0,0 +1,26 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/net/uhttpmock/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= uhttpmock
+PORTVERSION= 0.3.1
+PORTREVISION= 1
+CATEGORIES= net gnome
+MASTER_SITES= http://tecnocode.co.uk/downloads/uhttpmock/
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= HTTP web service mocking library for GNOME
+
+BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common \
+ vapigen:${PORTSDIR}/lang/vala \
+ gtkdoc-rebase:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+
+USES= gettext gmake libtool pathfix pkgconfig
+USE_GNOME= gnomeprefix gtk20 introspection:build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/net/uhttpmock/distinfo b/net/uhttpmock/distinfo
new file mode 100644
index 000000000000..f5759ca20642
--- /dev/null
+++ b/net/uhttpmock/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/uhttpmock-0.3.1.tar.gz) = 94825912b02ed679ec5ae70f5b59f2428fce062ebd08a5fd1afc51a59c7fb727
+SIZE (gnome3/uhttpmock-0.3.1.tar.gz) = 286132
diff --git a/net/uhttpmock/pkg-descr b/net/uhttpmock/pkg-descr
new file mode 100644
index 000000000000..79ae8f84b1d1
--- /dev/null
+++ b/net/uhttpmock/pkg-descr
@@ -0,0 +1,5 @@
+uhttpmock is a HTTP web service mocking project for projects
+which use libsoup. It is still in its infancy, but is
+already used by https://wiki.gnome.org/libgdata for unit testing.
+
+WWW: https://gitorious.org/uhttpmock
diff --git a/net/uhttpmock/pkg-plist b/net/uhttpmock/pkg-plist
new file mode 100644
index 000000000000..548d9fa6f485
--- /dev/null
+++ b/net/uhttpmock/pkg-plist
@@ -0,0 +1,37 @@
+include/libuhttpmock-0.0/uhttpmock/uhm-resolver.h
+include/libuhttpmock-0.0/uhttpmock/uhm-server.h
+include/libuhttpmock-0.0/uhttpmock/uhm-version.h
+include/libuhttpmock-0.0/uhttpmock/uhm.h
+lib/girepository-1.0/Uhm-0.0.typelib
+lib/libuhttpmock-0.0.a
+lib/libuhttpmock-0.0.so
+lib/libuhttpmock-0.0.so.0
+lib/libuhttpmock-0.0.so.0.1.1
+libdata/pkgconfig/libuhttpmock-0.0.pc
+share/doc/libuhttpmock-0.0/UhmResolver.html
+share/doc/libuhttpmock-0.0/UhmServer.html
+share/doc/libuhttpmock-0.0/annotation-glossary.html
+share/doc/libuhttpmock-0.0/api-index-deprecated.html
+share/doc/libuhttpmock-0.0/api-index-full.html
+share/doc/libuhttpmock-0.0/ch01.html
+share/doc/libuhttpmock-0.0/ch02.html
+share/doc/libuhttpmock-0.0/home.png
+share/doc/libuhttpmock-0.0/index.html
+share/doc/libuhttpmock-0.0/index.sgml
+share/doc/libuhttpmock-0.0/ix03.html
+share/doc/libuhttpmock-0.0/ix04.html
+share/doc/libuhttpmock-0.0/left-insensitive.png
+share/doc/libuhttpmock-0.0/left.png
+share/doc/libuhttpmock-0.0/libuhttpmock-0.0-Version-Information.html
+share/doc/libuhttpmock-0.0/libuhttpmock-0.0.devhelp2
+share/doc/libuhttpmock-0.0/pt01.html
+share/doc/libuhttpmock-0.0/pt02.html
+share/doc/libuhttpmock-0.0/pt03.html
+share/doc/libuhttpmock-0.0/right-insensitive.png
+share/doc/libuhttpmock-0.0/right.png
+share/doc/libuhttpmock-0.0/style.css
+share/doc/libuhttpmock-0.0/up-insensitive.png
+share/doc/libuhttpmock-0.0/up.png
+share/gir-1.0/Uhm-0.0.gir
+share/vala/vapi/libuhttpmock-0.0.deps
+share/vala/vapi/libuhttpmock-0.0.vapi