aboutsummaryrefslogtreecommitdiff
path: root/net/unison
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-30 12:52:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-30 12:52:16 +0000
commit7a98df2288890e1dc47f0630b3072f8e028b6d5c (patch)
tree64f47d20ea110e5b69a98e2dfbf50daed7debc0c /net/unison
parent3c2958a62b5d4a0b838919dcab2727c20d4ab7e2 (diff)
downloadports-7a98df2288890e1dc47f0630b3072f8e028b6d5c.tar.gz
ports-7a98df2288890e1dc47f0630b3072f8e028b6d5c.zip
- Allow build with older version of ocaml too
PR: ports/69695 Submitted by: Dan Pelleg <daniel+gnats@pelleg.org> (maintainer)
Notes
Notes: svn path=/head/; revision=115082
Diffstat (limited to 'net/unison')
-rw-r--r--net/unison/Makefile11
-rw-r--r--net/unison/files/ocaml-external-patch-ab13
2 files changed, 24 insertions, 0 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index b3de6afbdb4c..149126354848 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= daniel+unison@pelleg.org
COMMENT= A user-level file synchronization tool
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+PATCH_DEPENDS= ${BUILD_DEPENDS}
USE_GMAKE= yes
MAKE_ARGS= UISTYLE=text CFLAGS=""
@@ -28,6 +29,16 @@ EXTRA_DOCS= unison-manual.dvi unison-manual.html \
unison-manual.pdf unison-manual.ps
.endif
+pre-patch:
+ @if [ `ocamlc -version | ${SED} -e s/\\\.//g -e s/\\\+.*//` -gt 307 ] ; then \
+ if ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/ocaml-external-patch-ab ; then \
+ ${TRUE} ; \
+ else \
+ ${ECHO_MSG} ">> Patch ocaml-external-patch-ab failed to apply cleanly." ; \
+ ${FALSE} ; \
+ fi; \
+ fi
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/unison
.if !defined(NOPORTDOCS)
diff --git a/net/unison/files/ocaml-external-patch-ab b/net/unison/files/ocaml-external-patch-ab
new file mode 100644
index 000000000000..247ae274f9f7
--- /dev/null
+++ b/net/unison/files/ocaml-external-patch-ab
@@ -0,0 +1,13 @@
+--- ubase/uprintf.ml.orig Thu Jul 29 22:50:35 2004
++++ ubase/uprintf.ml Thu Jul 29 22:51:55 2004
+@@ -10,8 +10,8 @@
+ (* *)
+ (***********************************************************************)
+
+-external format_int: string -> int -> string = "format_int"
+-external format_float: string -> float -> string = "format_float"
++external format_int: string -> int -> string = "caml_format_int"
++external format_float: string -> float -> string = "caml_format_float"
+
+ let fprintf outchan doafter format =
+ let format = (Obj.magic format : string) in