aboutsummaryrefslogtreecommitdiff
path: root/net/urlendec
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-15 04:46:47 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-15 04:46:47 +0000
commit9daeddc93bb199f8b7e6f09543301c8d634c63a9 (patch)
tree8c16df1f8790c8d55de43e6693906a04694622b9 /net/urlendec
parente0636c6184e7eaf1878fe0204e0349fc97a17f77 (diff)
downloadports-9daeddc93bb199f8b7e6f09543301c8d634c63a9.tar.gz
ports-9daeddc93bb199f8b7e6f09543301c8d634c63a9.zip
- Unbreak the port by assembling and linking this 32-bit code
correctly so it works on both amd64 and i386 - Amend COMMENT to be more specific, add LICENSE (BSD2CLAUSE) - Convert to PLIST_FILES/PORTDOCS and drop four-line pkg-plist - Install documentation files in the dedicated helper target - Extend the port description and fix a minor typo while here
Notes
Notes: svn path=/head/; revision=568428
Diffstat (limited to 'net/urlendec')
-rw-r--r--net/urlendec/Makefile28
-rw-r--r--net/urlendec/pkg-descr7
-rw-r--r--net/urlendec/pkg-plist4
3 files changed, 24 insertions, 15 deletions
diff --git a/net/urlendec/Makefile b/net/urlendec/Makefile
index ba398e17beba..22582d89f7ff 100644
--- a/net/urlendec/Makefile
+++ b/net/urlendec/Makefile
@@ -3,24 +3,36 @@
PORTNAME= urlendec
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.whizkidtech.redprince.net/fports/
MAINTAINER= ports@FreeBSD.org
-COMMENT= URL encoder and decoder
+COMMENT= URL encoder and decoder written in assembly
-BUILD_DEPENDS= nasm:devel/nasm
+LICENSE= BSD2CLAUSE
+
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= written in x86 assembly language
-ONLY_FOR_ARCHS= i386
+BUILD_DEPENDS= nasm:devel/nasm
-BINARIES= urlencode urldecode
-DOCFILES= index.html rfc1738.txt
+PLIST_FILES= bin/urlencode bin/urldecode
+PORTDOCS= index.html rfc1738.txt
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e '/^[[:blank:]]*ld/s,-o,-m elf_i386_fbsd &, \
+ ; /^[[:blank:]]*nasm/s,elf,&32,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^section/s,code,text,' ${WRKSRC}/*.asm
+
do-install:
- ${INSTALL_PROGRAM} ${BINARIES:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/urlendec
- ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/share/doc/urlendec
+ ${INSTALL_PROGRAM} ${PLIST_FILES:[1..2]:T:S,^,${WRKSRC}/,} \
+ ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/urlendec/pkg-descr b/net/urlendec/pkg-descr
index 0e6770b9fdf5..44b0633890d3 100644
--- a/net/urlendec/pkg-descr
+++ b/net/urlendec/pkg-descr
@@ -1,6 +1,7 @@
-A set of two tools to URL encode and URL decode any stream of data, either
-from the command line or from standard input.
+A set of two tools to URL encode and URL decode any stream of data,
+read either from the command line or from standard input. Written
+in assembly language, they are tiny and very fast.
-See RFC 1738, section 2.2, for an eplanation of URL encoding.
+See RFC 1738, section 2.2, for an explanation of URL encoding.
WWW: http://www.whizkidtech.redprince.net/urlendec/
diff --git a/net/urlendec/pkg-plist b/net/urlendec/pkg-plist
deleted file mode 100644
index 25caab2b1d1a..000000000000
--- a/net/urlendec/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/urlencode
-bin/urldecode
-%%PORTDOCS%%share/doc/urlendec/index.html
-%%PORTDOCS%%share/doc/urlendec/rfc1738.txt