aboutsummaryrefslogtreecommitdiff
path: root/net/vinagre
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-08-02 09:58:14 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-08-02 09:58:14 +0000
commitfb0a1b6f1323190476ea7f8e72608d8a15f67989 (patch)
treea669e98f4d6eeb3b6d305a9f355f88e7bbc4271e /net/vinagre
parent2c4b314b1ade73963a7198485f387300b49899c7 (diff)
downloadports-fb0a1b6f1323190476ea7f8e72608d8a15f67989.tar.gz
ports-fb0a1b6f1323190476ea7f8e72608d8a15f67989.zip
net/vinagre: patch for support passwords more than 8 chars
- support ARD (OS-X remote desktop) - increase the lenght of passwords which can be entered from 8 to 32 The upstream issue with 9 years discussion: https://bugzilla.gnome.org/show_bug.cgi?id=652334 Idea of the patch with description: https://bugzilla.gnome.org/show_bug.cgi?id=666598 The max length 32 from here: https://www.mac-forums.com/threads/maximum-length-of-passwords.317066/ PR: 248196 Submitted by: VVD <vvd@unislabs.com> Approved by: desktop
Notes
Notes: svn path=/head/; revision=543941
Diffstat (limited to 'net/vinagre')
-rw-r--r--net/vinagre/Makefile2
-rw-r--r--net/vinagre/files/patch-plugins_vnc_vinagre-vnc-tab.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index e6a510c0d05d..1e079fabdf3f 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vinagre
PORTVERSION= 3.22.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/net/vinagre/files/patch-plugins_vnc_vinagre-vnc-tab.c b/net/vinagre/files/patch-plugins_vnc_vinagre-vnc-tab.c
new file mode 100644
index 000000000000..46e5a6c89442
--- /dev/null
+++ b/net/vinagre/files/patch-plugins_vnc_vinagre-vnc-tab.c
@@ -0,0 +1,20 @@
+Increase the accepted length of passwords.
+
+- VNC only accepts 8 characters; however some impelementations allow for longer
+ passwords to be used. Increase the passwords that can be entered to 32 chars.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=652334
+https://gitlab.gnome.org/GNOME/vinagre/-/issues/17
+https://bugzilla.redhat.com/show_bug.cgi?id=1767963
+
+--- plugins/vnc/vinagre-vnc-tab.c.orig
++++ plugins/vnc/vinagre-vnc-tab.c
+@@ -508,7 +508,7 @@
+ {
+ host = vinagre_connection_get_best_name (conn);
+ if (!vinagre_utils_request_credential (window, "VNC", host, NULL, NULL,
+- FALSE, need_username, need_password, 8, NULL, &username, &password,
++ FALSE, need_username, need_password, 32, NULL, &username, &password,
+ &save_in_keyring))
+ {
+ vinagre_tab_remove_from_notebook (tab);