aboutsummaryrefslogtreecommitdiff
path: root/net/waypipe/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-08-02 04:33:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-08-02 04:33:13 +0000
commit3e8363b2c88fed832ae5133fe7287f2d81ee48e4 (patch)
tree034975277fefa85e4569a8550e392934a5b09bd1 /net/waypipe/Makefile
parentc53e7310c50008ee2899c2e839c684eae87f1f58 (diff)
downloadports-3e8363b2c88fed832ae5133fe7287f2d81ee48e4.tar.gz
ports-3e8363b2c88fed832ae5133fe7287f2d81ee48e4.zip
net/waypipe: update to 0.4.0
Notes
Notes: svn path=/head/; revision=507841
Diffstat (limited to 'net/waypipe/Makefile')
-rw-r--r--net/waypipe/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/net/waypipe/Makefile b/net/waypipe/Makefile
index 4411958361c4..f8f327b70358 100644
--- a/net/waypipe/Makefile
+++ b/net/waypipe/Makefile
@@ -2,13 +2,9 @@
PORTNAME= waypipe
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.0
-PORTREVISION= 3
+DISTVERSION= 0.4.0
CATEGORIES= net
-PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/commit/
-PATCHFILES+= 04b9a483e346.patch:-p1
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Network transparency with Wayland
@@ -18,15 +14,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= wayland-protocols>=1.12:graphics/wayland-protocols \
wayland>=1.15:graphics/wayland
-USES= compiler:c11 meson pkgconfig
+USES= compiler:c11 localbase:ldflags meson pkgconfig
USE_GITLAB= yes
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= mstoeckl
-GL_COMMIT= 8cf7845e63470490af3af95e178ba5fa74d8056b
+GL_COMMIT= 039bd9acb20fe423f6c3b068bb08c6e6935f0d2b
PLIST_FILES= bin/${PORTNAME}
-OPTIONS_DEFINE= FFMPEG LZ4 MANPAGES OPENGL ZSTD
-OPTIONS_DEFAULT=FFMPEG LZ4 MANPAGES OPENGL ZSTD
+OPTIONS_DEFINE= FFMPEG LZ4 MANPAGES OPENGL VAAPI ZSTD
+OPTIONS_DEFAULT=FFMPEG LZ4 MANPAGES OPENGL VAAPI ZSTD
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
FFMPEG_MESON_ENABLED= with_video
@@ -43,6 +39,9 @@ OPENGL_USE= GL=gbm
OPENGL_LIB_DEPENDS= libdrm.so:graphics/libdrm
OPENGL_MESON_ENABLED= with_dmabuf
+VAAPI_LIB_DEPENDS= libva.so:multimedia/libva
+VAAPI_MESON_ENABLED= with_vaapi
+
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_MESON_ENABLED= with_zstd