aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-08-05 20:19:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-08-05 20:19:06 +0000
commit8a0d943c5945b2314cbd3541a8527cf4842938b1 (patch)
tree9f35baacee8b06212aa76da66908189a8ea1fd24 /net/wireshark/Makefile
parentb2a521e5112f75c7e8541462bf77a59ed9c9be21 (diff)
downloadports-8a0d943c5945b2314cbd3541a8527cf4842938b1.tar.gz
ports-8a0d943c5945b2314cbd3541a8527cf4842938b1.zip
Update to 2.0.5.
See https://www.wireshark.org/docs/relnotes/wireshark-2.0.5.html for the list of changes in this release. While here, enable DECRYPT support by default [1]. Requested by: oshogbo
Notes
Notes: svn path=/head/; revision=419706
Diffstat (limited to 'net/wireshark/Makefile')
-rw-r--r--net/wireshark/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 69495b773346..f24e5545115d 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME?= wireshark
-PORTVERSION= 2.0.4
+PORTVERSION= 2.0.5
PORTREVISION?= 0
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
@@ -27,10 +27,9 @@ DATADIR_NAME= wireshark
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
GNU_CONFIGURE= yes
-USES= alias cpe gmake libtool perl5 pkgconfig python:build tar:bzip2
+USES= alias cpe gmake libtool perl5 pkgconfig python:build ssl tar:bzip2
USE_PERL5= build
USE_GNOME= glib20
-USE_OPENSSL= yes
CONFIGURE_ARGS+= --program-transform-name="" \
--with-ssl=${OPENSSLBASE}
INSTALL_TARGET= install-strip
@@ -63,7 +62,7 @@ OPTIONS_RADIO_ASYNCDNS= ADNS CARES
OPTIONS_RADIO_GUI= GTK2 GTK3 QT5
OPTIONS_SINGLE_KERBEROS=KRB_BASE KRB_HEIMDAL KRB_MIT KRB_NONE
-OPTIONS_DEFAULT?= SNMP ADNS IPV6 GEOIP KRB_BASE GTK3
+OPTIONS_DEFAULT?= SNMP ADNS IPV6 GEOIP KRB_BASE GTK3 DECRYPT
RTP_DESC= Enable support for playing back RTP streams
DECRYPT_DESC= Decryption support for SSL and IPSec