aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2018-12-08 16:10:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2018-12-08 16:10:31 +0000
commit34bb44318f4d3436b12dde10902fc80fe63120db (patch)
tree9b02d5d60908a37cf64bc0ef10b46a35dba159f4 /net/wireshark
parente93e4466d77edfc9cec2c64e8e2c6bca6a7ea128 (diff)
downloadports-34bb44318f4d3436b12dde10902fc80fe63120db.tar.gz
ports-34bb44318f4d3436b12dde10902fc80fe63120db.zip
Fix packaging.
Conditionalize sshdump and ciscodump as they need libssh. PR: 233858
Notes
Notes: svn path=/head/; revision=486960
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile40
1 files changed, 34 insertions, 6 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 9d5d1d4289d1..60ff4b1c8125 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= wireshark
PORTVERSION= 2.6.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
@@ -50,14 +50,14 @@ CFLAGS+= -funit-at-a-time
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
- reordercap captype randpktdump udpdump sharkd dumpcap ciscodump sshdump
+ reordercap captype randpktdump udpdump sharkd dumpcap
.if defined(LITE)
PKGNAMESUFFIX= -lite
PLIST_SUB+= ${x:tu}="@comment $x not installed" \
${x:tu}_LIB="@comment $x not installed " \
${x:tu}_MAN="@comment $x not installed "
CONFIGURE_ARGS+= --enable-$x=no
-OPTIONS_EXCLUDE+= RTP SNMP GEOIP LUA CARES ANDROIDDUMP
+OPTIONS_EXCLUDE+= RTP SNMP GEOIP LUA CARES ANDROIDDUMP SSHDUMP
.else
PLIST_SUB+= ${x:tu}=bin/$x \
${x:tu}_MAN="" \
@@ -65,7 +65,7 @@ PLIST_SUB+= ${x:tu}=bin/$x \
.endif
.endfor
-OPTIONS_DEFINE= RTP SNMP GEOIP LUA DECRYPT ANDROIDDUMP CARES
+OPTIONS_DEFINE= RTP SNMP GEOIP LUA DECRYPT ANDROIDDUMP CARES SSHDUMP CISCODUMP
OPTIONS_RADIO= GUI
OPTIONS_SINGLE= KERBEROS
@@ -84,6 +84,8 @@ KRB_BASE_DESC= Kerberos support via base system
KRB_HEIMDAL_DESC= Kerberos support via security/heimdal
KRB_MIT_DESC= Kerberos support via security/krb5
KRB_NONE_DESC= Disable Kerberos support
+SSHDUMP_DESC= Build sshdump extcap tool
+CISCODUMP_DESC= Build ciscodump extcap tool
GTK2_USE= GNOME=gtk20,cairo
GTK3_USE= GNOME=gtk30,cairo
@@ -103,6 +105,8 @@ CARES_LIB_DEPENDS= libcares.so:dns/c-ares
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
DECRYPT_LIB_DEPENDS= libgnutls.so:security/gnutls \
libgcrypt.so:security/libgcrypt
+SSHDUMP_LIB_DEPENDS= libssh.so:security/libssh
+CISCODUMP_LIB_DEPENDS= libssh.so:security/libssh
KRB_NONE_CONFIGURE_ON= --without-krb5
KRB_NONE_CONFIGURE_OFF= --with-krb5 --with-krb5-crypto-openssl
@@ -119,6 +123,10 @@ GEOIP_CONFIGURE_WITH= geoip
DECRYPT_CONFIGURE_WITH= gnutls
ANDROIDDUMP_CONFIGURE_ON=--enable-androiddump=yes
ANDROIDDUMP_CONFIGURE_OFF=--enable-androiddump=no
+SSHDUMP_CONFIGURE_ON=--enable-sshdump=yes
+SSHDUMP_CONFIGURE_OFF=--enable-sshdump=no
+CISCODUMP_CONFIGURE_ON=--enable-sshdump=yes
+CISCODUMP_CONFIGURE_OFF=--enable-sshdump=no
LUA_CPPFLAGS= -I${LUA_INCDIR}
@@ -134,9 +142,15 @@ GTK3_PLIST_SUB= GUI_GTK=""
OPTIONS_SUB= yes
.if defined(LITE)
-CONFIGURE_ARGS+=--enable-androiddump=no
+CONFIGURE_ARGS+=--enable-androiddump=no \
+ --enable-sshdump=no \
+ --enable-ciscodump=no
PLIST_SUB+= ANDROIDDUMP_LIB="@comment " \
- ANDROIDDUMP_MAN="@comment "
+ ANDROIDDUMP_MAN="@comment " \
+ SSHDUMP_LIB="@comment " \
+ SSHDUMP_MAN="@comment " \
+ CISCODUMP_LIB="@comment " \
+ CISCODUMP_MAN="@comment "
.endif
.include <bsd.port.options.mk>
@@ -159,6 +173,20 @@ PLIST_SUB+= ANDROIDDUMP_LIB="" \
PLIST_SUB+= ANDROIDDUMP_LIB="@comment " \
ANDROIDDUMP_MAN="@comment "
.endif
+.if ${PORT_OPTIONS:MSSHDUMP}
+PLIST_SUB+= SSHDUMP_LIB="" \
+ SSHDUMP_MAN=""
+.else
+PLIST_SUB+= SSHDUMP_LIB="@comment " \
+ SSHDUMP_MAN="@comment "
+.endif
+.if ${PORT_OPTIONS:MCISCODUMP}
+PLIST_SUB+= CISCODUMP_LIB="" \
+ CISCODUMP_MAN=""
+.else
+PLIST_SUB+= CISCODUMP_LIB="@comment " \
+ CISCODUMP_MAN="@comment "
+.endif
.endif
.if ${PORT_OPTIONS:MKRB_BASE} && exists(${LOCALBASE}/include/krb5.h)