aboutsummaryrefslogtreecommitdiff
path: root/net/wol/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-10 11:31:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-10 11:31:06 +0000
commit77ec05dfb888f8d9d4028f0b377e0d509f60003f (patch)
tree579069203c9d76fab9886fea0f6a9a998686c110 /net/wol/Makefile
parent57c5cce4e24fde6ecb7f0e1d1ef04a2575918b7a (diff)
downloadports-77ec05dfb888f8d9d4028f0b377e0d509f60003f.tar.gz
ports-77ec05dfb888f8d9d4028f0b377e0d509f60003f.zip
add wol 0.5.1
Wake On LAN client
Notes
Notes: svn path=/head/; revision=52855
Diffstat (limited to 'net/wol/Makefile')
-rw-r--r--net/wol/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/wol/Makefile b/net/wol/Makefile
new file mode 100644
index 000000000000..184e86757da2
--- /dev/null
+++ b/net/wol/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: wol
+# Date created: Jan 10, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wol
+PORTVERSION= 0.5.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ahh
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
+ giconv:${PORTSDIR}/converters/libiconv \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgiconv -lgnugetopt"
+
+post-patch:
+ @${PERL} -pi -e "s/iconv.h/giconv.h/g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>