aboutsummaryrefslogtreecommitdiff
path: root/net/xbone
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-01-20 08:04:22 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-01-20 08:04:22 +0000
commita2d26cafb13f69ba99ae577598f1300bccc18346 (patch)
tree12a71d5eaef86be0937029d1a8742e2f57a97e34 /net/xbone
parent41f70d5c98a28f8cf39871c5e80cf2f20a97c551 (diff)
downloadports-a2d26cafb13f69ba99ae577598f1300bccc18346.tar.gz
ports-a2d26cafb13f69ba99ae577598f1300bccc18346.zip
X-Bone dynamically deploys and manages Internet overlays to reduce
their configuration effort and increase network component sharing. X-Bone discovers, configures, and monitors network resources to create overlays over existing IP networks. X-Bone uses two-layer IP in IP tunneled overlays and supports existing applications and unmodified routing, multicast, and DNS services in unmodified operating systems. X-Bone also support IPSec within overlays. Submitted by: Yu-Shun Wang <yushunwa@isi.edu>
Notes
Notes: svn path=/head/; revision=37360
Diffstat (limited to 'net/xbone')
-rw-r--r--net/xbone/Makefile75
-rw-r--r--net/xbone/distinfo1
-rw-r--r--net/xbone/pkg-comment1
-rw-r--r--net/xbone/pkg-deinstall27
-rw-r--r--net/xbone/pkg-deinstall.rd21
-rw-r--r--net/xbone/pkg-descr15
-rw-r--r--net/xbone/pkg-plist211
-rw-r--r--net/xbone/pkg-plist.rd141
8 files changed, 492 insertions, 0 deletions
diff --git a/net/xbone/Makefile b/net/xbone/Makefile
new file mode 100644
index 000000000000..396b1827bb21
--- /dev/null
+++ b/net/xbone/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: XBone
+# Date created: 19 Jan 2001
+# Whom: Yu-Shun Wang <xbone@isi.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XBone
+PORTVERSION= 1.3.1
+CATEGORIES= net
+MASTER_SITES= http://www.isi.edu/xbone/software/x-bone/
+
+MAINTAINER= yushunwa@isi.edu
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 320000
+FORBIDDEN= "X-Bone does not support FreeBSD prior to 3.2"
+.endif
+
+USE_GMAKE= yes
+USE_PERL5= yes
+IS_INTERACTIVE= yes
+NO_BUILD= yes
+
+PERL_LIB= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+
+.if !defined(USA_RESIDENT) || ${USA_RESIDENT}!=YES && ${USA_RESIDENT}!=NO
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "ERROR! You must set variable USA_RESIDENT to YES, if you are"
+ @${ECHO} "USA resident or to NO, if you aren't USA resident to build"
+ @${ECHO} "this package. This option is required by other softwares"
+ @${ECHO} "X-Bone depends on."
+ @${FALSE}
+.elif !defined(XBONE_OPTION) || ${XBONE_OPTION}!=RD && ${XBONE_OPTION}!=OMGUI
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "! You must set variable XBONE_OPTION=OMGUI or XBONE_OPTION=RD."
+ @${ECHO} " OMGUI: Install & configure the system for:"
+ @${ECHO} " (1) X-Bone Overlay Manager"
+ @${ECHO} " (2) X-Bone GUI files (html & CGI scripts)"
+ @${ECHO} " (3) X-Bone Overlay DNS server"
+ @${ECHO} " ** NORMALLY, YOU ONLY NEED ONE OMGUI-HOST TO RUN XBONE."
+ @${ECHO} ""
+ @${ECHO} " RD: Install the X-Bone Resource Daemon which enables the"
+ @${ECHO} " system to participate in overlays as either a host"
+ @${ECHO} " or a router."
+ @${ECHO} " ** YOU NEED MULTIPLE RD-HOSTS TO CONSTRUCT OVERLAYS."
+ @${FALSE}
+.elif defined(XBONE_OPTION)
+.if ${XBONE_OPTION}==RD
+BUILD_DEPENDS= ${PERL_LIB}/Net/Netmask.pm:${PORTSDIR}/net/p5-Net-Netmask \
+ ${PERL_LIB}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+INSTALL_TARGET= rd
+PLIST= ${PKGDIR}/pkg-plist.rd
+PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.rd
+.else
+BUILD_DEPENDS= ${PREFIX}/sbin/httpsd:${PORTSDIR}/www/apache13-ssl\
+ ${PERL_LIB}/CGI/Carp.pm:${PORTSDIR}/www/p5-CGI \
+ ${PERL_LIB}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${PERL_LIB}/Net/Netmask.pm:${PORTSDIR}/net/p5-Net-Netmask\
+ ${PERL_LIB}/File/CounterFile.pm:${PORTSDIR}/misc/p5-File-CounterFile \
+ ${PERL_LIB}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+INSTALL_TARGET= omgui
+MAKE_ARGS= PERL5=${PERL5} SYS=${SYS}
+.endif
+.endif
+
+RUN_DEPENDS= ${PREFIX}/bin/ip-tun:${PORTSDIR}/net/ip-tun
+
+MAN1= xb-pick.1
+MAN5= XB_Defs.pm.5 Xbone_daemon.conf.5 Xbone_daemon.state.5
+MAN8= X-Bone.8 xb-daemon.8 xb-overlay-manager.8 xb-config.8
+
+.include <bsd.port.post.mk>
diff --git a/net/xbone/distinfo b/net/xbone/distinfo
new file mode 100644
index 000000000000..42a277f6f93b
--- /dev/null
+++ b/net/xbone/distinfo
@@ -0,0 +1 @@
+MD5 (XBone-1.3.1.tar.gz) = c07084c1f164e49c325575e3398da319
diff --git a/net/xbone/pkg-comment b/net/xbone/pkg-comment
new file mode 100644
index 000000000000..bd071fdd486a
--- /dev/null
+++ b/net/xbone/pkg-comment
@@ -0,0 +1 @@
+A system for dynamic internet overlay deployment and management
diff --git a/net/xbone/pkg-deinstall b/net/xbone/pkg-deinstall
new file mode 100644
index 000000000000..6fe609cfddff
--- /dev/null
+++ b/net/xbone/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+if [ -z $2 ]; then
+ exit 0
+fi
+if [ $2 != "POST-DEINSTALL" ]; then
+ echo "!!! This script is for post-deinstallation only."; \
+ exit 0
+fi
+echo "==> Post-deinstallation cleanup:"
+if [ -d /etc/xbone ]; then
+ /usr/bin/dialog --yesno "/etc/xbone found. Do you want to DELETE it?\
+ Warning: <YES> would DELETE ALL XBONE CONFIG/STATE\
+ files and ALL CERTIFICATES." 8 50 &&
+ rm -rf /etc/xbone || echo " - /etc/xbone is not deleted."
+fi
+/usr/bin/dialog --yesno "Do you want to DELETE all remaining XBone files\
+ under /usr/local/xbone, /usr/local/www & /usr/local/etc/apache?" 8 50 &&
+for f in /usr/local/xbone /usr/local/www /usr/local/etc/apache; do
+ if [ -d $f ]; then
+ rm -rf $f
+ fi
+ if [ -d "$f-OLD" ]; then
+ mv -f $f-OLD $f
+ fi
+done ||
+echo "Check /usr/local/[xbone|www|etc/apache] for possible remaining files."
+
diff --git a/net/xbone/pkg-deinstall.rd b/net/xbone/pkg-deinstall.rd
new file mode 100644
index 000000000000..592b77802368
--- /dev/null
+++ b/net/xbone/pkg-deinstall.rd
@@ -0,0 +1,21 @@
+#!/bin/sh
+if [ -z $2 ]; then
+ exit 0
+fi
+if [ $2 != "POST-DEINSTALL" ]; then
+ echo "!!! This script is for post-deinstallation only."; \
+ exit 0
+fi
+echo "==> Post-deinstallation cleanup:"
+if [ -d /etc/xbone ]; then
+ /usr/bin/dialog --yesno "/etc/xbone found. Do you want to DELETE it?\
+ Warning: <YES> would DELETE ALL XBONE CONFIG/STATE\
+ files and ALL CERTIFICATES." 8 50 &&
+ rm -rf /etc/xbone || echo " - /etc/xbone is not deleted."
+fi
+if [ -d /usr/local/xbone ]; then
+ /usr/bin/dialog --yesno "Do you want to DELETE all remaining XBone files\
+ under /usr/local/xbone?" 8 50 &&
+ rm -rf /usr/local/xbone || echo " - /usr/local/xbone not deleted."
+fi
+
diff --git a/net/xbone/pkg-descr b/net/xbone/pkg-descr
new file mode 100644
index 000000000000..e8661dbc2894
--- /dev/null
+++ b/net/xbone/pkg-descr
@@ -0,0 +1,15 @@
+X-Bone dynamically deploys and manages Internet overlays to reduce
+their configuration effort and increase network component sharing.
+X-Bone discovers, configures, and monitors network resources to
+create overlays over existing IP networks.
+
+X-Bone uses two-layer IP in IP tunneled overlays and supports existing
+applications and unmodified routing, multicast, and DNS services in
+unmodified operating systems. X-Bone also support IPSec within overlays.
+
+Full details can be found on the web at:
+
+WWW: http://www.isi.edu/xbone/
+
+- Joe Touch, Project Leader, X-Bone group, USC/ISI
+ touch@isi.edu; the group can be reached at xbone@isi.edu
diff --git a/net/xbone/pkg-plist b/net/xbone/pkg-plist
new file mode 100644
index 000000000000..eff2e5d137f9
--- /dev/null
+++ b/net/xbone/pkg-plist
@@ -0,0 +1,211 @@
+xbone/doc/README.security
+xbone/doc/arch
+xbone/doc/daemon_data_structures
+xbone/doc/disclaimer
+xbone/doc/gui
+xbone/doc/om_data_structures
+xbone/doc/plan
+xbone/doc/protocol
+xbone/doc/rd.data-structures
+xbone/install/apache_conf_sample/.cvsignore
+xbone/install/apache_conf_sample/access.conf
+xbone/install/apache_conf_sample/httpsd.conf
+xbone/install/apache_conf_sample/httpsd.conf.ORIG
+xbone/install/apache_conf_sample/magic
+xbone/install/apache_conf_sample/mime.types
+xbone/install/apache_conf_sample/srm.conf
+xbone/install/named_conf_sample/xbone/xbone-reverse.private
+xbone/install/named_conf_sample/xbone/xbone-reverse.private.ORIG
+xbone/install/named_conf_sample/xbone/xbone.private
+xbone/install/named_conf_sample/xbone/xbone.private.ORIG
+xbone/install/named_conf_sample/named.conf
+xbone/install/named_conf_sample/named.conf.ORIG
+xbone/install/named_conf_sample/resolv.conf
+xbone/install/named_conf_sample/resolv.conf.ORIG
+xbone/install/CHANGES
+xbone/install/COPYRIGHT
+xbone/install/FAQ
+xbone/install/FILELIST
+xbone/install/INSTALL
+xbone/install/Makefile
+xbone/install/README
+xbone/install/REQUIREMENTS
+xbone/install/SECURITY
+xbone/install/setkey.tar.gz
+xbone/install/xb-DNS-config.pl
+xbone/install/xb-Host-check.pl
+xbone/install/xb-Port-check.pl
+xbone/install/xb-Source-patch.pl
+xbone/lib/cert/CAcert.der
+xbone/lib/cert/CAcert.pem
+xbone/lib/XB_Common.pm
+xbone/lib/XB_Defs.pm
+xbone/lib/XB_Defs.pm.ORIG
+xbone/lib/XB_IPsec.pm
+xbone/lib/XB_Log.pm
+xbone/lib/XB_Overlay_List.pm
+xbone/lib/XB_SSL.pm
+xbone/lib/XB_Utils.pm
+xbone/man/man1/xb-pick.1
+xbone/man/man5/XB_Defs.pm.5
+xbone/man/man5/Xbone_daemon.conf.5
+xbone/man/man5/Xbone_daemon.state.5
+xbone/man/man8/X-Bone.8
+xbone/man/man8/xb-config.8
+xbone/man/man8/xb-daemon.8
+xbone/man/man8/xb-overlay-manager.8
+xbone/om/XB_IP_Allocation.pm
+xbone/om/XB_MIB.pm
+xbone/om/XB_OM_App_Start.pm
+xbone/om/XB_Ping.pm
+xbone/om/XB_RPC.pm
+xbone/om/XB_Topology.pm
+xbone/om/xb-overlay-manager.pl
+xbone/rd/apps/xb-config.pl
+xbone/rd/apps/xb-config.pl.ORIG
+xbone/rd/apps/xb-overlay-list.pl
+xbone/rd/apps/xb-pick
+xbone/rd/XB_App_Start.pm
+xbone/rd/XB_Commands.pm
+xbone/rd/XB_DNS.pm
+xbone/rd/XB_Node_DB.pm
+xbone/rd/XB_Route.pm
+xbone/rd/XB_Tunnel.pm
+xbone/rd/xb-daemon.pl
+xbone/rd/xb-daemon.pl.ORIG
+xbone/www/cgi-bin/index.pl
+xbone/www/cgi-bin/index.pl.ORIG
+xbone/www/cgi-bin/xb-get-ca-cert.pl
+xbone/www/cgi-bin/xb-get-ca-cert.pl.ORIG
+xbone/www/cgi-bin/xb-req-user-cert.pl
+xbone/www/cgi-bin/xb-req-user-cert.pl.ORIG
+xbone/www/htdocs/index.html
+xbone/www/htdocs/robots.txt
+xbone/www/htdocs/xbone.css
+xbone/www/s-cgi-bin/XB_Interface.pm
+xbone/www/s-cgi-bin/XB_Interface.pm.ORIG
+xbone/www/s-cgi-bin/index.pl
+xbone/www/s-cgi-bin/index.pl.ORIG
+xbone/www/s-cgi-bin/xb-admin.pl
+xbone/www/s-cgi-bin/xb-admin.pl.ORIG
+xbone/www/s-cgi-bin/xb-cookies.pl
+xbone/www/s-cgi-bin/xb-cookies.pl.ORIG
+xbone/www/s-cgi-bin/xb-create.pl
+xbone/www/s-cgi-bin/xb-create.pl.ORIG
+xbone/www/s-cgi-bin/xb-destroy.pl
+xbone/www/s-cgi-bin/xb-destroy.pl.ORIG
+xbone/www/s-cgi-bin/xb-req-host-cert.pl
+xbone/www/s-cgi-bin/xb-req-host-cert.pl.ORIG
+xbone/www/s-cgi-bin/xb-status.pl
+xbone/www/s-cgi-bin/xb-status.pl.ORIG
+xbone/www/s-htdocs/images/h1.gif
+xbone/www/s-htdocs/images/h2.gif
+xbone/www/s-htdocs/images/h3.gif
+xbone/www/s-htdocs/images/h4.gif
+xbone/www/s-htdocs/images/h5.gif
+xbone/www/s-htdocs/images/h6.gif
+xbone/www/s-htdocs/images/h7.gif
+xbone/www/s-htdocs/images/h8.gif
+xbone/www/s-htdocs/images/linear.gif
+xbone/www/s-htdocs/images/ring.gif
+xbone/www/s-htdocs/images/stag.gif
+xbone/www/s-htdocs/images/star.gif
+xbone/www/s-htdocs/images/tree.gif
+xbone/www/s-htdocs/index.html
+xbone/www/s-htdocs/robots.txt
+xbone/www/s-htdocs/xbone.css
+www/cgi-bin/index.pl
+www/cgi-bin/index.pl.ORIG
+www/cgi-bin/xb-get-ca-cert.pl
+www/cgi-bin/xb-get-ca-cert.pl.ORIG
+www/cgi-bin/xb-req-user-cert.pl
+www/cgi-bin/xb-req-user-cert.pl.ORIG
+www/htdocs/index.html
+www/htdocs/robots.txt
+www/htdocs/xbone.css
+www/lib/cert/CAcert.der
+www/lib/cert/CAcert.pem
+www/lib/XB_Common.pm
+www/lib/XB_Defs.pm
+www/lib/XB_Defs.pm.ORIG
+www/lib/XB_IPsec.pm
+www/lib/XB_Log.pm
+www/lib/XB_Overlay_List.pm
+www/lib/XB_SSL.pm
+www/lib/XB_Utils.pm
+www/s-cgi-bin/XB_Interface.pm
+www/s-cgi-bin/XB_Interface.pm.ORIG
+www/s-cgi-bin/index.pl
+www/s-cgi-bin/index.pl.ORIG
+www/s-cgi-bin/xb-admin.pl
+www/s-cgi-bin/xb-admin.pl.ORIG
+www/s-cgi-bin/xb-cookies.pl
+www/s-cgi-bin/xb-cookies.pl.ORIG
+www/s-cgi-bin/xb-create.pl
+www/s-cgi-bin/xb-create.pl.ORIG
+www/s-cgi-bin/xb-destroy.pl
+www/s-cgi-bin/xb-destroy.pl.ORIG
+www/s-cgi-bin/xb-req-host-cert.pl
+www/s-cgi-bin/xb-req-host-cert.pl.ORIG
+www/s-cgi-bin/xb-status.pl
+www/s-cgi-bin/xb-status.pl.ORIG
+www/s-htdocs/images/h1.gif
+www/s-htdocs/images/h2.gif
+www/s-htdocs/images/h3.gif
+www/s-htdocs/images/h4.gif
+www/s-htdocs/images/h5.gif
+www/s-htdocs/images/h6.gif
+www/s-htdocs/images/h7.gif
+www/s-htdocs/images/h8.gif
+www/s-htdocs/images/linear.gif
+www/s-htdocs/images/ring.gif
+www/s-htdocs/images/stag.gif
+www/s-htdocs/images/star.gif
+www/s-htdocs/images/tree.gif
+www/s-htdocs/index.html
+www/s-htdocs/robots.txt
+www/s-htdocs/xbone.css
+etc/apache/.cvsignore
+etc/apache/access.conf
+etc/apache/httpd.conf
+etc/apache/httpsd.conf
+etc/apache/httpsd.conf.ORIG
+etc/apache/magic
+etc/apache/mime.types
+etc/apache/srm.conf
+bin/xb-config
+bin/xb-daemon
+bin/xb-overlay-manager
+bin/xb-pick
+@dirrm etc/apache
+@dirrm www/cgi-bin
+@dirrm www/htdocs
+@dirrm www/lib/cert
+@dirrm www/lib
+@dirrm www/s-cgi-bin
+@dirrm www/s-htdocs/images
+@dirrm www/s-htdocs
+@dirrm www
+@unexec mv -f www-OLD www 2>/dev/null || true
+@unexec mv -f etc/apache-OLD etc/apache 2>/dev/null || true
+@dirrm xbone/doc
+@dirrm xbone/install/apache_conf_sample
+@dirrm xbone/install/named_conf_sample/xbone
+@dirrm xbone/install/named_conf_sample
+@dirrm xbone/install
+@dirrm xbone/man/man1
+@dirrm xbone/man/man5
+@dirrm xbone/man/man8
+@dirrm xbone/man
+@dirrm xbone/lib/cert
+@dirrm xbone/lib
+@dirrm xbone/om
+@dirrm xbone/rd/apps
+@dirrm xbone/rd
+@dirrm xbone/www/cgi-bin
+@dirrm xbone/www/htdocs
+@dirrm xbone/www/s-cgi-bin
+@dirrm xbone/www/s-htdocs/images
+@dirrm xbone/www/s-htdocs
+@dirrm xbone/www
+@dirrm xbone
diff --git a/net/xbone/pkg-plist.rd b/net/xbone/pkg-plist.rd
new file mode 100644
index 000000000000..22bb72c5468a
--- /dev/null
+++ b/net/xbone/pkg-plist.rd
@@ -0,0 +1,141 @@
+xbone/doc/README.security
+xbone/doc/arch
+xbone/doc/daemon_data_structures
+xbone/doc/disclaimer
+xbone/doc/gui
+xbone/doc/om_data_structures
+xbone/doc/plan
+xbone/doc/protocol
+xbone/doc/rd.data-structures
+xbone/install/apache_conf_sample/.cvsignore
+xbone/install/apache_conf_sample/access.conf
+xbone/install/apache_conf_sample/httpsd.conf
+xbone/install/apache_conf_sample/httpsd.conf.ORIG
+xbone/install/apache_conf_sample/magic
+xbone/install/apache_conf_sample/mime.types
+xbone/install/apache_conf_sample/srm.conf
+xbone/install/named_conf_sample/xbone/xbone-reverse.private
+xbone/install/named_conf_sample/xbone/xbone-reverse.private.ORIG
+xbone/install/named_conf_sample/xbone/xbone.private
+xbone/install/named_conf_sample/xbone/xbone.private.ORIG
+xbone/install/named_conf_sample/named.conf
+xbone/install/named_conf_sample/named.conf.ORIG
+xbone/install/named_conf_sample/resolv.conf
+xbone/install/named_conf_sample/resolv.conf.ORIG
+xbone/install/CHANGES
+xbone/install/COPYRIGHT
+xbone/install/FAQ
+xbone/install/FILELIST
+xbone/install/INSTALL
+xbone/install/Makefile
+xbone/install/README
+xbone/install/REQUIREMENTS
+xbone/install/SECURITY
+xbone/install/setkey.tar.gz
+xbone/install/xb-DNS-config.pl
+xbone/install/xb-Host-check.pl
+xbone/install/xb-Port-check.pl
+xbone/install/xb-Source-patch.pl
+xbone/lib/cert/CAcert.der
+xbone/lib/cert/CAcert.pem
+xbone/lib/XB_Common.pm
+xbone/lib/XB_Defs.pm
+xbone/lib/XB_Defs.pm.ORIG
+xbone/lib/XB_IPsec.pm
+xbone/lib/XB_Log.pm
+xbone/lib/XB_Overlay_List.pm
+xbone/lib/XB_SSL.pm
+xbone/lib/XB_Utils.pm
+xbone/man/man1/xb-pick.1
+xbone/man/man5/XB_Defs.pm.5
+xbone/man/man5/Xbone_daemon.conf.5
+xbone/man/man5/Xbone_daemon.state.5
+xbone/man/man8/X-Bone.8
+xbone/man/man8/xb-config.8
+xbone/man/man8/xb-daemon.8
+xbone/man/man8/xb-overlay-manager.8
+xbone/om/XB_IP_Allocation.pm
+xbone/om/XB_MIB.pm
+xbone/om/XB_OM_App_Start.pm
+xbone/om/XB_Ping.pm
+xbone/om/XB_RPC.pm
+xbone/om/XB_Topology.pm
+xbone/om/xb-overlay-manager.pl
+xbone/rd/apps/xb-config.pl
+xbone/rd/apps/xb-config.pl.ORIG
+xbone/rd/apps/xb-overlay-list.pl
+xbone/rd/apps/xb-pick
+xbone/rd/XB_App_Start.pm
+xbone/rd/XB_Commands.pm
+xbone/rd/XB_DNS.pm
+xbone/rd/XB_Node_DB.pm
+xbone/rd/XB_Route.pm
+xbone/rd/XB_Tunnel.pm
+xbone/rd/xb-daemon.pl
+xbone/rd/xb-daemon.pl.ORIG
+xbone/www/cgi-bin/index.pl
+xbone/www/cgi-bin/index.pl.ORIG
+xbone/www/cgi-bin/xb-get-ca-cert.pl
+xbone/www/cgi-bin/xb-get-ca-cert.pl.ORIG
+xbone/www/cgi-bin/xb-req-user-cert.pl
+xbone/www/cgi-bin/xb-req-user-cert.pl.ORIG
+xbone/www/htdocs/index.html
+xbone/www/htdocs/robots.txt
+xbone/www/htdocs/xbone.css
+xbone/www/s-cgi-bin/XB_Interface.pm
+xbone/www/s-cgi-bin/XB_Interface.pm.ORIG
+xbone/www/s-cgi-bin/index.pl
+xbone/www/s-cgi-bin/index.pl.ORIG
+xbone/www/s-cgi-bin/xb-admin.pl
+xbone/www/s-cgi-bin/xb-admin.pl.ORIG
+xbone/www/s-cgi-bin/xb-cookies.pl
+xbone/www/s-cgi-bin/xb-cookies.pl.ORIG
+xbone/www/s-cgi-bin/xb-create.pl
+xbone/www/s-cgi-bin/xb-create.pl.ORIG
+xbone/www/s-cgi-bin/xb-destroy.pl
+xbone/www/s-cgi-bin/xb-destroy.pl.ORIG
+xbone/www/s-cgi-bin/xb-req-host-cert.pl
+xbone/www/s-cgi-bin/xb-req-host-cert.pl.ORIG
+xbone/www/s-cgi-bin/xb-status.pl
+xbone/www/s-cgi-bin/xb-status.pl.ORIG
+xbone/www/s-htdocs/images/h1.gif
+xbone/www/s-htdocs/images/h2.gif
+xbone/www/s-htdocs/images/h3.gif
+xbone/www/s-htdocs/images/h4.gif
+xbone/www/s-htdocs/images/h5.gif
+xbone/www/s-htdocs/images/h6.gif
+xbone/www/s-htdocs/images/h7.gif
+xbone/www/s-htdocs/images/h8.gif
+xbone/www/s-htdocs/images/linear.gif
+xbone/www/s-htdocs/images/ring.gif
+xbone/www/s-htdocs/images/stag.gif
+xbone/www/s-htdocs/images/star.gif
+xbone/www/s-htdocs/images/tree.gif
+xbone/www/s-htdocs/index.html
+xbone/www/s-htdocs/robots.txt
+xbone/www/s-htdocs/xbone.css
+bin/xb-config
+bin/xb-daemon
+bin/xb-overlay-manager
+bin/xb-pick
+@dirrm xbone/doc
+@dirrm xbone/install/apache_conf_sample
+@dirrm xbone/install/named_conf_sample/xbone
+@dirrm xbone/install/named_conf_sample
+@dirrm xbone/install
+@dirrm xbone/man/man1
+@dirrm xbone/man/man5
+@dirrm xbone/man/man8
+@dirrm xbone/man
+@dirrm xbone/lib/cert
+@dirrm xbone/lib
+@dirrm xbone/om
+@dirrm xbone/rd/apps
+@dirrm xbone/rd
+@dirrm xbone/www/cgi-bin
+@dirrm xbone/www/htdocs
+@dirrm xbone/www/s-cgi-bin
+@dirrm xbone/www/s-htdocs/images
+@dirrm xbone/www/s-htdocs
+@dirrm xbone/www
+@dirrm xbone