aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-10-24 09:02:02 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-10-24 09:02:02 +0000
commitf6d9b952f6ed3a111039ce124c7fc15e1bf313e1 (patch)
treebd987e8985ee288f1548d4453162564659b7391c /net/xmlrpc-c
parent461d366e96cc67f24e2a71b58917f7c948723052 (diff)
downloadports-f6d9b952f6ed3a111039ce124c7fc15e1bf313e1.tar.gz
ports-f6d9b952f6ed3a111039ce124c7fc15e1bf313e1.zip
- Fix linker issue with static xmlrpc-c libraries.
- Bump PORTREVISION PR: ports/128033 Submitted by: Roman Bogorodskiy (novel@)
Notes
Notes: svn path=/head/; revision=221959
Diffstat (limited to 'net/xmlrpc-c')
-rw-r--r--net/xmlrpc-c/Makefile1
-rw-r--r--net/xmlrpc-c/files/patch-src-cpp-Makefile11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 3bbe8f7c61f9..b6aafe3cfb21 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xmlrpc-c
PORTVERSION= 1.06.30
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
diff --git a/net/xmlrpc-c/files/patch-src-cpp-Makefile b/net/xmlrpc-c/files/patch-src-cpp-Makefile
new file mode 100644
index 000000000000..11ef6216f427
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-src-cpp-Makefile
@@ -0,0 +1,11 @@
+--- src/cpp/Makefile.orig 2008-10-12 21:53:42.000000000 +0400
++++ src/cpp/Makefile 2008-10-12 21:53:51.000000000 +0400
+@@ -139,7 +139,7 @@
+ # RULES TO COMPILE OBJECT MODULES FOR LIBRARIES
+ #-----------------------------------------------------------------------------
+
+-CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD)
++CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD) -fPIC
+
+ XmlRpcCpp.o:%.o:%.cpp
+ $(CXX) -c $(BASIC_INCLUDES) $(CXXFLAGS) $<