aboutsummaryrefslogtreecommitdiff
path: root/net/xorp
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2006-09-22 12:16:47 +0000
committerBruce M Simpson <bms@FreeBSD.org>2006-09-22 12:16:47 +0000
commit02fd15a3ef4997e655bf09fd6948cef480ab3fdc (patch)
treec72fe8ee42e6bf77f486e549c894964b923a4c46 /net/xorp
parent812d282788f276df4e7d10420d3a299f1383920b (diff)
downloadports-02fd15a3ef4997e655bf09fd6948cef480ab3fdc.tar.gz
ports-02fd15a3ef4997e655bf09fd6948cef480ab3fdc.zip
Add a port of the eXtensible Open Router Project, version 1.3.
Notes
Notes: svn path=/head/; revision=173600
Diffstat (limited to 'net/xorp')
-rw-r--r--net/xorp/Makefile84
-rw-r--r--net/xorp/distinfo3
-rw-r--r--net/xorp/files/xorp.rc.sample37
-rw-r--r--net/xorp/pkg-descr12
-rw-r--r--net/xorp/pkg-plist126
5 files changed, 262 insertions, 0 deletions
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
new file mode 100644
index 000000000000..f956009bd416
--- /dev/null
+++ b/net/xorp/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: xorp
+# Date created: 22nd September 2006
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xorp
+PORTVERSION= 1.3
+CATEGORIES= net
+MASTER_SITES= http://www.xorp.org/releases/${PORTVERSION}/ \
+ http://www2.xorp.org/releases/${PORTVERSION}/ \
+ http://www5.xorp.org/releases/${PORTVERSION}/ \
+ http://www3.xorp.org/releases/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= The eXtensible Open Router Platform
+
+NOMAN= defined
+
+USE_GMAKE= yes
+
+#
+# XXX: The default prefix needs to be overridden, because the install
+# targets create a replica of the XORP build tree containing only
+# the binaries and template files, rooted at ${PREFIX}.
+#
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}/xorp \
+ --program-prefix="" ${CONFIGURE_TARGET}
+CONFIGURE_ENV+= CXXFLAGS="-Wno-uninitialized"
+
+OPTIONS= \
+ ADVMCAST "Build with Advanced Multicast API" On \
+ IPV6 "Build with IPv6 support" On \
+ SNMP "Build with SNMP MIB support (BROKEN)" Off \
+ OPTIMIZATION "Build with optimization" Off \
+ CHECK "Build with regression test dependencies " Off \
+ DEBUGGING "Enable debugging" Off \
+ PROFILING "Enable profiling" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ADVMCAST)
+CONFIGURE_ARGS+= --enable-advanced-mcast-api
+.endif
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+# XXX: The net-snmp MIB tests are currently broken; the MIBs
+# will therefore not build.
+.if defined(WITH_SNMP)
+BUILD_DEPENDS= ${LOCALBASE}/bin/snmpd:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --with-snmp \
+ --with-path-to-snmpd=${LOCALBASE}/bin/snmpd \
+ --with-path-to-net-snmpd-config=${LOCALBASE}/bin/net-snmp-config
+.else
+CONFIGURE_ARGS+= --without-snmp
+.endif
+
+.if defined(WITH_OPTIMIZATION)
+CONFIGURE_ARGS+= --enable-optimize
+.endif
+
+# Bash and Python are only required if running the regression tests.
+.if defined(WITH_CHECK)
+BUILD_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
+.endif
+
+.if defined(WITH_DEBUGGING)
+CONFIGURE_ARGS+= --enable-debug-msgs --enable-debug-fnames
+.endif
+
+.if defined(WITH_PROFILING)
+CONFIGURE_ARGS+= --enable-profile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/xorp/distinfo b/net/xorp/distinfo
new file mode 100644
index 000000000000..62f09ba9cbd8
--- /dev/null
+++ b/net/xorp/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorp-1.3.tar.gz) = d428b0c3c7afdad32b529cce2f8b0b2b
+SHA256 (xorp-1.3.tar.gz) = 4196f2d02268d732a4268924b971ff7fe9cc5425cde53ff10dd45665dcee7bbd
+SIZE (xorp-1.3.tar.gz) = 8359944
diff --git a/net/xorp/files/xorp.rc.sample b/net/xorp/files/xorp.rc.sample
new file mode 100644
index 000000000000..b0fce9c8775b
--- /dev/null
+++ b/net/xorp/files/xorp.rc.sample
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# A sample XORP startup script.
+# XXX: This needs more work to be useful.
+#
+
+# PROVIDE: xorp
+# REQUIRE: NETWORKING
+# BEFORE:
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable xorp:
+#
+#xorp_enable="YES"
+#xorp_config_boot="/usr/local/xorp/rtrmgr/config.boot"
+#
+
+. /etc/rc.subr
+
+name=xorp
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${xorp_enable="NO"}
+: ${xorp_rtrmgr_pidfile="/var/run/xorp_rtrmgr.pid"}
+: ${xorp_config_boot="/usr/local/xorp/rtrmgr/config.boot"}
+: ${xorp_flags="/usr/local/xorp/rtrmgr/config.boot"}
+
+command=/usr/local/xorp/rtrmgr/xorp_rtrmgr
+pidfile=$xorp_rtrmgr_pidfile
+required_files=$xorp_config_boot
+sig_stop=INT
+
+run_rc_command "$1"
diff --git a/net/xorp/pkg-descr b/net/xorp/pkg-descr
new file mode 100644
index 000000000000..b9d1d5d50240
--- /dev/null
+++ b/net/xorp/pkg-descr
@@ -0,0 +1,12 @@
+XORP is the eXtensible Open Router Platform.
+
+The XORP project is developing an open source software router. The software
+is intended to be stable and fully featured enough for production use, and
+flexible and extensible enough for research use. The software is covered by
+a BSD-style license and the code is publicly available allowing deployment,
+development, and commericalization.
+
+WWW: http://www.xorp.org/
+
+Bruce
+bms@FreeBSD.org
diff --git a/net/xorp/pkg-plist b/net/xorp/pkg-plist
new file mode 100644
index 000000000000..89d55e6505a4
--- /dev/null
+++ b/net/xorp/pkg-plist
@@ -0,0 +1,126 @@
+xorp/BUGS
+xorp/BUILD_NOTES
+xorp/ERRATA
+xorp/LICENSE
+xorp/README
+xorp/RELEASE_NOTES
+xorp/TODO
+xorp/VERSION
+xorp/bgp/xorp_bgp
+xorp/bgp/tools/print_peers
+xorp/bgp/tools/print_routes
+xorp/bgp/tools/xorpsh_print_peers
+xorp/bgp/tools/xorpsh_print_routes
+xorp/cli/tools/send_cli_processor_xrl
+xorp/etc/templates/bgp.cmds
+xorp/etc/templates/bgp.tp
+xorp/etc/templates/fea.cmds
+xorp/etc/templates/fea.tp
+xorp/etc/templates/fib2mrib.tp
+xorp/etc/templates/host.cmds
+xorp/etc/templates/igmp.cmds
+xorp/etc/templates/igmp.tp
+xorp/etc/templates/interfaces.tp
+xorp/etc/templates/mfea.cmds
+xorp/etc/templates/mfea4.tp
+xorp/etc/templates/mfea6.cmds
+xorp/etc/templates/mfea6.tp
+xorp/etc/templates/misc.cmds
+xorp/etc/templates/mld.cmds
+xorp/etc/templates/mld.tp
+xorp/etc/templates/ospfv2.cmds
+xorp/etc/templates/ospfv2.tp
+xorp/etc/templates/pim.cmds
+xorp/etc/templates/pim6.cmds
+xorp/etc/templates/rib.tp
+xorp/etc/templates/pimsm4.tp
+xorp/etc/templates/pimsm6.tp
+xorp/etc/templates/plumbing.tp
+xorp/etc/templates/policy.tp
+xorp/etc/templates/protocols.tp
+xorp/etc/templates/rib.cmds
+xorp/etc/templates/rip.cmds
+xorp/etc/templates/rip.tp
+xorp/etc/templates/ripng.tp
+xorp/etc/templates/rtrmgr.tp
+xorp/etc/templates/snmp.tp
+xorp/etc/templates/static_routes.tp
+xorp/etc/templates/xorpsh.cmds
+xorp/fea/xorp_fea
+xorp/fea/xorp_fea_dummy
+xorp/fea/tools/show_interfaces
+xorp/fib2mrib/xorp_fib2mrib
+xorp/libxipc/call_xrl
+xorp/libxipc/xorp_finder
+xorp/mld6igmp/xorp_igmp
+xorp/mld6igmp/xorp_mld
+xorp/ospf/xorp_ospfv2
+xorp/ospf/xorp_ospfv3
+xorp/ospf/tools/print_lsas
+xorp/ospf/tools/print_neighbours
+xorp/pim/xorp_pimsm4
+xorp/pim/xorp_pimsm6
+xorp/policy/xorp_policy
+xorp/rib/add_route
+xorp/rib/main_routemap
+xorp/rib/xorp_rib
+xorp/rib/tools/show_routes
+xorp/rtrmgr/xorpsh
+xorp/rtrmgr/xorp_profiler
+xorp/rtrmgr/xorp_rtrmgr
+xorp/static_routes/xorp_static_routes
+xorp/xrl/targets/bgp.xrls
+xorp/xrl/targets/bgp4_mib.xrls
+xorp/xrl/targets/cli.xrls
+xorp/xrl/targets/coord.xrls
+xorp/xrl/targets/fea.xrls
+xorp/xrl/targets/demo_fea_ifmgr_client.xrls
+xorp/xrl/targets/fea_ifmgr_mirror.xrls
+xorp/xrl/targets/fib2mrib.xrls
+xorp/xrl/targets/finder.xrls
+xorp/xrl/targets/finder_client.xrls
+xorp/xrl/targets/mfea.xrls
+xorp/xrl/targets/mld6igmp.xrls
+xorp/xrl/targets/ospfv2.xrls
+xorp/xrl/targets/ospfv3.xrls
+xorp/xrl/targets/packet_acl.xrls
+xorp/xrl/targets/pim.xrls
+xorp/xrl/targets/policy.xrls
+xorp/xrl/targets/profiler.xrls
+xorp/xrl/targets/rib.xrls
+xorp/xrl/targets/ribclient.xrls
+xorp/xrl/targets/rip.xrls
+xorp/xrl/targets/ripng.xrls
+xorp/xrl/targets/rtrmgr.xrls
+xorp/xrl/targets/show_routes.xrls
+xorp/xrl/targets/socket_server.xrls
+xorp/xrl/targets/static_routes.xrls
+xorp/xrl/targets/test.xrls
+xorp/xrl/targets/test_fea_ifmgr_mirror.xrls
+xorp/xrl/targets/test_finder_events.xrls
+xorp/xrl/targets/test_peer.xrls
+xorp/xrl/targets/test_socket4.xrls
+xorp/xrl/targets/test_socket6.xrls
+xorp/xrl/targets/test_xrls.xrls
+xorp/xrl/targets/xorp_if_mib.xrls
+xorp/xrl/targets/xorpsh.xrls
+@dirrm xorp/xrl/targets
+@dirrm xorp/xrl
+@dirrm xorp/static_routes
+@dirrm xorp/rtrmgr
+@dirrm xorp/rip/tools
+@dirrm xorp/rip
+@dirrm xorp/rib
+@dirrm xorp/pim
+@dirrm xorp/ospf/tools
+@dirrm xorp/ospf
+@dirrm xorp/mld6igmp
+@dirrm xorp/libxipc
+@dirrm xorp/fea
+@dirrm xorp/etc/templates
+@dirrm xorp/etc/rc.d
+@dirrm xorp/etc
+@dirrm xorp/cli/tools
+@dirrm xorp/cli
+@dirrm xorp/bgp/tools
+@dirrm xorp/bgp