aboutsummaryrefslogtreecommitdiff
path: root/net/yami4/Makefile
diff options
context:
space:
mode:
authorMaciej Sobczak <prog@msobczak.com>2023-01-26 12:11:08 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-01-29 22:04:31 +0000
commit3fab77d970d381cd1ec6924d5fd4a989122b9d1e (patch)
tree23688ad44862a5870002cff094c6e4c118197804 /net/yami4/Makefile
parent522670310d10096c4ebc284b55f30b4ce0f1aa09 (diff)
downloadports-3fab77d970d381cd1ec6924d5fd4a989122b9d1e.tar.gz
ports-3fab77d970d381cd1ec6924d5fd4a989122b9d1e.zip
net/yami4: Update to 2.0.0 and set new maintainer
Maintainer has no more ports, but was the original creator of this one. PR: 268383 Reported by: prog@msobczak.com
Diffstat (limited to 'net/yami4/Makefile')
-rw-r--r--net/yami4/Makefile55
1 files changed, 41 insertions, 14 deletions
diff --git a/net/yami4/Makefile b/net/yami4/Makefile
index bd0ba449d2e4..9839a0eee5c2 100644
--- a/net/yami4/Makefile
+++ b/net/yami4/Makefile
@@ -1,36 +1,63 @@
PORTNAME= yami4
-PORTVERSION= 1.12.0
+PORTVERSION= 2.0.0
CATEGORIES= net
MASTER_SITES= http://www.inspirel.com/yami4/files/
DISTNAME= yami4-gpl-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= prog@msobczak.com
COMMENT= Messaging library for distributed systems
WWW= http://www.inspirel.com/yami4/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
-USES= compiler:c++11-lang zip
+USES= zip
-CXXFLAGS+= -I${WRKSRC}/include
-# Fixes "unknown type name 'sem_t'" on FreeBSD 13
-CXXFLAGS+= -D_LIBCPP_NO_NATIVE_SEMAPHORES
-MAKE_ARGS= COMPILER="${CXX}" OPTIONS="${CXXFLAGS}"
+OPTIONS_DEFINE= YAMI4CPP YAMI4PYTHON DOCS
+OPTIONS_DEFAULT= YAMI4CPP
+OPTIONS_SUB= yes
+YAMI4CPP_DESC= Core and C++ libraries
+YAMI4PYTHON_DESC= Loadable module for Python3.9
-PORTDOCS= *
+do-build:
-OPTIONS_DEFINE= DOCS
-
-do-build :
+do-build-YAMI4CPP-on:
${DO_MAKE_BUILD} -C ${WRKSRC}/src/core
${DO_MAKE_BUILD} -C ${WRKSRC}/src/cpp
+do-build-YAMI4PYTHON-on:
+ ${DO_MAKE_BUILD} -C ${WRKSRC}/src/python3 PYTHON_INCLUDE=${PREFIX}/include/python3.9 PYTHON_LIBDIR=${PREFIX}/lib
+
do-install:
- cd ${WRKSRC}/include && ${COPYTREE_SHARE} "yami4-core yami4-cpp" ${STAGEDIR}${PREFIX}/include
- cd ${WRKSRC}/lib && ${INSTALL_DATA} *.a ${STAGEDIR}${PREFIX}/lib
+# Note: the interaction between all options is too complex to handle with .if/.endif,
+# so the DOCS is first installed en-bloc and then selectively UNstaged
do-install-DOCS-on:
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "core cpp" ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "core cpp python3" ${STAGEDIR}${DOCSDIR}
+
+do-install-YAMI4CPP-on:
+ cd ${WRKSRC}/include && ${COPYTREE_SHARE} "yami4-core yami4-cpp" ${STAGEDIR}${PREFIX}/include
+ ${RM} ${STAGEDIR}${PREFIX}/include/yami4-core/Doxyfile
+ ${RM} ${STAGEDIR}${PREFIX}/include/yami4-core/doxymain.h
+ ${RM} ${STAGEDIR}${PREFIX}/include/yami4-cpp/Doxyfile
+ ${RM} ${STAGEDIR}${PREFIX}/include/yami4-cpp/doxymain.h
+ cd ${WRKSRC}/lib && ${INSTALL_DATA} libyamicore.a libyamicpp.a ${STAGEDIR}${PREFIX}/lib
+
+do-install-YAMI4PYTHON-on:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/python3.9
+ cd ${WRKSRC}/lib && ${INSTALL_DATA} yami.py ${STAGEDIR}${PREFIX}/lib/python3.9
+ cd ${WRKSRC}/lib && ${INSTALL_LIB} libyami4py.so ${STAGEDIR}${PREFIX}/lib/python3.9
+
+post-install-YAMI4CPP-off:
+ ${RM} -r ${STAGEDIR}${DOCSDIR}/core
+ ${RM} -r ${STAGEDIR}${DOCSDIR}/cpp
+
+post-install-YAMI4PYTHON-off:
+ ${RM} -r ${STAGEDIR}${DOCSDIR}/python3
.include <bsd.port.mk>
+
+.if ${PORT_OPTIONS:MYAMI4PYTHON}
+USES+= python:3.9
+LIB_DEPENDS+= libpython3.9.so:lang/python39
+.endif