aboutsummaryrefslogtreecommitdiff
path: root/net/yami4
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-01-03 19:46:55 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-01-03 19:46:55 +0000
commite06006f8c0bf30f7a4c52b8fc05a7e8ade638dfc (patch)
tree83d2c1ec474f750e58fd70a8ee0602a61bac7506 /net/yami4
parent548fd70f90cc1fd69fe1cdacf17570ce93f88b50 (diff)
downloadports-e06006f8c0bf30f7a4c52b8fc05a7e8ade638dfc.tar.gz
ports-e06006f8c0bf30f7a4c52b8fc05a7e8ade638dfc.zip
New port: net/yami4
YAMI4 is a messaging solution for distributed systems. It is a set of libraries for several platforms and programming languages. This port installs the core and C++ libraries with documentation. WWW: http://www.inspirel.com/yami4/ PR: 184471 Submitted by: prog@msobczak.com
Notes
Notes: svn path=/head/; revision=376167
Diffstat (limited to 'net/yami4')
-rw-r--r--net/yami4/Makefile37
-rw-r--r--net/yami4/distinfo2
-rw-r--r--net/yami4/pkg-descr5
-rw-r--r--net/yami4/pkg-plist169
4 files changed, 213 insertions, 0 deletions
diff --git a/net/yami4/Makefile b/net/yami4/Makefile
new file mode 100644
index 000000000000..be01e9a4c4c6
--- /dev/null
+++ b/net/yami4/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= yami4
+PORTVERSION= 1.10.0
+CATEGORIES= net
+MASTER_SITES= http://www.inspirel.com/yami4/files/
+DISTNAME= yami4-gpl-1.10.0
+
+MAINTAINER= prog@msobczak.com
+COMMENT= Messaging library for distributed systems
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
+
+# USES= compiler:c++11-lib
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+BROKEN= Does only compile with FreeBSD 10.x or higher
+.endif
+
+do-build :
+ cd ${WRKSRC}/src/core; make
+ cd ${WRKSRC}/src/cpp; make
+
+do-install :
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/yami4
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/yami4/core
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/yami4/cpp
+ (cd ${WRKSRC}/doc/core && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/doc/yami4/core)
+ (cd ${WRKSRC}/doc/cpp && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/doc/yami4/cpp)
+ (cd ${WRKSRC}/include && ${COPYTREE_SHARE} yami4-core ${STAGEDIR}${PREFIX}/include)
+ (cd ${WRKSRC}/include && ${COPYTREE_SHARE} yami4-cpp ${STAGEDIR}${PREFIX}/include)
+ (cd ${WRKSRC}/lib && ${INSTALL_DATA} *.a ${STAGEDIR}${PREFIX}/lib)
+
+.include <bsd.port.post.mk>
diff --git a/net/yami4/distinfo b/net/yami4/distinfo
new file mode 100644
index 000000000000..af09e1922eb3
--- /dev/null
+++ b/net/yami4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yami4-gpl-1.10.0.tar.gz) = 4ebff8e8e69b538b4168184217c328d5bce5dc0d95164606fba12dc0ccae43dc
+SIZE (yami4-gpl-1.10.0.tar.gz) = 1071584
diff --git a/net/yami4/pkg-descr b/net/yami4/pkg-descr
new file mode 100644
index 000000000000..d948bf83d034
--- /dev/null
+++ b/net/yami4/pkg-descr
@@ -0,0 +1,5 @@
+YAMI4 is a messaging solution for distributed systems.
+It is a set of libraries for several platforms and programming languages.
+This port installs the core and C++ libraries with documentation.
+
+WWW: http://www.inspirel.com/yami4/
diff --git a/net/yami4/pkg-plist b/net/yami4/pkg-plist
new file mode 100644
index 000000000000..2f676134fe8b
--- /dev/null
+++ b/net/yami4/pkg-plist
@@ -0,0 +1,169 @@
+include/yami4-core/agent.h
+include/yami4-core/allocator.h
+include/yami4-core/channel_descriptor.h
+include/yami4-core/core.h
+include/yami4-core/dll.h
+include/yami4-core/fatal_errors.h
+include/yami4-core/option_names.h
+include/yami4-core/parameter_entry.h
+include/yami4-core/parameter_iterator.h
+include/yami4-core/parameter_type.h
+include/yami4-core/parameters.h
+include/yami4-core/raw_buffer_data_source.h
+include/yami4-core/serializable.h
+include/yami4-cpp/activity_statistics_monitor.h
+include/yami4-cpp/agent.h
+include/yami4-cpp/agent_impl_base.h
+include/yami4-cpp/connection_event.h
+include/yami4-cpp/connection_event_dispatcher_base.h
+include/yami4-cpp/connection_event_generic_dispatcher.h
+include/yami4-cpp/errors.h
+include/yami4-cpp/event_callback.h
+include/yami4-cpp/incoming_message.h
+include/yami4-cpp/incoming_message_dispatcher_base.h
+include/yami4-cpp/incoming_message_generic_dispatcher.h
+include/yami4-cpp/io_error_dispatcher_base.h
+include/yami4-cpp/io_error_generic_dispatcher.h
+include/yami4-cpp/message_state.h
+include/yami4-cpp/option_names.h
+include/yami4-cpp/outgoing_message.h
+include/yami4-cpp/outgoing_message_dispatcher_base.h
+include/yami4-cpp/outgoing_message_generic_dispatcher.h
+include/yami4-cpp/parameter_entry.h
+include/yami4-cpp/parameter_type.h
+include/yami4-cpp/parameters.h
+include/yami4-cpp/raw_buffer_data_source.h
+include/yami4-cpp/serializable.h
+include/yami4-cpp/value_publisher.h
+include/yami4-cpp/value_publisher_overflow_action.h
+include/yami4-cpp/value_publisher_overflow_dispatcher_base.h
+include/yami4-cpp/value_publisher_overflow_generic_dispatcher.h
+include/yami4-cpp/version.h
+include/yami4-cpp/yami.h
+lib/libyamicore.a
+lib/libyamicpp.a
+share/doc/yami4/core/annotated.html
+share/doc/yami4/core/bc_s.png
+share/doc/yami4/core/classes.html
+share/doc/yami4/core/classyami_1_1core_1_1agent-members.html
+share/doc/yami4/core/classyami_1_1core_1_1agent.html
+share/doc/yami4/core/classyami_1_1core_1_1channel__descriptor-members.html
+share/doc/yami4/core/classyami_1_1core_1_1channel__descriptor.html
+share/doc/yami4/core/classyami_1_1core_1_1parameter__entry-members.html
+share/doc/yami4/core/classyami_1_1core_1_1parameter__entry.html
+share/doc/yami4/core/classyami_1_1core_1_1parameter__iterator-members.html
+share/doc/yami4/core/classyami_1_1core_1_1parameter__iterator.html
+share/doc/yami4/core/classyami_1_1core_1_1parameters-members.html
+share/doc/yami4/core/classyami_1_1core_1_1parameters.html
+share/doc/yami4/core/classyami_1_1core_1_1raw__buffer__data__source-members.html
+share/doc/yami4/core/classyami_1_1core_1_1raw__buffer__data__source.html
+share/doc/yami4/core/classyami_1_1core_1_1serializable-members.html
+share/doc/yami4/core/classyami_1_1core_1_1serializable.html
+share/doc/yami4/core/closed.png
+share/doc/yami4/core/doxygen.css
+share/doc/yami4/core/doxygen.png
+share/doc/yami4/core/ftv2blank.png
+share/doc/yami4/core/ftv2doc.png
+share/doc/yami4/core/ftv2folderclosed.png
+share/doc/yami4/core/ftv2folderopen.png
+share/doc/yami4/core/ftv2lastnode.png
+share/doc/yami4/core/ftv2link.png
+share/doc/yami4/core/ftv2mlastnode.png
+share/doc/yami4/core/ftv2mnode.png
+share/doc/yami4/core/ftv2node.png
+share/doc/yami4/core/ftv2plastnode.png
+share/doc/yami4/core/ftv2pnode.png
+share/doc/yami4/core/ftv2splitbar.png
+share/doc/yami4/core/ftv2vertline.png
+share/doc/yami4/core/functions.html
+share/doc/yami4/core/functions_func.html
+share/doc/yami4/core/hierarchy.html
+share/doc/yami4/core/index.html
+share/doc/yami4/core/jquery.js
+share/doc/yami4/core/namespacemembers.html
+share/doc/yami4/core/namespacemembers_enum.html
+share/doc/yami4/core/namespacemembers_eval.html
+share/doc/yami4/core/namespacemembers_func.html
+share/doc/yami4/core/namespacemembers_type.html
+share/doc/yami4/core/namespaces.html
+share/doc/yami4/core/namespaceyami.html
+share/doc/yami4/core/namespaceyami_1_1core.html
+share/doc/yami4/core/nav_f.png
+share/doc/yami4/core/nav_h.png
+share/doc/yami4/core/navtree.css
+share/doc/yami4/core/navtree.js
+share/doc/yami4/core/open.png
+share/doc/yami4/core/resize.js
+share/doc/yami4/core/tab_a.png
+share/doc/yami4/core/tab_b.png
+share/doc/yami4/core/tab_h.png
+share/doc/yami4/core/tab_s.png
+share/doc/yami4/core/tabs.css
+share/doc/yami4/cpp/annotated.html
+share/doc/yami4/cpp/bc_s.png
+share/doc/yami4/cpp/classes.html
+share/doc/yami4/cpp/classyami_1_1activity__statistics__monitor-members.html
+share/doc/yami4/cpp/classyami_1_1activity__statistics__monitor.html
+share/doc/yami4/cpp/classyami_1_1agent-members.html
+share/doc/yami4/cpp/classyami_1_1agent.html
+share/doc/yami4/cpp/classyami_1_1event__callback-members.html
+share/doc/yami4/cpp/classyami_1_1event__callback.html
+share/doc/yami4/cpp/classyami_1_1incoming__message-members.html
+share/doc/yami4/cpp/classyami_1_1incoming__message.html
+share/doc/yami4/cpp/classyami_1_1outgoing__message-members.html
+share/doc/yami4/cpp/classyami_1_1outgoing__message.html
+share/doc/yami4/cpp/classyami_1_1parameter__entry-members.html
+share/doc/yami4/cpp/classyami_1_1parameter__entry.html
+share/doc/yami4/cpp/classyami_1_1parameters-members.html
+share/doc/yami4/cpp/classyami_1_1parameters.html
+share/doc/yami4/cpp/classyami_1_1parameters_1_1iterator-members.html
+share/doc/yami4/cpp/classyami_1_1parameters_1_1iterator.html
+share/doc/yami4/cpp/classyami_1_1raw__buffer__data__source-members.html
+share/doc/yami4/cpp/classyami_1_1raw__buffer__data__source.html
+share/doc/yami4/cpp/classyami_1_1serializable-members.html
+share/doc/yami4/cpp/classyami_1_1serializable.html
+share/doc/yami4/cpp/classyami_1_1value__publisher-members.html
+share/doc/yami4/cpp/classyami_1_1value__publisher.html
+share/doc/yami4/cpp/classyami_1_1yami__logic__error-members.html
+share/doc/yami4/cpp/classyami_1_1yami__logic__error.html
+share/doc/yami4/cpp/classyami_1_1yami__runtime__error-members.html
+share/doc/yami4/cpp/classyami_1_1yami__runtime__error.html
+share/doc/yami4/cpp/closed.png
+share/doc/yami4/cpp/doxygen.css
+share/doc/yami4/cpp/doxygen.png
+share/doc/yami4/cpp/ftv2blank.png
+share/doc/yami4/cpp/ftv2doc.png
+share/doc/yami4/cpp/ftv2folderclosed.png
+share/doc/yami4/cpp/ftv2folderopen.png
+share/doc/yami4/cpp/ftv2lastnode.png
+share/doc/yami4/cpp/ftv2link.png
+share/doc/yami4/cpp/ftv2mlastnode.png
+share/doc/yami4/cpp/ftv2mnode.png
+share/doc/yami4/cpp/ftv2node.png
+share/doc/yami4/cpp/ftv2plastnode.png
+share/doc/yami4/cpp/ftv2pnode.png
+share/doc/yami4/cpp/ftv2splitbar.png
+share/doc/yami4/cpp/ftv2vertline.png
+share/doc/yami4/cpp/functions.html
+share/doc/yami4/cpp/functions_func.html
+share/doc/yami4/cpp/functions_type.html
+share/doc/yami4/cpp/hierarchy.html
+share/doc/yami4/cpp/index.html
+share/doc/yami4/cpp/jquery.js
+share/doc/yami4/cpp/namespacemembers.html
+share/doc/yami4/cpp/namespacemembers_enum.html
+share/doc/yami4/cpp/namespacemembers_eval.html
+share/doc/yami4/cpp/namespacemembers_vars.html
+share/doc/yami4/cpp/namespaces.html
+share/doc/yami4/cpp/namespaceyami.html
+share/doc/yami4/cpp/nav_f.png
+share/doc/yami4/cpp/nav_h.png
+share/doc/yami4/cpp/navtree.css
+share/doc/yami4/cpp/navtree.js
+share/doc/yami4/cpp/open.png
+share/doc/yami4/cpp/resize.js
+share/doc/yami4/cpp/tab_a.png
+share/doc/yami4/cpp/tab_b.png
+share/doc/yami4/cpp/tab_h.png
+share/doc/yami4/cpp/tab_s.png
+share/doc/yami4/cpp/tabs.css