aboutsummaryrefslogtreecommitdiff
path: root/net/yaph/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:35:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:35:54 +0000
commit3f463d1310ead0cb1bae4eb1cce7197b49c3fee1 (patch)
tree2237cbeaf1b78a8b49252d6ec0bfca4ee2312831 /net/yaph/Makefile
parentc4a25f6b2ae5d1cdad338b32fe86dbc85384ec22 (diff)
downloadports-3f463d1310ead0cb1bae4eb1cce7197b49c3fee1.tar.gz
ports-3f463d1310ead0cb1bae4eb1cce7197b49c3fee1.zip
New port: yaph 0.91
New port, yaph (yet another proxy scanner), 0.91 Yaph provides the ability to reveal public proxy servers. PR: ports/53319 Submitted by: Patrick MARIE <mycroft@virgaria.org>
Notes
Notes: svn path=/head/; revision=90744
Diffstat (limited to 'net/yaph/Makefile')
-rw-r--r--net/yaph/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/yaph/Makefile b/net/yaph/Makefile
new file mode 100644
index 000000000000..973419a9d5ae
--- /dev/null
+++ b/net/yaph/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: yaph
+# Date created: 14 jui 2003
+# Whom: Patrick MARIE <mycroft@virgaria.org>
+# $FreeBSD$
+
+PORTNAME= yaph
+PORTVERSION= 0.91
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mycroft@virgaria.org
+COMMENT= Yaph is a proxy scanner
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_GETOPT_LONG=yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_REINPLACE= yes
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/yaph/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/yaph/yaph ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/yaph/yaph.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>