aboutsummaryrefslogtreecommitdiff
path: root/net/yaz
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-03-08 00:39:25 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-03-08 00:39:25 +0000
commitba3d7c3fa72b1149b741d96381b5be687f905eed (patch)
tree6b2d72f8ad11b1ce5ac9fc0eba2935216875f3d1 /net/yaz
parentc8ebffada18d3592803b6c1429ad51b1dcf8cb4a (diff)
downloadports-ba3d7c3fa72b1149b741d96381b5be687f905eed.tar.gz
ports-ba3d7c3fa72b1149b741d96381b5be687f905eed.zip
net/yaz: Use pkgconfig to detect libxml2, libxslt and icu
PR: 262409
Diffstat (limited to 'net/yaz')
-rw-r--r--net/yaz/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index 6072f2e50f44..7047259e5019 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= yaz
DISTVERSION= 5.31.1
CATEGORIES= net
-MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
+MASTER_SITES= https://ftp.indexdata.dk/pub/yaz/
MAINTAINER= nc@FreeBSD.org
COMMENT= Z39.50/SR client and API library
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicuuc.so:devel/icu \
libgnutls.so:security/gnutls
-USES= gnome iconv libtool ncurses pathfix pkgconfig readline \
- shebangfix tcl
+USES= gnome iconv libtool ncurses pathfix localbase:ldflags \
+ pkgconfig readline shebangfix tcl
SHEBANG_FILES= src/yaz-asncomp
GNU_CONFIGURE= yes
USE_GNOME= libxml2 libxslt
@@ -23,9 +23,7 @@ USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS= --enable-shared --with-iconv=${ICONV_PREFIX} \
- --with-xml2=${LOCALBASE} --with-xslt=${LOCALBASE} \
- --with-icu=${LOCALBASE} --enable-tcpd
-LDFLAGS+= -L${LOCALBASE}/lib
+ --with-xml2 --with-xslt --with-icu --enable-tcpd
LIBS+= -lexecinfo
PORTDOCS= *