aboutsummaryrefslogtreecommitdiff
path: root/net/zaptel12
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-08-14 18:12:52 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-08-14 18:12:52 +0000
commit70e458d4b64d5941cbbcad7dcaa922e84ae07340 (patch)
tree291de12c9562dee62e240ed3cb4200dc93f86a31 /net/zaptel12
parent75d18604928e05d955b1f5b15aba4277ed16db83 (diff)
downloadports-70e458d4b64d5941cbbcad7dcaa922e84ae07340.tar.gz
ports-70e458d4b64d5941cbbcad7dcaa922e84ae07340.zip
Convert to rcNG.
PR: 101958 Submitted by: Anish Mistry
Notes
Notes: svn path=/head/; revision=170623
Diffstat (limited to 'net/zaptel12')
-rw-r--r--net/zaptel12/Makefile10
-rw-r--r--net/zaptel12/files/zaptel.sh36
-rw-r--r--net/zaptel12/pkg-message28
-rw-r--r--net/zaptel12/pkg-plist1
4 files changed, 3 insertions, 72 deletions
diff --git a/net/zaptel12/Makefile b/net/zaptel12/Makefile
index 4a09f215790f..f923a28fe819 100644
--- a/net/zaptel12/Makefile
+++ b/net/zaptel12/Makefile
@@ -20,13 +20,14 @@ NO_PACKAGE= Should be in sync with the kernel to work correctly
ONLY_FOR_ARCHS= i386
-PKGMESSAGE= ${WRKSRC}/.MESSAGE
MAKE_ENV= KMODDIR=${PREFIX}/lib/zaptel
+SUB_FILES= pkg-message
+USE_RC_SUBR= zaptel
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-IGNORE= "does not build on FreeBSD \< 5.x"
+IGNORE= does not build on FreeBSD \< 5.x
.endif
pre-everything::
@@ -42,15 +43,10 @@ post-patch:
${WRKSRC}/ztcfg/ztcfg.c
pre-su-install:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > \
- ${PKGMESSAGE}
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/zaptel.sh > \
- ${WRKDIR}/zaptel.sh.sample
@${MKDIR} ${PREFIX}/lib/zaptel
post-install:
@${TOUCH} ${PREFIX}/lib/zaptel/linker.hints
- @${INSTALL_SCRIPT} ${WRKDIR}/zaptel.sh.sample ${PREFIX}/etc/rc.d
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net/zaptel12/files/zaptel.sh b/net/zaptel12/files/zaptel.sh
deleted file mode 100644
index 4356f95d1374..000000000000
--- a/net/zaptel12/files/zaptel.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-
-PREFIX=%%PREFIX%%
-LIBDIR=${PREFIX}/lib/zaptel
-
-case "$1" in
- start)
- /sbin/kldload ${LIBDIR}/zaptel.ko || exit 1
- /sbin/kldload ${LIBDIR}/qozap.ko || exit 1
- /sbin/kldload ${LIBDIR}/wcfxo.ko || exit 1
- /sbin/kldload ${LIBDIR}/wcfxs.ko || exit 1
- /sbin/kldload ${LIBDIR}/wct1xxp.ko || exit 1
- /sbin/kldload ${LIBDIR}/wct4xxp.ko || exit 1
- /sbin/kldload ${LIBDIR}/wcte11xp.ko || exit 1
- ${PREFIX}/bin/ztcfg
- echo -n " zaptel"
- ;;
-
- stop)
- /sbin/kldunload qozap.ko || exit 1
- /sbin/kldunload wcfxs.ko || exit 1
- /sbin/kldunload wcfxo.ko || exit 1
- /sbin/kldunload wct1xxp.ko || exit 1
- /sbin/kldunload wct4xxp.ko || exit 1
- /sbin/kldunload wcte11xp.ko || exit 1
- /sbin/kldunload zaptel.ko || exit 1
- echo -n " zaptel"
- ;;
-
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/net/zaptel12/pkg-message b/net/zaptel12/pkg-message
deleted file mode 100644
index b74305863234..000000000000
--- a/net/zaptel12/pkg-message
+++ /dev/null
@@ -1,28 +0,0 @@
--------------------------------------------------------------------------------
-IMPORTANT! MAKE SURE TO READ THE FOLLOWING!
-
-To use the driver, make a copy of %%PREFIX%%/etc/rc.d/zaptel.sh.sample
-under %%PREFIX%%/etc/rc.d/zaptel.sh.
-
-To load the driver run (as root):
-
-# %%PREFIX%%/etc/rc.d/zaptel.sh start
-
-To unload it:
-
-# %%PREFIX%%/etc/rc.d/zaptel.sh stop
-
-It'll also load the driver automatically when the system is started.
-
-Report problems to Alexander Timoshenko <gonzo@pbxpress.com>. Please note that
-it is still "work in progress" so that your bug reports are welcome and will
-help to improve quality of the drivers.
-
-Great thanks to all companies and individuals who made this driver happen,
-including but not limited to, John Todd, Chris Coleman, Alexander Timoshenko,
-PBXpress, Inc, Max Khon, LF.net, Luigi Rizzo and others contributors.
-
-Thanks and enjoy!
-
--Maxim
--------------------------------------------------------------------------------
diff --git a/net/zaptel12/pkg-plist b/net/zaptel12/pkg-plist
index fb3e1b5c7628..debb163c15f3 100644
--- a/net/zaptel12/pkg-plist
+++ b/net/zaptel12/pkg-plist
@@ -3,7 +3,6 @@ bin/ztcfg
bin/ztmonitor
bin/zttest
bin/zttool
-etc/rc.d/zaptel.sh.sample
include/tonezone.h
include/zaptel.h
lib/libtonezone.a