aboutsummaryrefslogtreecommitdiff
path: root/net/zaptel12
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2005-04-17 07:44:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2005-04-17 07:44:28 +0000
commite5e2a21eeccd64c209e827210c060dd211537f4f (patch)
tree0a1715d3b89b6d74312130247206851e2f66c7a8 /net/zaptel12
parentff8cbab99a5ae2865bf422a41b8dab51b6550b0e (diff)
downloadports-e5e2a21eeccd64c209e827210c060dd211537f4f.tar.gz
ports-e5e2a21eeccd64c209e827210c060dd211537f4f.zip
Forgot to add/remove patches in the previous commit.
Notes
Notes: svn path=/head/; revision=133508
Diffstat (limited to 'net/zaptel12')
-rw-r--r--net/zaptel12/files/patch-qozap::Makefile13
-rw-r--r--net/zaptel12/files/patch-wcfxo::Makefile13
-rw-r--r--net/zaptel12/files/patch-wcfxo::wcfxo.c22
-rw-r--r--net/zaptel12/files/patch-wcfxs::Makefile13
-rw-r--r--net/zaptel12/files/patch-wcfxs::wcfxs.c20
-rw-r--r--net/zaptel12/files/patch-wct1xxp::Makefile13
-rw-r--r--net/zaptel12/files/patch-wct4xxp::Makefile13
-rw-r--r--net/zaptel12/files/patch-wcte11xp::Makefile13
-rw-r--r--net/zaptel12/files/patch-zaptel::Makefile13
-rw-r--r--net/zaptel12/files/patch-zaptel::zaptel.c26
-rw-r--r--net/zaptel12/files/patch-zaptel::zaptel.h16
-rw-r--r--net/zaptel12/files/patch-ztcfg::Makefile26
-rw-r--r--net/zaptel12/files/patch-ztdummy::Makefile14
13 files changed, 105 insertions, 110 deletions
diff --git a/net/zaptel12/files/patch-qozap::Makefile b/net/zaptel12/files/patch-qozap::Makefile
new file mode 100644
index 000000000000..eb4604d5a43e
--- /dev/null
+++ b/net/zaptel12/files/patch-qozap::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- qozap/Makefile
++++ qozap/Makefile
+@@ -4,6 +4,7 @@
+ SRCS= qozap.c qozap_freebsd.c
+ SRCS+= device_if.h bus_if.h isa_if.h pci_if.h
+ CFLAGS+=-I../zaptel
++WERROR= -Wall
+
+ #DEBUG_FLAGS= -g
+
diff --git a/net/zaptel12/files/patch-wcfxo::Makefile b/net/zaptel12/files/patch-wcfxo::Makefile
new file mode 100644
index 000000000000..3f2f9307e1b0
--- /dev/null
+++ b/net/zaptel12/files/patch-wcfxo::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- wcfxo/Makefile
++++ wcfxo/Makefile
+@@ -6,6 +6,7 @@
+ CFLAGS+=-I../zaptel -g
+ SRCS+=device_if.h bus_if.h isa_if.h pci_if.h
+ SRCS+=wcfxovar.h
++WERROR= -Wall
+
+ load: wcfxo.ko
+ kldload ./wcfxo.ko
diff --git a/net/zaptel12/files/patch-wcfxo::wcfxo.c b/net/zaptel12/files/patch-wcfxo::wcfxo.c
deleted file mode 100644
index 1a2810a58b6d..000000000000
--- a/net/zaptel12/files/patch-wcfxo::wcfxo.c
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- wcfxo/wcfxo.c
-+++ wcfxo/wcfxo.c
-@@ -267,8 +267,14 @@
-
- /* Character device entry points */
- static struct cdevsw wcfxo_cdevsw = {
--#if __FreeBSD_version >= 502103
-- .d_version = D_VERSION,
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = 197,
-+#endif
-+#else
-+ .d_version = D_VERSION,
- #endif
- .d_name = "wcfxo",
- .d_open = wcfxo_sys_open,
diff --git a/net/zaptel12/files/patch-wcfxs::Makefile b/net/zaptel12/files/patch-wcfxs::Makefile
new file mode 100644
index 000000000000..fafb7be8daa8
--- /dev/null
+++ b/net/zaptel12/files/patch-wcfxs::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- wcfxs/Makefile
++++ wcfxs/Makefile
+@@ -6,6 +6,7 @@
+ CFLAGS+=-I../zaptel -g
+ SRCS+=device_if.h bus_if.h isa_if.h pci_if.h
+ SRCS+=wcfxsvar.h
++WERROR= -Wall
+
+ load: wcfxs.ko
+ kldload ./wcfxs.ko
diff --git a/net/zaptel12/files/patch-wcfxs::wcfxs.c b/net/zaptel12/files/patch-wcfxs::wcfxs.c
deleted file mode 100644
index bab8faf9d09e..000000000000
--- a/net/zaptel12/files/patch-wcfxs::wcfxs.c
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- wcfxs/wcfxs.c
-+++ wcfxs/wcfxs.c
-@@ -308,7 +308,13 @@
-
- /* Character device entry points */
- static struct cdevsw wcfxs_cdevsw = {
--#if __FreeBSD_version >= 502103
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = 198,
-+#endif
-+#else
- .d_version = D_VERSION,
- #endif
- .d_name = "wcfxs",
diff --git a/net/zaptel12/files/patch-wct1xxp::Makefile b/net/zaptel12/files/patch-wct1xxp::Makefile
new file mode 100644
index 000000000000..f2fb84034d20
--- /dev/null
+++ b/net/zaptel12/files/patch-wct1xxp::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- wct1xxp/Makefile
++++ wct1xxp/Makefile
+@@ -6,6 +6,7 @@
+ CFLAGS+=-I../zaptel -g
+ SRCS+=device_if.h bus_if.h isa_if.h pci_if.h
+ SRCS+=wct1xxp_var.h
++WERROR= -Wall
+
+ load: wct1xxp.ko
+ kldload ./wct1xxp.ko
diff --git a/net/zaptel12/files/patch-wct4xxp::Makefile b/net/zaptel12/files/patch-wct4xxp::Makefile
new file mode 100644
index 000000000000..2a456d29fdde
--- /dev/null
+++ b/net/zaptel12/files/patch-wct4xxp::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- wct4xxp/Makefile
++++ wct4xxp/Makefile
+@@ -5,6 +5,7 @@
+ KMOD=wct4xxp
+ CFLAGS+=-I../zaptel -g
+ SRCS+=device_if.h bus_if.h isa_if.h pci_if.h
++WERROR= -Wall
+
+ load: wct4xxp.ko
+ kldload ./wct4xxp.ko
diff --git a/net/zaptel12/files/patch-wcte11xp::Makefile b/net/zaptel12/files/patch-wcte11xp::Makefile
new file mode 100644
index 000000000000..c2309f926dd1
--- /dev/null
+++ b/net/zaptel12/files/patch-wcte11xp::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- wcte11xp/Makefile
++++ wcte11xp/Makefile
+@@ -6,6 +6,7 @@
+ CFLAGS+=-I../zaptel -g
+ SRCS+=device_if.h bus_if.h isa_if.h pci_if.h
+ SRCS+=wcte11xp_var.h
++WERROR= -Wall
+
+ load: wcte11xp.ko
+ kldload ./wcte11xp.ko
diff --git a/net/zaptel12/files/patch-zaptel::Makefile b/net/zaptel12/files/patch-zaptel::Makefile
new file mode 100644
index 000000000000..ddf54b3fbc70
--- /dev/null
+++ b/net/zaptel12/files/patch-zaptel::Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- zaptel/Makefile
++++ zaptel/Makefile
+@@ -5,6 +5,7 @@
+ KMOD=zaptel
+ CFLAGS+=-g
+ CLEANFILES+=gendigits tones.h
++WERROR=-Wall
+
+ SRCS+=device_if.h bus_if.h vnode_if.h
+
diff --git a/net/zaptel12/files/patch-zaptel::zaptel.c b/net/zaptel12/files/patch-zaptel::zaptel.c
deleted file mode 100644
index a5fc0b4cf7d9..000000000000
--- a/net/zaptel12/files/patch-zaptel::zaptel.c
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD$
-
---- zaptel/zaptel.c
-+++ zaptel/zaptel.c
-@@ -156,12 +156,17 @@
- #endif
-
- static struct cdevsw zt_devsw = {
--#if __FreeBSD_version >= 502103
-+#if __FreeBSD_version < 502103
-+#ifdef MAJOR_AUTO
-+ .d_maj = MAJOR_AUTO,
-+#else
-+ .d_maj = ZT_MAJOR,
-+#endif
-+#else
- .d_version = D_VERSION,
- #endif
- .d_open = ztopen,
-- .d_name = "zaptel",
-- .d_maj = ZT_MAJOR
-+ .d_name = "zaptel"
- };
-
-
diff --git a/net/zaptel12/files/patch-zaptel::zaptel.h b/net/zaptel12/files/patch-zaptel::zaptel.h
deleted file mode 100644
index b25d6f31755b..000000000000
--- a/net/zaptel12/files/patch-zaptel::zaptel.h
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- zaptel/zaptel.h.orig
-+++ zaptel/zaptel.h
-@@ -34,9 +34,9 @@
- #if !defined(_ZAPTEL_H)
- #define _ZAPTEL_H
-
-+#ifdef _KERNEL
- #include "os.h"
-
--#ifdef _KERNEL
- #include <sys/select.h>
- #include <sys/param.h>
-
diff --git a/net/zaptel12/files/patch-ztcfg::Makefile b/net/zaptel12/files/patch-ztcfg::Makefile
deleted file mode 100644
index cc147a290b14..000000000000
--- a/net/zaptel12/files/patch-ztcfg::Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD$
-
---- ztcfg/Makefile
-+++ ztcfg/Makefile
-@@ -10,10 +10,19 @@
-
- all: ztcfg libtonezone.a
-
--ztcfg: ztcfg.o tonezone.o zonedata.o
-+ztcfg: ztcfg.o tonezone.o zonedata.o
- ${CC} ${CFLAGS} -o ztcfg ztcfg.o tonezone.o zonedata.o -lm
-
- ztcfg.c: ztcfg.h
-+
-+ztcfg.o: ztcfg.c
-+ ${CC} ${CFLAGS} -o ztcfg.o -c ztcfg.c
-+
-+tonezone.o: tonezone.c
-+ ${CC} ${CFLAGS} -o tonezone.o -c tonezone.c
-+
-+zonedata.o: zonedata.c
-+ ${CC} ${CFLAGS} -o zonedata.o -c zonedata.c
-
- libtonezone.a: tonezone.o
- ar r libtonezone.a tonezone.o zonedata.o
diff --git a/net/zaptel12/files/patch-ztdummy::Makefile b/net/zaptel12/files/patch-ztdummy::Makefile
new file mode 100644
index 000000000000..b3672857f58b
--- /dev/null
+++ b/net/zaptel12/files/patch-ztdummy::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ztdummy/Makefile
++++ ztdummy/Makefile
+@@ -4,7 +4,7 @@
+ SRCS=ztdummy.c ztdummy.h
+ KMOD=ztdummy
+ CFLAGS+=-I../zaptel -g
+-
++WERROR= -Wall
+ SRCS+=ztdummy.h
+
+ load: ztdummy.ko