aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-11 18:19:38 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-11 18:19:38 +0000
commit01ecacedda3f6a10fb2ff3dff30eeb461b3bb46b (patch)
treec63527b009d045ec6660df44f57b27a04b78fe34 /net
parent457c1da57df96c8375a0e742f5b6f89857012312 (diff)
downloadports-01ecacedda3f6a10fb2ff3dff30eeb461b3bb46b.tar.gz
ports-01ecacedda3f6a10fb2ff3dff30eeb461b3bb46b.zip
- Update to version 1.6 [1]
- Respect global CFLAGS during build - Mark MAKE_JOBS_UNSAFE PR: ports/167770 [1] Submitted by: Tor Halvard Furulund <squat@squat.no> (maintainer) [1]
Notes
Notes: svn path=/head/; revision=296444
Diffstat (limited to 'net')
-rw-r--r--net/miniupnpd/Makefile5
-rw-r--r--net/miniupnpd/distinfo4
-rw-r--r--net/miniupnpd/files/patch-Makefile15
3 files changed, 17 insertions, 7 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 5b7c9d49cece..7298c8d5011a 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= miniupnpd
-PORTVERSION= 1.5
+PORTVERSION= 1.6
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -21,12 +21,13 @@ SUB_LIST= UUID=${UUID}
UUID!= uuidgen
FWNAME?= pf
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd
+MAKE_JOBS_UNSAFE=yes
MAN8= miniupnpd.8
USE_RC_SUBR= miniupnpd.sh
-OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off \
+OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off
.include <bsd.port.options.mk>
.if defined(WITH_PF_ENABLE_FILTER_RULES)
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
index 6205a0ca7278..6cf599be1363 100644
--- a/net/miniupnpd/distinfo
+++ b/net/miniupnpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (miniupnpd-1.5.tar.gz) = 402db10f46d23ffcafbb655ad7333daf1271fb115f92aa293e22cc974fa8da30
-SIZE (miniupnpd-1.5.tar.gz) = 98993
+SHA256 (miniupnpd-1.6.tar.gz) = a26744025038a207d96a2dce96aa76db095886eb68dee87321b9da55cb1c8585
+SIZE (miniupnpd-1.6.tar.gz) = 124917
diff --git a/net/miniupnpd/files/patch-Makefile b/net/miniupnpd/files/patch-Makefile
index ec0841685816..453e3f547ac6 100644
--- a/net/miniupnpd/files/patch-Makefile
+++ b/net/miniupnpd/files/patch-Makefile
@@ -1,6 +1,15 @@
---- Makefile.orig 2009-11-06 08:23:18.000000000 +0800
-+++ Makefile 2009-11-06 08:23:31.000000000 +0800
-@@ -25,10 +25,12 @@
+--- Makefile.orig 2011-05-27 00:49:17.000000000 +0200
++++ Makefile 2012-05-11 19:42:37.000000000 +0200
+@@ -11,7 +11,7 @@
+ # Linux users, please use Makefile.linux :
+ # make -f Makefile.linux
+
+-CFLAGS = -pipe -Wall -Os
++CFLAGS += -pipe -Wall
+ #CFLAGS = -pipe -Wall -O -g -DDEBUG
+ CC ?= gcc
+ RM = rm -f
+@@ -32,10 +32,12 @@
# better way to find if we are using ipf or pf
.if $(OSNAME) == "FreeBSD"