aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'net')
-rw-r--r--net/p5-Frontier-RPC/Makefile1
-rw-r--r--net/p5-Net-Cassandra-Easy/Makefile8
-rw-r--r--net/p5-Net-DAV-Server/Makefile3
-rw-r--r--net/p5-Net-Delicious/Makefile12
-rw-r--r--net/p5-Net-NIS-Listgroup/Makefile2
-rw-r--r--net/p5-Net-Pcap/Makefile4
-rw-r--r--net/p5-Net-RTP/Makefile3
-rw-r--r--net/p5-Net-Server/Makefile8
-rw-r--r--net/p5-POE-Component-Generic/Makefile6
-rw-r--r--net/p5-REST-Google/Makefile3
-rw-r--r--net/p5-S3/Makefile2
-rw-r--r--net/p5-Socket-GetAddrInfo/Makefile11
-rw-r--r--net/p5-Socket-GetAddrInfo/pkg-plist19
13 files changed, 32 insertions, 50 deletions
diff --git a/net/p5-Frontier-RPC/Makefile b/net/p5-Frontier-RPC/Makefile
index f5dda7672e2c..49ebe62cf388 100644
--- a/net/p5-Frontier-RPC/Makefile
+++ b/net/p5-Frontier-RPC/Makefile
@@ -15,6 +15,7 @@ COMMENT= Frontier::RPC implements UserLand Software's XML RPC
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/net/p5-Net-Cassandra-Easy/Makefile b/net/p5-Net-Cassandra-Easy/Makefile
index 21e20e676e11..2202c2e064f6 100644
--- a/net/p5-Net-Cassandra-Easy/Makefile
+++ b/net/p5-Net-Cassandra-Easy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Net-Cassandra-Easy
PORTVERSION= 0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,12 +11,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perlish interface to the Cassandra database
-RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
p5-Hash-Merge>=0:${PORTSDIR}/textproc/p5-Hash-Merge \
p5-Modern-Perl>=0:${PORTSDIR}/lang/p5-Modern-Perl \
- p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/net/p5-Net-DAV-Server/Makefile b/net/p5-Net-DAV-Server/Makefile
index 726fbedbb7c8..360eb7d7ddfb 100644
--- a/net/p5-Net-DAV-Server/Makefile
+++ b/net/p5-Net-DAV-Server/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/\1/}
MAINTAINER= perl@FreeBSD.org
COMMENT= Provide a DAV Server
-RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+BUILD_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-File-Find-Rule-Filesys-Virtual>=0:${PORTSDIR}/devel/p5-File-Find-Rule-Filesys-Virtual \
@@ -20,6 +20,7 @@ RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=1.62000:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
diff --git a/net/p5-Net-Delicious/Makefile b/net/p5-Net-Delicious/Makefile
index f505cd23c95d..f7d4a22cd8f2 100644
--- a/net/p5-Net-Delicious/Makefile
+++ b/net/p5-Net-Delicious/Makefile
@@ -13,14 +13,14 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= OOP for managing posts on del.icio.us
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-Log-Dispatch>=2:${PORTSDIR}/devel/p5-Log-Dispatch \
- p5-XML-Simple>=2:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Config-Simple>=2:${PORTSDIR}/devel/p5-Config-Simple \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-IO-stringy>=2.1:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Log-Dispatch>=2:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-TimeDate>=2.27:${PORTSDIR}/devel/p5-TimeDate \
- p5-Config-Simple>=2:${PORTSDIR}/devel/p5-Config-Simple \
- p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
+ p5-XML-Simple>=2:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-YAML>=0.35:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
diff --git a/net/p5-Net-NIS-Listgroup/Makefile b/net/p5-Net-NIS-Listgroup/Makefile
index be3284fe261d..3a6b1fbedc6b 100644
--- a/net/p5-Net-NIS-Listgroup/Makefile
+++ b/net/p5-Net-NIS-Listgroup/Makefile
@@ -19,7 +19,7 @@ USES= perl5
USE_PERL5= configure
post-patch:
- ${MKDIR} ${WRKSRC}/lib
+ @${MKDIR} ${WRKSRC}/lib
${MV} ${WRKSRC}/Net ${WRKSRC}/lib
.include <bsd.port.mk>
diff --git a/net/p5-Net-Pcap/Makefile b/net/p5-Net-Pcap/Makefile
index c843d31e50da..c6915bf8267a 100644
--- a/net/p5-Net-Pcap/Makefile
+++ b/net/p5-Net-Pcap/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to pcap(3) LBL packet capture library
+BUILD_DEPENDS= p5-IO-Interface>=0:${PORTSDIR}/net/p5-IO-Interface
RUN_DEPENDS= p5-IO-Interface>=0:${PORTSDIR}/net/p5-IO-Interface
-TEST_DEPENDS= p5-Socket>=0:${PORTSDIR}/net/p5-Socket \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
USE_PERL5= configure
diff --git a/net/p5-Net-RTP/Makefile b/net/p5-Net-RTP/Makefile
index 04a69fbc0577..2fff79fc11da 100644
--- a/net/p5-Net-RTP/Makefile
+++ b/net/p5-Net-RTP/Makefile
@@ -11,10 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Send and receive RTP packets (RFC3550)
-RUN_DEPENDS= p5-IO-Socket-Multicast6>=0.02:${PORTSDIR}/net/p5-IO-Socket-Multicast6 \
+BUILD_DEPENDS= p5-IO-Socket-Multicast6>=0.02:${PORTSDIR}/net/p5-IO-Socket-Multicast6 \
p5-IO-Socket-Multicast>=1.00:${PORTSDIR}/net/p5-IO-Socket-Multicast \
p5-IO-Socket-INET6>=1.20:${PORTSDIR}/net/p5-IO-Socket-INET6 \
p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
diff --git a/net/p5-Net-Server/Makefile b/net/p5-Net-Server/Makefile
index 712b945aa1fa..9653b5a3870c 100644
--- a/net/p5-Net-Server/Makefile
+++ b/net/p5-Net-Server/Makefile
@@ -22,11 +22,7 @@ OPTIONS_DEFINE= IPV6
USES= perl5
USE_PERL5= configure
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIPV6}
-BUILD_DEPENDS+= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
-RUN_DEPENDS+= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
-.endif
+IPV6_BUILD_DEPENDS= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
+IPV6_RUN_DEPENDS= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Generic/Makefile b/net/p5-POE-Component-Generic/Makefile
index 01d6a3efdbaa..93e7ebf7235a 100644
--- a/net/p5-POE-Component-Generic/Makefile
+++ b/net/p5-POE-Component-Generic/Makefile
@@ -3,9 +3,8 @@
PORTNAME= POE-Component-Generic
PORTVERSION= 0.14.03
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSION= ${PORTVERSION:C/\.(..)$/\1/}
-PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,9 +12,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides non-blocking access to a blocking object
-RUN_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
+BUILD_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump \
p5-Net-SSH2>=0:${PORTSDIR}/net/p5-Net-SSH2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/net/p5-REST-Google/Makefile b/net/p5-REST-Google/Makefile
index 98cfd596b3f4..6172afb53135 100644
--- a/net/p5-REST-Google/Makefile
+++ b/net/p5-REST-Google/Makefile
@@ -3,7 +3,7 @@
PORTNAME= REST-Google
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:EJS
@@ -13,7 +13,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Access Google REST (aka AJAX) API from Perl
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-version>=0.50:${PORTSDIR}/devel/p5-version \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index a55bfab87512..879d942f2915 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -23,7 +23,7 @@ USE_PERL5= run
WRKSRC= ${WRKDIR}/s3-example-libraries/perl
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
${INSTALL_DATA} ${WRKSRC}/S3/* ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
${INSTALL_DATA} ${WRKSRC}/S3.pm ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
${INSTALL_SCRIPT} ${WRKSRC}/s3-*.pl ${STAGEDIR}${PREFIX}/bin
diff --git a/net/p5-Socket-GetAddrInfo/Makefile b/net/p5-Socket-GetAddrInfo/Makefile
index 7a89fd60df70..1b5ffc00e2b5 100644
--- a/net/p5-Socket-GetAddrInfo/Makefile
+++ b/net/p5-Socket-GetAddrInfo/Makefile
@@ -17,13 +17,4 @@ USES= perl5 shebangfix
USE_PERL5= modbuild
SHEBANG_FILES= bin/getaddrinfo bin/getnameinfo
-.include <bsd.port.pre.mk>
-
-# It only needs to compile stuff on perl older than 5.16.
-.if ${PERL_LEVEL} < 501600
-PLIST_SUB+= OLD_PERL="" NEW_PERL="@comment "
-.else
-PLIST_SUB+= OLD_PERL="@comment " NEW_PERL=""
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Socket-GetAddrInfo/pkg-plist b/net/p5-Socket-GetAddrInfo/pkg-plist
index af1b5a64853c..bdf7cd3b6197 100644
--- a/net/p5-Socket-GetAddrInfo/pkg-plist
+++ b/net/p5-Socket-GetAddrInfo/pkg-plist
@@ -1,21 +1,14 @@
bin/getaddrinfo
bin/getnameinfo
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo.pm
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo/Core.pm
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo/Emul.pm
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo/Socket6api.pm
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo/Strict.pm
-%%OLD_PERL%%%%SITE_ARCH%%/Socket/GetAddrInfo/XS.pm
-%%OLD_PERL%%%%SITE_ARCH%%/auto/Socket/GetAddrInfo/GetAddrInfo.so
+%%SITE_PERL%%/Socket/GetAddrInfo.pm
+%%SITE_PERL%%/Socket/GetAddrInfo/Core.pm
+%%SITE_PERL%%/Socket/GetAddrInfo/Emul.pm
+%%SITE_PERL%%/Socket/GetAddrInfo/Socket6api.pm
+%%SITE_PERL%%/Socket/GetAddrInfo/Strict.pm
+%%SITE_PERL%%/Socket/GetAddrInfo/XS.pm
%%PERL5_MAN3%%/Socket::GetAddrInfo.3.gz
%%PERL5_MAN3%%/Socket::GetAddrInfo::Emul.3.gz
%%PERL5_MAN3%%/Socket::GetAddrInfo::Socket6api.3.gz
%%PERL5_MAN3%%/Socket::GetAddrInfo::Strict.3.gz
man/man1/getaddrinfo.1.gz
man/man1/getnameinfo.1.gz
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo.pm
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo/Core.pm
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo/Emul.pm
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo/Socket6api.pm
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo/Strict.pm
-%%NEW_PERL%%%%SITE_PERL%%/Socket/GetAddrInfo/XS.pm