aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-10-11 20:40:35 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-10-11 20:40:35 +0000
commit20f291b238ab08ab51cc9054cba1d234e564e1f1 (patch)
treeec73f53fb0282099d65229e345eae0eb437391f0 /net
parenta1f17a257735ae97d1c25b2b0fb1638dfc309c53 (diff)
downloadports-20f291b238ab08ab51cc9054cba1d234e564e1f1.tar.gz
ports-20f291b238ab08ab51cc9054cba1d234e564e1f1.zip
Fix a bug introduced by a previous patch, whereby pam_winbind.so would
fail to load correctly. PR: ports/104269 Submitted by: Dominic Marks <dom@helenmarks.co.uk> Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=175217
Diffstat (limited to 'net')
-rw-r--r--net/samba3/Makefile2
-rw-r--r--net/samba3/files/patch-za2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 4e8a0e42bc50..797437d5e9a0 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= samba
PORTVERSION?= 3.0.23c
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
diff --git a/net/samba3/files/patch-za b/net/samba3/files/patch-za
index cadc4bb4c754..d92a775832ff 100644
--- a/net/samba3/files/patch-za
+++ b/net/samba3/files/patch-za
@@ -28,7 +28,7 @@
+ char *env;
+
+ if ((env=getenv(WINBINDD_DONT_ENV)) != NULL) {
-+ if(strequal(env, "1")) {
++ if(strcmp(env, "1")) {
+ return True;
+ }
+ }