aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 17:23:36 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 17:23:36 +0000
commit4534dad4a09757d0295139b3bf7652d4f1063744 (patch)
tree9cab5246c2d980eec11eb0eec132bfc609aaa760 /net
parent64475c2024336cece182bdf308c17f13839afe05 (diff)
downloadports-4534dad4a09757d0295139b3bf7652d4f1063744.tar.gz
ports-4534dad4a09757d0295139b3bf7652d4f1063744.zip
Use OPTIONS helpers.
Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=360411
Diffstat (limited to 'net')
-rw-r--r--net/ntp/Makefile36
1 files changed, 13 insertions, 23 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 1c64a4145d41..d22879be5cc1 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -22,35 +22,27 @@ SHEBANG_FILES= ${WRKSRC}/scripts/ntptrace.in ${WRKSRC}/scripts/ntp-wait.in
perl_OLD_CMD= @PATH_PERL@
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake
+OPTIONS_SUB= yes
.include "Makefile.inc"
-.include <bsd.port.options.mk>
+NTPSNMPD_PLIST_FILES= bin/ntpsnmpd
+NTPSNMPD_BUILD_DEPENDS= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
+NTPSNMPD_RUN_DEPENDS= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
+NTPSNMPD_CONFIGURE_OFF= --without-ntpsnmpd
-.if ${PORT_OPTIONS:MNTPSNMPD}
-PLIST_FILES+= bin/ntpsnmpd
-BUILD_DEPENDS+= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
-RUN_DEPENDS+= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
-.else
-CONFIGURE_ARGS+= --without-ntpsnmpd
-.endif
+SSL_USE= OPENSSL=yes
+SSL_CONFIGURE_OFF= --without-crypto
+
+IPV6_CONFIGURE_ENABLE= ipv6
+
+NTP_SIGND_CONFIGURE_ENABLE= ntp-signd
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
--with-openssl-libdir=${OPENSSLLIB}
-PLIST_SUB+= SSL=""
-.else
-CONFIGURE_ARGS+= --without-crypto
-PLIST_SUB+= SSL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MNTP_SIGND}
-CONFIGURE_ARGS+= --enable-ntp-signd
.endif
.for D in ${NTP_DRIVERS}
@@ -68,11 +60,9 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>