aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 22:57:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 22:58:37 +0000
commit470acdeabc3b7f6e1090cb44747c264aa8e73842 (patch)
treecffc0fdcfd61e2f060ac32e330a886673b586505 /net
parentc7310466d2a98963e0ac53f50d5a87b5dcac7bfe (diff)
downloadports-470acdeabc3b7f6e1090cb44747c264aa8e73842.tar.gz
ports-470acdeabc3b7f6e1090cb44747c264aa8e73842.zip
net/owamp: Fix build with llvm15
Approved by: portmgr (blanket)
Diffstat (limited to 'net')
-rw-r--r--net/owamp/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/owamp/Makefile b/net/owamp/Makefile
index 0e42b00f76e2..060efaff951b 100644
--- a/net/owamp/Makefile
+++ b/net/owamp/Makefile
@@ -11,4 +11,10 @@ LICENSE= APACHE20
GNU_CONFIGURE= yes
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
.include <bsd.port.mk>