aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-06-14 07:51:42 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-06-14 07:51:42 +0000
commit475fec5c4da27cccddd7def230c9f1a4cea13bde (patch)
treed7f251dc1865001dde0d6b557aac044a188a9b2f /net
parent8b44a9ada7024ad07368c673f0f141e03bf9b3f7 (diff)
downloadports-475fec5c4da27cccddd7def230c9f1a4cea13bde.tar.gz
ports-475fec5c4da27cccddd7def230c9f1a4cea13bde.zip
Add throttled 0.3.2, bandwidth shaping and QoS solution.
PR: ports/67850 Submitted by: quest <quest@mac.com>
Notes
Notes: svn path=/head/; revision=111440
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/throttled/Makefile37
-rw-r--r--net/throttled/distinfo2
-rw-r--r--net/throttled/pkg-descr11
4 files changed, 51 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b62a8c3138b9..d7696ff7aaa6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -661,6 +661,7 @@
SUBDIR += tethereal
SUBDIR += tethereal-lite
SUBDIR += thcrut
+ SUBDIR += throttled
SUBDIR += tightvnc
SUBDIR += tik
SUBDIR += tintin++
diff --git a/net/throttled/Makefile b/net/throttled/Makefile
new file mode 100644
index 000000000000..42f69b4f4851
--- /dev/null
+++ b/net/throttled/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: throttled
+# Date created: 11 Jun 2004
+# Whom: quest <quest@mac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= throttled
+PORTVERSION= 0.3.2
+CATEGORIES= net
+MASTER_SITES= http://www.intrarts.com/Files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= quest@mac.com
+COMMENT= Bandwidth shaping and QoS solution
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= sbin/throttled sbin/throttled-startup
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 499999
+IGNORE= "is for FreeBSD 4.X only"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|install: all|install: $$\{APPNAME\}|" \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/throttled-startup
+ @${REINPLACE_CMD} -e "s|c++|${CXX}|;s|-O3|${CXXFLAGS}|" \
+ ${WRKSRC}/src/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/net/throttled/distinfo b/net/throttled/distinfo
new file mode 100644
index 000000000000..fcd740986103
--- /dev/null
+++ b/net/throttled/distinfo
@@ -0,0 +1,2 @@
+MD5 (throttled-0.3.2.tgz) = d3e48c06ed3c8a4bf0017a37c213f4cb
+SIZE (throttled-0.3.2.tgz) = 182681
diff --git a/net/throttled/pkg-descr b/net/throttled/pkg-descr
new file mode 100644
index 000000000000..ec03d20d2c31
--- /dev/null
+++ b/net/throttled/pkg-descr
@@ -0,0 +1,11 @@
+throttled is a bandwidth shaping application for FreeBSD which allows you
+to cap your upstream bandwidth, prioritize ACK packets, and keep your
+download speeds high even when your server is sending out at full speed.
+It uses almost no cpu, and has a tiny footprint. Enjoy.
+
+For more information you can read the comments in throttled-startup
+
+WWW: http://www.intrarts.com/throttled.html
+
+- quest
+quest@mac.com