aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSeyed Pouria Mousavizadeh Tehrani <p.mousavizadeh@protonmail.com>2023-04-19 21:25:57 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-28 16:13:35 +0000
commit4dbff8c76445b2168890f89062c17653c438123c (patch)
tree3ce24816b0f78f3b7538110197853bf4b9238000 /net
parent5f57c067b60fc17e8b848a8e698c60a92dc765ac (diff)
downloadports-4dbff8c76445b2168890f89062c17653c438123c.tar.gz
ports-4dbff8c76445b2168890f89062c17653c438123c.zip
net/iodine: update to 0.8.0
Work around tzsetwall(3) having been removed in CURRENT. Changelog: https://github.com/yarrick/iodine/blob/master/CHANGELOG See also: https://github.com/yarrick/iodine/pull/86 PR: 270938
Diffstat (limited to 'net')
-rw-r--r--net/iodine/Makefile8
-rw-r--r--net/iodine/distinfo2
-rw-r--r--net/iodine/files/patch-src_iodined.c11
-rw-r--r--net/iodine/pkg-plist3
4 files changed, 17 insertions, 7 deletions
diff --git a/net/iodine/Makefile b/net/iodine/Makefile
index 8e01a53887f9..6ee4b601d621 100644
--- a/net/iodine/Makefile
+++ b/net/iodine/Makefile
@@ -1,14 +1,14 @@
PORTNAME= iodine
PORTVERSION= 0.8.0
CATEGORIES= net
-MASTER_SITES= http://code.kryo.se/iodine/ \
- http://redundancy.redundancy.org/mirror/
+MASTER_SITES= https://code.kryo.se/iodine/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= p.mousavizadeh@protonmail.com
COMMENT= Tunnel IPv4 data through a DNS server
WWW= https://code.kryo.se/iodine/
LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cpe
CPE_VENDOR= kryo
@@ -25,7 +25,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/iodine.8 ${STAGEDIR}${MANPREFIX}/man/man8
${GZIP_CMD} ${STAGEDIR}${MANPREFIX}/man/man8/iodine.8
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in README.md CHANGELOG TODO
+.for f in README.md CHANGELOG
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/net/iodine/distinfo b/net/iodine/distinfo
index 635dc19e2192..8b22b0381908 100644
--- a/net/iodine/distinfo
+++ b/net/iodine/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681805049
+TIMESTAMP = 1681933715
SHA256 (iodine-0.8.0.tar.gz) = 546e92cf8617f7970ea81c850b1063eb189c68c406d0c6a67e02c55e72e714c6
SIZE (iodine-0.8.0.tar.gz) = 100577
diff --git a/net/iodine/files/patch-src_iodined.c b/net/iodine/files/patch-src_iodined.c
new file mode 100644
index 000000000000..8cf0386e4b41
--- /dev/null
+++ b/net/iodine/files/patch-src_iodined.c
@@ -0,0 +1,11 @@
+--- src/iodined.c.orig 2023-04-19 20:18:03 UTC
++++ src/iodined.c
+@@ -2754,7 +2754,7 @@ main(int argc, char **argv)
+ do_pidfile(pidfile);
+
+ #ifdef FREEBSD
+- tzsetwall();
++ tzset();
+ #endif
+ #ifndef WINDOWS32
+ openlog(__progname, LOG_NDELAY, LOG_DAEMON);
diff --git a/net/iodine/pkg-plist b/net/iodine/pkg-plist
index 4b9c1059f54f..1412c07f6b87 100644
--- a/net/iodine/pkg-plist
+++ b/net/iodine/pkg-plist
@@ -2,5 +2,4 @@ bin/iodine
sbin/iodined
man/man8/iodine.8.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/README.md