aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 08:02:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 08:02:31 +0000
commit65500ed125c2efe788d2f83ef57838f285acf68c (patch)
treea35f5a8eef584a275d7b109b3d7b0f71076c61c2 /net
parent5034f925da1b45e57d55c7d218fc160d1441dffc (diff)
downloadports-65500ed125c2efe788d2f83ef57838f285acf68c.tar.gz
ports-65500ed125c2efe788d2f83ef57838f285acf68c.zip
- Add ndpi 1.4.0
- While I'm here: - Use PORTVERSION - Use USES=pathfix - Use PLIST_SUB - Update WWW nDPI is a ntop-maintained superset of the popular OpenDPI library. Its goal is to extend the original library by adding new protocols that are otherwise available only on the paid version of OpenDPI. Furthermore, we have modified nDPI do be more suitable for traffic monitoring applications, by disabling specific features that slow down the DPI engine while being them un-necessary for network traffic monitoring. WWW: http://www.ntop.org/products/ndpi/ PR: ports/184209 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Notes
Notes: svn path=/head/; revision=335456
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ndpi/Makefile22
-rw-r--r--net/ndpi/distinfo2
-rw-r--r--net/ndpi/pkg-descr8
-rw-r--r--net/ndpi/pkg-plist13
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dbed0e14c79c..636b08f1d828 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -406,6 +406,7 @@
SUBDIR += ncp
SUBDIR += ncplib
SUBDIR += ndisc6
+ SUBDIR += ndpi
SUBDIR += nemesis
SUBDIR += nepenthes
SUBDIR += nepim
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
new file mode 100644
index 000000000000..0b26cb99ab8a
--- /dev/null
+++ b/net/ndpi/Makefile
@@ -0,0 +1,22 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ndpi
+PORTVERSION= 1.4.0
+CATEGORIES= net
+MASTER_SITES= SF/ntop/nDPI
+DISTNAME= nDPI-${PORTVERSION}_r7023
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= ntop-maintained superset of the popular OpenDPI library
+
+LICENSE= GPLv3
+
+CONFIGURE_ARGS= --with-pic
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= pathfix pkgconfig
+
+PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
+
+.include <bsd.port.mk>
diff --git a/net/ndpi/distinfo b/net/ndpi/distinfo
new file mode 100644
index 000000000000..92560195b860
--- /dev/null
+++ b/net/ndpi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nDPI-1.4.0_r7023.tar.gz) = a06b45cbe9336d40acb7892a3399f41e7e341a37fd2526d0b242587d21bd4197
+SIZE (nDPI-1.4.0_r7023.tar.gz) = 522464
diff --git a/net/ndpi/pkg-descr b/net/ndpi/pkg-descr
new file mode 100644
index 000000000000..812b766e4bdd
--- /dev/null
+++ b/net/ndpi/pkg-descr
@@ -0,0 +1,8 @@
+nDPI is a ntop-maintained superset of the popular OpenDPI library. Its goal is
+to extend the original library by adding new protocols that are otherwise
+available only on the paid version of OpenDPI. Furthermore, we have modified
+nDPI do be more suitable for traffic monitoring applications, by disabling
+specific features that slow down the DPI engine while being them un-necessary
+for network traffic monitoring.
+
+WWW: http://www.ntop.org/products/ndpi/
diff --git a/net/ndpi/pkg-plist b/net/ndpi/pkg-plist
new file mode 100644
index 000000000000..e916105a1ed0
--- /dev/null
+++ b/net/ndpi/pkg-plist
@@ -0,0 +1,13 @@
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_api.h
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_debug_functions.h
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_define.h
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_macros.h
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocols_osdpi.h
+include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_public_functions.h
+lib/libndpi.a
+lib/libndpi.la
+lib/libndpi.so
+lib/libndpi.so.1
+libdata/pkgconfig/libndpi.pc
+@dirrm include/libndpi-%%MAJOR_VER%%/libndpi
+@dirrm include/libndpi-%%MAJOR_VER%%