aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-12-07 22:23:29 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-12-07 22:23:29 +0000
commit6cf4cb90d1d38d1ac8331a776a882c3a154d09ab (patch)
treeda67fb78a472c1dede8e8d1bd03f515ce1c0768d /net
parentba38e3c0f8a9a188986a9bc798816a7be651cad5 (diff)
downloadports-6cf4cb90d1d38d1ac8331a776a882c3a154d09ab.tar.gz
ports-6cf4cb90d1d38d1ac8331a776a882c3a154d09ab.zip
Unbreak this port by applying a simplified version of the real patch that
was submitted [1] which - adds USE_GCC since that's how libpvm3.a (a dependency) was built; - works around pvm's aimk build system to pass our LDFLAGS. While we are at it, migrate to the new LIB_DEPENDS format. PR: 183342 [1] Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net> [1] Pointyhat to: gerald [1]
Notes
Notes: svn path=/head/; revision=335853
Diffstat (limited to 'net')
-rw-r--r--net/xpvm/Makefile5
-rw-r--r--net/xpvm/files/patch-mrt-base_file.h10
-rw-r--r--net/xpvm/files/patch-src:Makefile.aimk15
3 files changed, 14 insertions, 16 deletions
diff --git a/net/xpvm/Makefile b/net/xpvm/Makefile
index fdd1c7500e2e..9ea0f46d4e7d 100644
--- a/net/xpvm/Makefile
+++ b/net/xpvm/Makefile
@@ -13,13 +13,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A Graphical Console and Monitor for PVM
-BROKEN= Fails to patch
-
MAKE_JOBS_UNSAFE= yes
+USE_GCC= yes
BUILD_DEPENDS= ${LOCALBASE}/lib/libpvm3.a:${PORTSDIR}/net/pvm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+LIB_DEPENDS= libtk84.so:${PORTSDIR}/x11-toolkits/tk84
WRKSRC= ${WRKDIR}/xpvm
PVM_ROOT?= ${LOCALBASE}/lib/pvm
diff --git a/net/xpvm/files/patch-mrt-base_file.h b/net/xpvm/files/patch-mrt-base_file.h
deleted file mode 100644
index 6f39e5ece4ce..000000000000
--- a/net/xpvm/files/patch-mrt-base_file.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- mrt/base_file.h.orig 2013-11-16 13:43:12.000000000 +0100
-+++ mrt/base_file.h 2013-11-16 13:44:09.000000000 +0100
-@@ -20,6 +20,7 @@
- */
-
- #include <string>
-+#include <sys/types.h>
- #include "export_mrt.h"
-
- namespace mrt {
diff --git a/net/xpvm/files/patch-src:Makefile.aimk b/net/xpvm/files/patch-src:Makefile.aimk
index 6d7886d89fe5..edf9b0d05ca1 100644
--- a/net/xpvm/files/patch-src:Makefile.aimk
+++ b/net/xpvm/files/patch-src:Makefile.aimk
@@ -1,6 +1,14 @@
-diff -ruN xpvm.orig/src/Makefile.aimk xpvm/src/Makefile.aimk
---- src/Makefile.aimk Fri Apr 10 05:11:22 1998
-+++ src/Makefile.aimk Thu Apr 1 13:38:57 2004
+--- src/Makefile.aimk.orig 1998-04-09 23:11:22.000000000 +0200
++++ src/Makefile.aimk 2013-11-16 20:41:32.000000000 +0100
+@@ -29,7 +29,7 @@
+ #CC = gcc
+
+ CFLAGS = $(CFLOPTS) $(PVMVERSION) -DIMA_$(PVM_ARCH) $(ARCHCFLAGS)
+-LFLAGS = $(ARCHCFLAGS)
++LFLAGS = $(LDFLAGS) $(ARCHCFLAGS)
+
+ AIMK = $(PVM_ROOT)/lib/aimk
+
@@ -39,36 +39,39 @@
#
@@ -100,3 +108,4 @@ diff -ruN xpvm.orig/src/Makefile.aimk xpvm/src/Makefile.aimk
+ $(LOCALBASE)/include/pvmtev.h \
$(TRCDIR)/trcdef.h $(TRCDIR)/trctype.h \
$(TRCDIR)/trcproto.h $(TRCDIR)/trccompat.h
+