aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-05-06 18:03:16 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-05-06 18:03:16 +0000
commit7e9469a758ed6578481636310cd2f526dab6db03 (patch)
treefe9014c9c50db52cfefc7adb6961587e80afd9ad /net
parent57f9d384d1b0bef5424c87b596dbbcf74ed3725f (diff)
downloadports-7e9469a758ed6578481636310cd2f526dab6db03.tar.gz
ports-7e9469a758ed6578481636310cd2f526dab6db03.zip
- Update to 2.17
Notes
Notes: svn path=/head/; revision=296094
Diffstat (limited to 'net')
-rw-r--r--net/dhcpd-pools/Makefile5
-rw-r--r--net/dhcpd-pools/distinfo4
-rw-r--r--net/dhcpd-pools/files/patch-src__other.c31
3 files changed, 37 insertions, 3 deletions
diff --git a/net/dhcpd-pools/Makefile b/net/dhcpd-pools/Makefile
index 0f39cb8ce57d..a04f2e0468a2 100644
--- a/net/dhcpd-pools/Makefile
+++ b/net/dhcpd-pools/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dhcpd-pools
-PORTVERSION= 2.16
+PORTVERSION= 2.17
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}
@@ -16,9 +16,12 @@ COMMENT= A tool to analyze isc-dhcp pool usage based on leases
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:${PORTSDIR}/devel/uthash
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-dhcpd-conf=${LOCALBASE}/etc/dhcpd.conf \
--with-dhcpd-leases=/var/db/dhcpd/dhcpd.leases
+CFLAGS+= -I/usr/include -I${LOCALBASE}/include
PLIST_FILES= bin/dhcpd-pools
PORTDATA= dhcpd-pools.cgi snmptest.pl
diff --git a/net/dhcpd-pools/distinfo b/net/dhcpd-pools/distinfo
index fcac148e89aa..76cec43daf9d 100644
--- a/net/dhcpd-pools/distinfo
+++ b/net/dhcpd-pools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dhcpd-pools-2.16.tar.gz) = ce191a173dde60e7ce684fa257a216fe8d2bf6b94981c1eb7e9e267e5eeb4250
-SIZE (dhcpd-pools-2.16.tar.gz) = 367461
+SHA256 (dhcpd-pools-2.17.tar.gz) = 99f966dc9745f2061d9ca5039837b543876ea02113a920d330f0fbf31f3f495e
+SIZE (dhcpd-pools-2.17.tar.gz) = 366581
diff --git a/net/dhcpd-pools/files/patch-src__other.c b/net/dhcpd-pools/files/patch-src__other.c
new file mode 100644
index 000000000000..deb1b7078c7b
--- /dev/null
+++ b/net/dhcpd-pools/files/patch-src__other.c
@@ -0,0 +1,31 @@
+--- ./src/other.c.orig 2012-05-02 13:52:56.000000000 -0400
++++ ./src/other.c 2012-05-06 13:52:32.000000000 -0400
+@@ -53,13 +53,28 @@
+
+ #include <err.h>
+ #include <errno.h>
++#ifndef __FreeBSD__
+ #include <error.h>
++#endif
+ #include <stdbool.h>
+ #include <stddef.h>
+ #include <stdio.h>
++#ifndef __FreeBSD__
+ #include <stdio_ext.h>
++#endif
+ #include <unistd.h>
+
++#ifdef __FreeBSD__
++#define error errc
++#endif
++
++#ifdef __FreeBSD__
++static size_t __fpending (FILE *fp)
++{
++ return (fp->_p - fp->_bf._base);
++}
++#endif
++
+ /* Simple memory allocation wrapper */
+ void *safe_malloc(const size_t size)
+ {