aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2020-04-27 16:39:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2020-04-27 16:39:35 +0000
commit7f1c7eaa391010a285d58bc8a9d2bdaa90235308 (patch)
tree8396d16ec7abc5ae92096561c60e83a42dfb1379 /net
parent56255bae4f77475db571081b27017fd6da97ce5b (diff)
downloadports-7f1c7eaa391010a285d58bc8a9d2bdaa90235308.tar.gz
ports-7f1c7eaa391010a285d58bc8a9d2bdaa90235308.zip
Update Python support for 3.x.
PR: 245970 Submitted by: dim (partially)
Notes
Notes: svn path=/head/; revision=533152
Diffstat (limited to 'net')
-rw-r--r--net/netatalk3/Makefile5
-rw-r--r--net/netatalk3/files/patch-contrib_shell__utils_afpstats11
2 files changed, 12 insertions, 4 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 8d5ccf32e68c..1f8b4ccff8e4 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -14,9 +14,6 @@ COMMENT= File server for Mac OS X
LICENSE= GPLv2
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libevent.so:devel/libevent
@@ -65,7 +62,7 @@ LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_OFF= --without-ldap
SENDFILE_CONFIGURE_ENABLE=sendfile
-DBUS_USES= gnome python:2.7
+DBUS_USES= gnome python
DBUS_USE= GNOME=glib20
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbus-1.so:devel/dbus
diff --git a/net/netatalk3/files/patch-contrib_shell__utils_afpstats b/net/netatalk3/files/patch-contrib_shell__utils_afpstats
new file mode 100644
index 000000000000..71814ae3fadb
--- /dev/null
+++ b/net/netatalk3/files/patch-contrib_shell__utils_afpstats
@@ -0,0 +1,11 @@
+--- contrib/shell_utils/afpstats.orig 2020-04-27 16:35:40 UTC
++++ contrib/shell_utils/afpstats
+@@ -23,7 +23,7 @@ def main():
+
+ reply = iface.GetUsers()
+ for name in reply:
+- print name
++ print(name)
+
+ if __name__ == '__main__':
+ main()