aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-01-14 18:00:18 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-01-14 18:00:18 +0000
commitb959d3d904664cb5ab25d067c41588db3487bbb3 (patch)
tree8658e74c79d086bead7a7b6fbbf6bba17a4305bb /net
parent170c06e7ece4a0f4edd150a7f997efa484be5dac (diff)
downloadports-b959d3d904664cb5ab25d067c41588db3487bbb3.tar.gz
ports-b959d3d904664cb5ab25d067c41588db3487bbb3.zip
- Fix RUN_DEPENDS (:=), mostly for portlint
- Change WITH_PCAP_PORT to LIB_DEPENDS, not BUILD_DEPENDS - add stopdaemon to pkg-plist - need chown in pkg-plist so that .tbz (package building) works - clean up install message (patch-Makefile.am) - add test in pkg-deinstall.in to test for DBDIR PR: ports/163682 Submitted by: scheidell@
Notes
Notes: svn path=/head/; revision=289193
Diffstat (limited to 'net')
-rw-r--r--net/ntop/Makefile11
-rw-r--r--net/ntop/files/patch-Makefile.am30
-rw-r--r--net/ntop/files/pkg-deinstall.in2
-rw-r--r--net/ntop/pkg-plist6
4 files changed, 35 insertions, 14 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index c4dafedbff83..0fc2564c5b49 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ntop
PORTVERSION= 4.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
#MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable
@@ -21,10 +21,8 @@ LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
dot:${PORTSDIR}/graphics/graphviz \
geoiplookup:${PORTSDIR}/net/GeoIP
-RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
- ${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts \
- rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
- geoiplookup:${PORTSDIR}/net/GeoIP
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ ${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
DBDIR?= /var/db
@@ -53,7 +51,6 @@ USE_RC_SUBR= ntop.sh
##
## Available knobs:
-## WITH_LOCALE: Enable locale (i18n) support.
## WITH_PCAP_PORT: Use libpcap from ports.
## WITH_XMLDUMP: Enable XML Dump support.
##
@@ -64,7 +61,7 @@ OPTIONS= PCAP_PORT "Use libpcap from ports." Off \
.include <bsd.port.pre.mk>
.if defined(WITH_PCAP_PORT)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+LIB_DEPENDS+= pcap.1:${PORTSDIR}/net/libpcap
CONFIGURE_ARGS+= --with-pcap-root=${LOCALBASE}
.else
CONFIGURE_ARGS+= --with-pcap-root=/usr
diff --git a/net/ntop/files/patch-Makefile.am b/net/ntop/files/patch-Makefile.am
index 1377c36d96a8..4b924a1f2c40 100644
--- a/net/ntop/files/patch-Makefile.am
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- ./Makefile.am.orig 2011-02-02 10:24:56.000000000 +0100
-+++ ./Makefile.am 2011-02-02 10:50:06.000000000 +0100
-@@ -68,8 +68,6 @@
+--- Makefile.am.orig 2011-03-03 08:44:59.000000000 -0500
++++ Makefile.am 2011-12-28 14:25:08.000000000 -0500
+@@ -61,8 +61,6 @@
ETTER_PASSIVE_FILE = etter.finger.os
ETTER_PASSIVE = $(ETTER_PASSIVE_FILE).gz
@@ -9,7 +9,25 @@
NTOPDATA = ntop-cert.pem \
$(ETTER_PASSIVE) \
-@@ -337,7 +335,6 @@
+@@ -303,15 +301,14 @@
+ echo " WARNING: This install created a directory for the ntop"; \
+ echo " files and databases:"; \
+ echo ""; \
+- echo " $(DESTDIR)/$(datadir)/ntop"; \
++ echo " $(CFG_DBFILE_DIR)"; \
+ echo ""; \
+ echo " This directory MUST be owned by the user"; \
+ echo " which you are going to use to run ntop."; \
+ echo ""; \
+ echo " The command you must issue is something like:"; \
+ echo ""; \
+- echo " chown -R ntop.ntop $(DESTDIR)/$(datadir)/ntop"; \
+- echo " or chown -R ntop:users $(DESTDIR)/$(datadir)/ntop"; \
++ echo " chown -R nobody:nobody $(CFG_DBFILE_DIR)"; \
+ echo ""; \
+ echo " man chown to check the syntax for YOUR system"; \
+ echo ""; \
+@@ -329,7 +326,6 @@
chcon -t textrel_shlib_t $(DESTDIR)$(libdir)/*ntop*.so
install-data-local: ntop.txt ntop.html faq.html dnetter
@@ -17,7 +35,7 @@
@if ! test -d $(DESTDIR)/$(datadir)/ntop; then \
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop; \
touch $(DESTDIR)/$(datadir)/ntop/warnuser; \
-@@ -373,21 +370,6 @@
+@@ -365,21 +361,6 @@
@echo ""
@echo ""
@echo -n "Preparing "
@@ -39,7 +57,7 @@
@echo -n "New file lines are: "
@gunzip -c oui.txt.gz | wc -l
@echo ""
-@@ -406,34 +388,6 @@
+@@ -398,34 +379,6 @@
@echo "Preparing "
@echo ""
diff --git a/net/ntop/files/pkg-deinstall.in b/net/ntop/files/pkg-deinstall.in
index 2e0d9914e1da..a55e12e99d9d 100644
--- a/net/ntop/files/pkg-deinstall.in
+++ b/net/ntop/files/pkg-deinstall.in
@@ -7,6 +7,7 @@ case $2 in
DEINSTALL)
;;
POST-DEINSTALL)
+ if [ -d %%DBDIR%%/ntop ];then
echo "===> post-deinstallation information for $1"
echo ""
echo " Please note that ntop was not completely removed"
@@ -15,6 +16,7 @@ case $2 in
echo " %%DBDIR%%/ntop can be removed if this port will not be"
echo " reinstalled."
echo ""
+ fi
;;
*)
exit 64
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 95ddcebca484..13b2534e9ab2 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -1,3 +1,4 @@
+@stopdaemon ntop
bin/ntop
etc/ntop/GeoIPASNum.dat
etc/ntop/GeoLiteCity.dat
@@ -453,7 +454,6 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/python/templates/rrdAlarmConfigurator.tmpl
%%DATADIR%%/python/templates/rrdAlarmConfiguratorHelp.tmpl
%%DATADIR%%/python/templates/rrdAlarmStart.tmpl
-@exec mkdir -p %%DBDIR%%/ntop
@dirrm %%DATADIR%%/html/MochiKit
@dirrm %%DATADIR%%/html/PlotKit
@dirrm %%DATADIR%%/html/img_inquisitor
@@ -475,3 +475,7 @@ lib/ntop/plugins/sflowPlugin.so
@dirrm etc/ntop
@dirrm lib/ntop/plugins
@dirrm lib/ntop
+@exec mkdir -p %%DBDIR%%/ntop
+@exec chown -R nobody:nobody %%DBDIR%%/ntop
+@unexec rmdir %%DBDIR%%/ntop 2>/dev/null || true
+@unexec rmdir %%DBDIR%% 2>/dev/null || true