aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2020-12-29 12:53:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2020-12-29 12:53:20 +0000
commitc1e26e39b09d42f834f7c0d2ddad50c90b0a7ce6 (patch)
tree46a1cb291cd68f4a19b568304841994a7e44f163 /net
parent67f7823c0cba528545ce845f2b11adb6ae8726b4 (diff)
downloadports-c1e26e39b09d42f834f7c0d2ddad50c90b0a7ce6.tar.gz
ports-c1e26e39b09d42f834f7c0d2ddad50c90b0a7ce6.zip
Add gitup 0.87, minimalist, dependency-free program to clone/pull git
repositories. PR: 252220 Submitted by: ed.arrakis@gmail.com Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=559576
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/gitup/Makefile45
-rw-r--r--net/gitup/distinfo3
-rw-r--r--net/gitup/pkg-descr8
-rw-r--r--net/gitup/pkg-message10
-rw-r--r--net/gitup/pkg-plist4
6 files changed, 71 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d9aee3a222cb..2b34c0772ab3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -178,6 +178,7 @@
SUBDIR += gerbera
SUBDIR += gfbgraph
SUBDIR += gitlab-agent
+ SUBDIR += gitup
SUBDIR += glflow
SUBDIR += glib-networking
SUBDIR += glusterfs
diff --git a/net/gitup/Makefile b/net/gitup/Makefile
new file mode 100644
index 000000000000..206b3b1b157f
--- /dev/null
+++ b/net/gitup/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= gitup
+DISTVERSION= 0.87
+CATEGORIES= net
+
+MAINTAINER= ed.arrakis@gmail.com
+COMMENT= Minimalist, dependency-free program to clone/pull git repositories
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= johnmehr
+
+ALL_TARGET= gitup
+CFLAGS+= -I${OPENSSLINC}
+LDADD= -lz -L${OPENSSLLIB} -lssl -lcrypto -lprivateucl
+MAKE_ARGS= CFLAGS="${CFLAGS}" \
+ LDADD="${LDADD}"
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ ${REINPLACE_CMD} 's,\./gitup.conf,${PREFIX}/etc/gitup.conf,' \
+ ${WRKSRC}/gitup.c
+ ${REINPLACE_CMD} 's,/usr/local,${PREFIX},g' \
+ ${WRKSRC}/gitup.1 ${WRKSRC}/gitup.conf.5
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gitup.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/gitup.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5
+ ${INSTALL_DATA} ${WRKSRC}/gitup.conf \
+ ${STAGEDIR}${PREFIX}/etc/gitup.conf.sample
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/gitup/distinfo b/net/gitup/distinfo
new file mode 100644
index 000000000000..d9470e927905
--- /dev/null
+++ b/net/gitup/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609199079
+SHA256 (johnmehr-gitup-0.87_GH0.tar.gz) = 7d8567714a902444fac1cb1f7d3d867ed9d4cf6e01e6e694dec0a917f35196a8
+SIZE (johnmehr-gitup-0.87_GH0.tar.gz) = 20296
diff --git a/net/gitup/pkg-descr b/net/gitup/pkg-descr
new file mode 100644
index 000000000000..5aba900b0fb3
--- /dev/null
+++ b/net/gitup/pkg-descr
@@ -0,0 +1,8 @@
+A minimalist, dependency-free FreeBSD program to clone/pull git
+repositories. Intended for non-developers, gitup synchronizes local
+copies of repositories without the additional overhead that the
+official git client requires. Because gitup neither uses nor updates
+the contents of .git directories, the official git client should not
+be used on repositories cloned or modified with gitup.
+
+WWW: https://github.com/johnmehr/gitup
diff --git a/net/gitup/pkg-message b/net/gitup/pkg-message
new file mode 100644
index 000000000000..91ab156ce2eb
--- /dev/null
+++ b/net/gitup/pkg-message
@@ -0,0 +1,10 @@
+[
+{
+ type: install
+ message: <<EOM
+Currently this program is beta, so the usual caveats/warnings (don't
+use it in a production environment, make sure you've got backups, dont
+(yet) run as root) apply.
+EOM
+}
+]
diff --git a/net/gitup/pkg-plist b/net/gitup/pkg-plist
new file mode 100644
index 000000000000..fcd9e77f06da
--- /dev/null
+++ b/net/gitup/pkg-plist
@@ -0,0 +1,4 @@
+bin/gitup
+man/man1/gitup.1.gz
+man/man5/gitup.conf.5.gz
+@sample etc/gitup.conf.sample