aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
commitc9cf6c61132115ca4b6476190fe9576d06ee06db (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /net
parentb100cd9f05b8e71f0cd2e142eafe47d54108a79c (diff)
downloadports-c9cf6c61132115ca4b6476190fe9576d06ee06db.tar.gz
ports-c9cf6c61132115ca4b6476190fe9576d06ee06db.zip
- Convert to new perl framework
Notes
Notes: svn path=/head/; revision=325134
Diffstat (limited to 'net')
-rw-r--r--net/p5-IO-Socket-IP/Makefile3
-rw-r--r--net/p5-Net-CLI-Interact/Makefile3
-rw-r--r--net/p5-Net-Dict/Makefile3
-rw-r--r--net/p5-Net-HTTPS-NB/Makefile3
-rw-r--r--net/p5-Net-OAuth2/Makefile3
-rw-r--r--net/p5-Net-OpenSSH-Parallel/Makefile3
-rw-r--r--net/p5-OAI-Harvester/Makefile3
-rw-r--r--net/p5-Socket/Makefile3
-rw-r--r--net/p5-URI-Query/Makefile3
9 files changed, 18 insertions, 9 deletions
diff --git a/net/p5-IO-Socket-IP/Makefile b/net/p5-IO-Socket-IP/Makefile
index ee40763b9eee..47372621040f 100644
--- a/net/p5-IO-Socket-IP/Makefile
+++ b/net/p5-IO-Socket-IP/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Socket>=1.97:${PORTSDIR}/net/p5-Socket
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= IO::Socket::IP.3
diff --git a/net/p5-Net-CLI-Interact/Makefile b/net/p5-Net-CLI-Interact/Makefile
index 773e9821e8ce..f574bb6afc60 100644
--- a/net/p5-Net-CLI-Interact/Makefile
+++ b/net/p5-Net-CLI-Interact/Makefile
@@ -26,7 +26,8 @@ BUILD_DEPENDS= p5-Class-Load>=0:${PORTSDIR}/devel/p5-Class-Load \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Net::CLI::Interact.3 \
Net::CLI::Interact::Action.3 \
diff --git a/net/p5-Net-Dict/Makefile b/net/p5-Net-Dict/Makefile
index 6010760dceb4..c39ccc32d1e5 100644
--- a/net/p5-Net-Dict/Makefile
+++ b/net/p5-Net-Dict/Makefile
@@ -14,7 +14,8 @@ COMMENT= Simple client API for the DICT protocol
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Net::Dict.3
diff --git a/net/p5-Net-HTTPS-NB/Makefile b/net/p5-Net-HTTPS-NB/Makefile
index 5d5c5c437a84..da8d0031abdb 100644
--- a/net/p5-Net-HTTPS-NB/Makefile
+++ b/net/p5-Net-HTTPS-NB/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-IO-Socket-SSL>=0.98:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Net-HTTP>=0:${PORTSDIR}/net/p5-Net-HTTP
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Net::HTTPS::NB.3
diff --git a/net/p5-Net-OAuth2/Makefile b/net/p5-Net-OAuth2/Makefile
index c7ac8969c486..8f8a89a943bf 100644
--- a/net/p5-Net-OAuth2/Makefile
+++ b/net/p5-Net-OAuth2/Makefile
@@ -23,7 +23,8 @@ TEST_DEPENDS= p5-Test-Mock-LWP-Dispatch>=0:${PORTSDIR}/devel/p5-Test-Mock-LWP-Di
p5-Test-Pod>=1.22:${PORTSDIR}/devel/p5-Test-Pod \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Net::OAuth2.3 \
Net::OAuth2::AccessToken.3 \
diff --git a/net/p5-Net-OpenSSH-Parallel/Makefile b/net/p5-Net-OpenSSH-Parallel/Makefile
index f1e2c17d12b8..6930e086ad7e 100644
--- a/net/p5-Net-OpenSSH-Parallel/Makefile
+++ b/net/p5-Net-OpenSSH-Parallel/Makefile
@@ -20,7 +20,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Net-OpenSSH>=0.39:${PORTSDIR}/net/p5-Net-OpenSSH
RUN_DEPENDS= p5-Net-OpenSSH>=0.39:${PORTSDIR}/net/p5-Net-OpenSSH
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Net::OpenSSH::Parallel.3 \
Net::OpenSSH::Parallel::Constants.3
diff --git a/net/p5-OAI-Harvester/Makefile b/net/p5-OAI-Harvester/Makefile
index 350acd94198b..be0e92deb499 100644
--- a/net/p5-OAI-Harvester/Makefile
+++ b/net/p5-OAI-Harvester/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-URI>=1.30:${PORTSDIR}/net/p5-URI \
p5-libwww>=2.0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= oai-listrecords.1 oai-listsets.1
MAN3= Net::OAI::Base.3 Net::OAI::Error.3 Net::OAI::GetRecord.3 \
diff --git a/net/p5-Socket/Makefile b/net/p5-Socket/Makefile
index 6c57f1eb4ef8..9c9d1561a206 100644
--- a/net/p5-Socket/Makefile
+++ b/net/p5-Socket/Makefile
@@ -14,7 +14,8 @@ COMMENT= Networking constants and support functions
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Socket.3
diff --git a/net/p5-URI-Query/Makefile b/net/p5-URI-Query/Makefile
index e35d7a933273..f5a68920be34 100644
--- a/net/p5-URI-Query/Makefile
+++ b/net/p5-URI-Query/Makefile
@@ -20,7 +20,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-URI>=1.31:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= URI::Query.3