aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-29 16:38:07 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-29 16:38:07 +0000
commitcbe2b41915d6ca9dc9473f454405cb8e24aaac6a (patch)
tree7bf3fca34451ac8b45639c4342a7bdcb2cd5569c /net
parentcab58d62a7df7cc4b371ade680cf4f1b99807c05 (diff)
downloadports-cbe2b41915d6ca9dc9473f454405cb8e24aaac6a.tar.gz
ports-cbe2b41915d6ca9dc9473f454405cb8e24aaac6a.zip
- Add a version of rubygem-bunny that's locked to version 0.6.0 for use by
rubygem-chef-expander
Notes
Notes: svn path=/head/; revision=331967
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-bunny060/Makefile21
-rw-r--r--net/rubygem-bunny060/distinfo2
-rw-r--r--net/rubygem-bunny060/pkg-descr16
4 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3c89da6df9e4..6f929ceaa17d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1026,6 +1026,7 @@
SUBDIR += rubygem-amqp067
SUBDIR += rubygem-aws-s3
SUBDIR += rubygem-bunny
+ SUBDIR += rubygem-bunny060
SUBDIR += rubygem-connection_pool
SUBDIR += rubygem-domain_name
SUBDIR += rubygem-dropbox-sdk
diff --git a/net/rubygem-bunny060/Makefile b/net/rubygem-bunny060/Makefile
new file mode 100644
index 000000000000..f3b700929986
--- /dev/null
+++ b/net/rubygem-bunny060/Makefile
@@ -0,0 +1,21 @@
+# Created by: renchap@cocoa-x.com
+# $FreeBSD$
+
+PORTNAME= bunny
+PORTVERSION= 0.6.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Another synchronous Ruby AMQP client
+
+RUN_DEPENDS= rubygem-amq-protocol>=1.6.0:${PORTSDIR}/net/rubygem-amq-protocol
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PKGNAMESUFFIX= 060
+
+NO_STAGE= yes
+.include <bsd.port.mk>
diff --git a/net/rubygem-bunny060/distinfo b/net/rubygem-bunny060/distinfo
new file mode 100644
index 000000000000..3d13d521e03c
--- /dev/null
+++ b/net/rubygem-bunny060/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bunny-0.6.0.gem) = fb8142488e96124f1b880979d1006366f254323f555add01a028ef70db306038
+SIZE (rubygem/bunny-0.6.0.gem) = 32256
diff --git a/net/rubygem-bunny060/pkg-descr b/net/rubygem-bunny060/pkg-descr
new file mode 100644
index 000000000000..21ad3f2be176
--- /dev/null
+++ b/net/rubygem-bunny060/pkg-descr
@@ -0,0 +1,16 @@
+Bunny is an AMQP (Advanced Message Queuing Protocol) client, written in Ruby,
+that is intended to allow you to interact with AMQP-compliant message
+brokers/servers such as RabbitMQ in a synchronous fashion.
+
+It is based on a great deal of useful code from amqp by Aman Gupta and Carrot
+by Amos Elliston.
+
+You can use Bunny to :
+* Create and delete exchanges
+* Create and delete queues
+* Publish and consume messages
+
+Bunny is known to work with RabbitMQ versions 1.5.4 and above with version 0-8
+of the AMQP specification.
+
+WWW: https://github.com/ruby-amqp/bunny