aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
commitd203b12054ad82d30bac1f0a0c022b1393f861b3 (patch)
treeaa853b3ada1746f7fe92c44b10a0a57900e6b933 /net
parent90b2f12a8477639b13e1b928f143269e9284ead4 (diff)
downloadports-d203b12054ad82d30bac1f0a0c022b1393f861b3.tar.gz
ports-d203b12054ad82d30bac1f0a0c022b1393f861b3.zip
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225305
Diffstat (limited to 'net')
-rw-r--r--net/AquaGatekeeper/Makefile2
-rw-r--r--net/AquaGatekeeper2/Makefile2
-rw-r--r--net/acx100/Makefile4
-rw-r--r--net/atmsupport/Makefile8
-rw-r--r--net/bittwist/Makefile8
-rw-r--r--net/bpfstat/Makefile4
-rw-r--r--net/coda6_server/Makefile5
-rw-r--r--net/dhcperf/Makefile14
-rw-r--r--net/dhcprelya/Makefile8
-rw-r--r--net/freenx/Makefile4
-rw-r--r--net/frickin/Makefile8
-rw-r--r--net/ifdepd/Makefile8
-rw-r--r--net/ifstated/Makefile8
-rw-r--r--net/ipa_ipfw/Makefile6
14 files changed, 11 insertions, 78 deletions
diff --git a/net/AquaGatekeeper/Makefile b/net/AquaGatekeeper/Makefile
index cb1ca3b6a999..d66da058e8d7 100644
--- a/net/AquaGatekeeper/Makefile
+++ b/net/AquaGatekeeper/Makefile
@@ -52,7 +52,7 @@ post-install:
.if ${ARCH} == "i386"
LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-.elif ${OSVERSION} >= 600000 && ${ARCH} == "amd64"
+.elif ${ARCH} == "amd64"
LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
.endif
diff --git a/net/AquaGatekeeper2/Makefile b/net/AquaGatekeeper2/Makefile
index b6b8e9a26771..a969e5f436ff 100644
--- a/net/AquaGatekeeper2/Makefile
+++ b/net/AquaGatekeeper2/Makefile
@@ -54,7 +54,7 @@ post-install:
.if ${ARCH} == "i386"
LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-.elif ${OSVERSION} >= 600000 && ${ARCH} == "amd64"
+.elif ${ARCH} == "amd64"
LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
.endif
diff --git a/net/acx100/Makefile b/net/acx100/Makefile
index dec16a717363..3f19f0baec8b 100644
--- a/net/acx100/Makefile
+++ b/net/acx100/Makefile
@@ -54,10 +54,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501107
-IGNORE= This port requires newer kernel sources that include /sys/dev/owi/if_ieee80211.h
-.endif
-
.if ${OSVERSION} >= 601104
BROKEN= Does not compile on FreeBSD >= 6.x
DEPRECATED= Has been broken for more than 6 months
diff --git a/net/atmsupport/Makefile b/net/atmsupport/Makefile
index 9c0af4203753..bfc2832fb963 100644
--- a/net/atmsupport/Makefile
+++ b/net/atmsupport/Makefile
@@ -25,10 +25,4 @@ USE_LDCONFIG= yes
MAN1= unidecode.1 uniencode.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501114
-IGNORE= "ngATM not implemented on FreeBSD 4.x, 5.1 and earlier"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/bittwist/Makefile b/net/bittwist/Makefile
index 344792a64615..e7c805745f68 100644
--- a/net/bittwist/Makefile
+++ b/net/bittwist/Makefile
@@ -20,10 +20,4 @@ MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
MAN1= bittwist.1 bittwistb.1 bittwiste.1
PLIST_FILES= bin/bittwist bin/bittwistb bin/bittwiste
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600032
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/bpfstat/Makefile b/net/bpfstat/Makefile
index 2dacad213138..6d9ce9a233ce 100644
--- a/net/bpfstat/Makefile
+++ b/net/bpfstat/Makefile
@@ -19,10 +19,6 @@ PLIST_FILES= sbin/bpfstat
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600033
-IGNORE= will only work on systems >= 600033
-.endif
-
.if ${OSVERSION} >= 700000
IGNORE= this has been merged into netstat
.endif
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index e6a47f7418d9..5559befd6333 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -78,13 +78,8 @@ MAN8= venus-setup.8 \
.include <bsd.port.pre.mk>
.if ${CODA_SUITE} == client
-.if ${OSVERSION} < 501106
-IGNORE= lacks kernel support on this version of FreeBSD
-.endif
# this needs testing with the new version (6.1.1)
-#.if ${OSVERSION} >= 600000
#IGNORE= makes a kernel panic on this version of FreeBSD
-#.endif
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "WARNING:"
diff --git a/net/dhcperf/Makefile b/net/dhcperf/Makefile
index 240b91fbc8c2..48d7e64c4614 100644
--- a/net/dhcperf/Makefile
+++ b/net/dhcperf/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-1-freebsd-5.4-i386
MAINTAINER= edwin@mavetju.org
COMMENT= DHCPerf delivers accurate performance metrics of Dynamic Host Configuration Protocol service
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Rebuild of i386 package provided by Nominum.
NO_BUILD= yes
@@ -25,16 +27,6 @@ PLIST_FILES= bin/dhcperf \
PLIST_DIRS= share/doc/dhcperf
MAN1= dhcperf.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION}<504000
-IGNORE= requires FreeBSD 5.4 or higher
-.endif
-
-.if ${OSVERSION}>600000
-LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
-.endif
-
post-extract:
${TAR} -C ${WRKSRC} -zxvf ${WRKSRC}/${PORTNAME}-${PORTVERSION}_1.tgz
@@ -45,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dcsevaltutorial.pdf ${PREFIX}/share/doc/dhcperf/dcsevaltutorial.pdf
${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dhcperf.pdf ${PREFIX}/share/doc/dhcperf/dhcperf.pdf
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/dhcprelya/Makefile b/net/dhcprelya/Makefile
index 5e306ca216d3..baf6191b593f 100644
--- a/net/dhcprelya/Makefile
+++ b/net/dhcprelya/Makefile
@@ -19,16 +19,10 @@ PORTDOCS= README
PLIST_FILES= sbin/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= require pidfile_* finctions in libutils
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/freenx/Makefile b/net/freenx/Makefile
index 46ca1c377b4b..e26824a7b910 100644
--- a/net/freenx/Makefile
+++ b/net/freenx/Makefile
@@ -27,10 +27,6 @@ NXPREFIX?= ${PREFIX}/NX
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503102
-RUN_DEPENDS+= nc:${PORTSDIR}/net/netcat
-.endif
-
.if ${OSVERSION} < 601101
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-freenx-nxserver \
${PATCHDIR}/extra-patch-freenx-nxsetup
diff --git a/net/frickin/Makefile b/net/frickin/Makefile
index fc0ecbc2a76d..3ed160306ed8 100644
--- a/net/frickin/Makefile
+++ b/net/frickin/Makefile
@@ -38,10 +38,4 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= does not compile with old version of pf
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ifdepd/Makefile b/net/ifdepd/Makefile
index cffc32bba2db..4d97ae4f5060 100644
--- a/net/ifdepd/Makefile
+++ b/net/ifdepd/Makefile
@@ -18,12 +18,6 @@ PLIST_FILES= bin/ifdepd \
USE_RC_SUBR= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502113
-IGNORE= need link state change notification changes from May 2004
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/etc/rc\.subr|${RC_SUBR}|; s|/usr/local|${PREFIX}|' \
@@ -32,4 +26,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index babbf799e26f..7f54cc5c2ba9 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -29,10 +29,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502113
-IGNORE= need link state change notification changes from May 2004
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ipa_ipfw/Makefile b/net/ipa_ipfw/Makefile
index 57873826319d..f81259c80660 100644
--- a/net/ipa_ipfw/Makefile
+++ b/net/ipa_ipfw/Makefile
@@ -29,12 +29,6 @@ MAKE_ENV+= WITH_PTHREAD=yes
CFLAGS+= ${PTHREAD_CFLAGS}
.endif
-.if ${OSVERSION} < 500038
-. if (defined(IPFW2) && !defined(WITH_IPFW2)) || defined(WITH_IPFW2)
-MAKE_ENV+= IPFW2=yes
-. endif
-.endif
-
.if !defined(WITH_DEBUG_INFO)
MAKE_ENV+= DEBUG_FLAGS=""
.endif