aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:50:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:50:46 +0000
commitdc351e2b93ae7c3f3187aba02b66fd5846a30be1 (patch)
tree620fae33402bb199f8026af333f0bc1da9e3d682 /net
parent04a05cfa0bd35e445e82b83f2c4fd8b1d79ac89b (diff)
downloadports-dc351e2b93ae7c3f3187aba02b66fd5846a30be1.tar.gz
ports-dc351e2b93ae7c3f3187aba02b66fd5846a30be1.zip
Add rubygem-activestorage61 6.1.0 (copied from rubygem-activestorage60)
Notes
Notes: svn path=/head/; revision=561033
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-activestorage61/Makefile30
-rw-r--r--net/rubygem-activestorage61/distinfo3
-rw-r--r--net/rubygem-activestorage61/pkg-descr14
4 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b76fe9288df2..62d2242e52a8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1176,6 +1176,7 @@
SUBDIR += rtptools
SUBDIR += rubygem-activestorage52
SUBDIR += rubygem-activestorage60
+ SUBDIR += rubygem-activestorage61
SUBDIR += rubygem-amazon-ec2
SUBDIR += rubygem-amq-protocol
SUBDIR += rubygem-amqp
diff --git a/net/rubygem-activestorage61/Makefile b/net/rubygem-activestorage61/Makefile
new file mode 100644
index 000000000000..b0bc80f530fb
--- /dev/null
+++ b/net/rubygem-activestorage61/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= activestorage
+PORTVERSION= 6.1.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 61
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Attach cloud and local files in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack61>=${PORTVERSION}:www/rubygem-actionpack61 \
+ rubygem-activejob61>=${PORTVERSION}:devel/rubygem-activejob61 \
+ rubygem-activerecord61>=${PORTVERSION}:databases/rubygem-activerecord61 \
+ rubygem-activesupport61>=${PORTVERSION}:devel/rubygem-activesupport61 \
+ rubygem-marcel>=0.3.1<0.4:devel/rubygem-marcel \
+ rubygem-mimemagic>=0.3.2<0.4:misc/rubygem-mimemagic
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-activestorage61/distinfo b/net/rubygem-activestorage61/distinfo
new file mode 100644
index 000000000000..881d3ae9794a
--- /dev/null
+++ b/net/rubygem-activestorage61/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609179784
+SHA256 (rubygem/activestorage-6.1.0.gem) = 32901903bdd62d2eee1f9878b5ff601589ae7d9b67754d77f7d28194c0a5fa4f
+SIZE (rubygem/activestorage-6.1.0.gem) = 54784
diff --git a/net/rubygem-activestorage61/pkg-descr b/net/rubygem-activestorage61/pkg-descr
new file mode 100644
index 000000000000..192794021c2e
--- /dev/null
+++ b/net/rubygem-activestorage61/pkg-descr
@@ -0,0 +1,14 @@
+Active Storage makes it simple to upload and reference files in cloud services
+like Amazon S3, Google Cloud Storage, or Microsoft Azure Storage, and attach
+those files to Active Records. Supports having one main service and mirrors in
+other services for redundancy. It also provides a disk service for testing or
+local deployments, but the focus is on cloud storage.
+
+Files can be uploaded from the server to the cloud or directly from the client
+to the cloud.
+
+Image files can furthermore be transformed using on-demand variants for quality,
+aspect ratio, size, or any other MiniMagick or Vips supported transformation.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activestorage