aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-06-21 02:55:22 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-06-21 02:56:13 +0000
commite7a8c57aaa62afd9ee716ca3e9785ae41593df50 (patch)
tree0e50e551227a99e3361501f9696acf3b0b69ea10 /net
parent66539fd4d2915e6bbe84e6c5664312cf301ccde7 (diff)
downloadports-e7a8c57aaa62afd9ee716ca3e9785ae41593df50.tar.gz
ports-e7a8c57aaa62afd9ee716ca3e9785ae41593df50.zip
net/sakisafe: Make corrections to the port Makefile
These corrections were not committed due to an error on my part. PR: 264784
Diffstat (limited to 'net')
-rw-r--r--net/sakisafecli/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/net/sakisafecli/Makefile b/net/sakisafecli/Makefile
index f85b3bdc8767..c058f38735eb 100644
--- a/net/sakisafecli/Makefile
+++ b/net/sakisafecli/Makefile
@@ -2,12 +2,20 @@ PORTNAME= sakisafe
DISTVERSION= 2.0.7
CATEGORIES= net
MASTER_SITES= http://git.qorg11.net/sakisafe.git/snapshot/
+
+MAINTAINER= teru-sama@ebin.city
+COMMENT= Client for many file-sharing websites.
+
LICENSE= GPLv3
-CFLAGS= -I/usr/local/include -fPIC
+
LIB_DEPENDS= libconfig.so:devel/libconfig \
libcurl.so:ftp/curl
-MAINTAINER= teru-sama@ebin.city
-COMMENT= Client for many file-sharing websites.
-WWW= https://git.qorg11.net/sakisafe.git
-.include <bsd.port.mk>
+CFLAGS= -I/usr/local/include -fPIC
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sakisafecli/sakisafecli ${STAGEDIR}${PREFIX}/bin/sakisafecli
+ ${INSTALL_MAN} ${WRKSRC}/sakisafecli/sakisafecli.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/sakisafecli/sakisafeclirc.5 ${STAGEDIR}${MAN1PREFIX}/man/man5
+
+.include <bsd.port.mk>