aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-03-24 03:24:28 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-03-24 03:24:28 +0000
commite9ac69d875193a1a8a13231bef0da3624bbe4b61 (patch)
tree79fc22c0d02cba99a13c1790c89dee188800e9cb /net
parent002a77a68f5cd89fce887734fcbb341a5a09e832 (diff)
downloadports-e9ac69d875193a1a8a13231bef0da3624bbe4b61.tar.gz
ports-e9ac69d875193a1a8a13231bef0da3624bbe4b61.zip
net/tigervnc: 1.3.1 -> 1.4.3
Release-Notes: https://github.com/TigerVNC/tigervnc/releases/tag/v1.4.3 - should solve longstanding issue with Ctrl-hotkeys in vncviewer https://github.com/TigerVNC/tigervnc/issues/8 PR: 198721 Submitted by: Koichiro Iwao <meta+ports@vmeta.jp> (maintainer) Requested by: Georgy Lukyanchenko <egorxe@gmail.com>
Notes
Notes: svn path=/head/; revision=382065
Diffstat (limited to 'net')
-rw-r--r--net/tigervnc/Makefile16
-rw-r--r--net/tigervnc/distinfo4
-rw-r--r--net/tigervnc/files/patch-hw-vnc-off-by-one-error65
-rw-r--r--net/tigervnc/files/patch-vncviewer-always-built19
-rw-r--r--net/tigervnc/pkg-plist6
5 files changed, 15 insertions, 95 deletions
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index e6b529b66115..c40add25ad85 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= tigervnc
-PORTVERSION= 1.3.1
-PORTREVISION= 9
+PORTVERSION= 1.4.3
CATEGORIES= net x11-servers
-MASTER_SITES= SF:tigervnc
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}/:tigervnc
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:tigervnc
+MASTER_SITES= https://github.com/TigerVNC/tigervnc/archive/v${PORTVERSION}${EXTRACT_SUFX}?dummy=/
MAINTAINER= meta+ports@vmeta.jp
COMMENT= High-performance, platform-neutral implementation of VNC
@@ -79,7 +76,7 @@ CMAKE_ARGS+= -DBUILD_VIEWER=1
LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
libfltk.so:${PORTSDIR}/x11-toolkits/fltk
# ImageMagick is required to generate icons during build process
-BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
USE_XORG+= xcursor xfixes xft xinerama
PLIST_SUB+= VIEWER=""
INSTALLS_ICONS= yes
@@ -118,9 +115,10 @@ TIGERVNC_XORG_PATCH_VER= 114
# import from x11-server/xorg-server/Makefile
.ifdef WITH_OPENSSL_BASE
-# The reason why I use this is cause openssl from base doesn't install a .pc file
-# and configure will fail trying to find it. Setting both of those variables to
-# a *non-empty* value by-passes the pkg-config check.
+# The reason why I use this is cause openssl from base doesn't
+# install a .pc file and configure will fail trying to find it.
+# Setting both of those variables to a *non-empty* value by-passes
+# the pkg-config check.
CONFIGURE_ENV= SHA1_LIB="-L/usr/lib -lcrypto" SHA1_CFLAGS="-I/usr/include"
.endif
diff --git a/net/tigervnc/distinfo b/net/tigervnc/distinfo
index 7f22ff0eb565..ad12faa98038 100644
--- a/net/tigervnc/distinfo
+++ b/net/tigervnc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tigervnc-1.3.1.tar.gz) = 628622316eefa5d4f348f00a280a513569bfae3eae6a20d72e2990654d12274e
-SIZE (tigervnc-1.3.1.tar.gz) = 6888105
+SHA256 (tigervnc-1.4.3.tar.gz) = 0b2603db2b32dfd6e48f6f59618bd9819d187bfbb0c16218637d074a69756824
+SIZE (tigervnc-1.4.3.tar.gz) = 1372873
diff --git a/net/tigervnc/files/patch-hw-vnc-off-by-one-error b/net/tigervnc/files/patch-hw-vnc-off-by-one-error
deleted file mode 100644
index 6c4902c178fa..000000000000
--- a/net/tigervnc/files/patch-hw-vnc-off-by-one-error
+++ /dev/null
@@ -1,65 +0,0 @@
---- unix/xserver/hw/vnc/vncHooks.cc.orig 2013-07-01 12:41:24.000000000 +0000
-+++ unix/xserver/hw/vnc/vncHooks.cc 2013-07-20 13:38:14.424240970 +0000
-@@ -119,7 +119,7 @@
-
- // screen functions
-
--#if XORG < 112
-+#if XORG <= 112
- static Bool vncHooksCloseScreen(int i, ScreenPtr pScreen);
- #else
- static Bool vncHooksCloseScreen(ScreenPtr pScreen);
-@@ -140,7 +140,7 @@
- DeviceIntPtr pDev,
- #endif
- ScreenPtr pScreen, CursorPtr cursor);
--#if XORG < 112
-+#if XORG <= 112
- static void vncHooksBlockHandler(int i, pointer blockData, pointer pTimeout,
- pointer pReadmask);
- #else
-@@ -367,7 +367,7 @@
- // CloseScreen - unwrap the screen functions and call the original CloseScreen
- // function
-
--#if XORG < 112
-+#if XORG <= 112
- static Bool vncHooksCloseScreen(int i, ScreenPtr pScreen_)
- #else
- static Bool vncHooksCloseScreen(ScreenPtr pScreen_)
-@@ -405,7 +405,7 @@
-
- DBGPRINT((stderr,"vncHooksCloseScreen: unwrapped screen functions\n"));
-
--#if XORG < 112
-+#if XORG <= 112
- return (*pScreen->CloseScreen)(i, pScreen);
- #else
- return (*pScreen->CloseScreen)(pScreen);
-@@ -574,7 +574,7 @@
- // BlockHandler - ignore any changes during the block handler - it's likely
- // these are just drawing the cursor.
-
--#if XORG < 112
-+#if XORG <= 112
- static void vncHooksBlockHandler(int i, pointer blockData, pointer pTimeout,
- pointer pReadmask)
- #else
-@@ -582,7 +582,7 @@
- pointer pReadmask)
- #endif
- {
--#if XORG < 112
-+#if XORG <= 112
- SCREEN_UNWRAP(screenInfo.screens[i], BlockHandler);
- #else
- SCREEN_UNWRAP(pScreen_, BlockHandler);
-@@ -590,7 +590,7 @@
-
- vncHooksScreen->desktop->ignoreHooks(true);
-
--#if XORG < 112
-+#if XORG <= 112
- (*pScreen->BlockHandler) (i, blockData, pTimeout, pReadmask);
- #else
- (*pScreen->BlockHandler) (pScreen, pTimeout, pReadmask);
diff --git a/net/tigervnc/files/patch-vncviewer-always-built b/net/tigervnc/files/patch-vncviewer-always-built
deleted file mode 100644
index 7d4978b74808..000000000000
--- a/net/tigervnc/files/patch-vncviewer-always-built
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: CMakeLists.txt
-===================================================================
---- CMakeLists.txt (revision 5159)
-+++ CMakeLists.txt (working copy)
-@@ -390,9 +390,12 @@
- add_subdirectory(po)
- endif()
-
--add_subdirectory(vncviewer)
-+option(BUILD_VIEWER "Build TigerVNC viewer" ON)
-+if(BUILD_VIEWER)
-+ add_subdirectory(vncviewer)
-+ add_subdirectory(media)
-+endif()
-
--add_subdirectory(media)
-
- include(cmake/BuildPackages.cmake)
-
diff --git a/net/tigervnc/pkg-plist b/net/tigervnc/pkg-plist
index 695d71315cf1..df3797fb47b7 100644
--- a/net/tigervnc/pkg-plist
+++ b/net/tigervnc/pkg-plist
@@ -17,6 +17,12 @@ man/man1/Xvnc.1.gz
%%NLS%%share/locale/ru/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sk/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/es/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/it/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/tigervnc.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/tigervnc.mo
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENCE.TXT
%%VIEWER%%share/icons/hicolor/16x16/apps/tigervnc.png