aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2021-09-06 21:22:58 +0000
committerXin LI <delphij@FreeBSD.org>2021-09-06 21:27:39 +0000
commitea525437cd38a64c0ce84e442ad8b4e2e2ee3a4a (patch)
tree4f8667b07ecef2668116705b0977c1f62f0ad276 /net
parenta2131bbf862a15b2f299e009ae02b87621168d70 (diff)
downloadports-ea525437cd38a64c0ce84e442ad8b4e2e2ee3a4a.tar.gz
ports-ea525437cd38a64c0ce84e442ad8b4e2e2ee3a4a.zip
net/openldap24-server: Make DEBUG default.
In 616f384d5cce7f52a9f5a2164d405f4185bbcab9 the port was converted to use the option framework's handling of options. Previously, when "DEBUG" is unchecked, the port will not pass --disable-debug and because debug was enabled by default in upstream, the option is effectively saying build with debug anyways. After the conversion, we are now correctly building a non-debug build which will also remove syslog support. Restore the historical behavior and build with debug option by default as it's what expected by upstream and the option never worked on FreeBSD until the recent conversion actually fixed the option to do what it was intended to do. PR: ports/257884
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index cfe181e3923e..f61cbd144015 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -49,13 +49,14 @@ WANT_OPENLDAP_VER?= 24
BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
-PORTREVISION_CLIENT= 1
-PORTREVISION_SERVER= 3
+PORTREVISION_CLIENT= 2
+PORTREVISION_SERVER= 4
OPENLDAP_SHLIB_MAJOR= 2
OPENLDAP_SHLIB_MINOR= 11.7
OPENLDAP_MAJOR= ${DISTVERSION:R}
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
+OPTIONS_DEFAULT= DEBUG
FETCH_DESC= Enable fetch(3) support
GSSAPI_DESC= With GSSAPI support
@@ -114,7 +115,7 @@ OPTIONS_DEFINE+= OUTLOOK
OPTIONS_DEFINE+= KQUEUE
OPTIONS_DEFINE+= DYNAMIC_MODULES
-OPTIONS_DEFAULT= DYNAMIC_MODULES
+OPTIONS_DEFAULT+= DYNAMIC_MODULES
OPTIONS_DEFAULT+= ${BKNDS_DEFAULTS}
OPTIONS_DEFAULT+= ${OPTIONS_GROUP_OVLYS}