aboutsummaryrefslogtreecommitdiff
path: root/news/husky
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-09-21 22:09:08 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-09-21 22:09:08 +0000
commit2ded93783ddc75c7b2bf26b9dc79624b6d273381 (patch)
tree32d85e5b5f352cae00c190004aa74fd817559cef /news/husky
parentb65beb26da6941b6ddfb72026f8f92ee713ca924 (diff)
downloadports-2ded93783ddc75c7b2bf26b9dc79624b6d273381.tar.gz
ports-2ded93783ddc75c7b2bf26b9dc79624b6d273381.zip
Rework husky ports to use a more conventional MASTER/SLAVE port pattern.
- Remove Makefile.local as it is intended to be a user file that should not be committed. Its documentation is poor (r12873) but users are relying on it. - Remove CONFLICTS as for every port it just conflicted with itself. With hat: portmgr
Notes
Notes: svn path=/head/; revision=397523
Diffstat (limited to 'news/husky')
-rw-r--r--news/husky/Makefile31
-rw-r--r--news/husky/Makefile.local32
2 files changed, 27 insertions, 36 deletions
diff --git a/news/husky/Makefile b/news/husky/Makefile
index e70cd3975d9a..4b9392d4e484 100644
--- a/news/husky/Makefile
+++ b/news/husky/Makefile
@@ -1,15 +1,38 @@
# $FreeBSD$
-PORTNAME= husky
+PORTNAME?= husky
+PORTVERSION= 1.9.20140519
+PORTREVISION?= 2
+PORTEPOCH?= 0
+CATEGORIES?= news mail
+MASTER_SITES= SF/husky/husky/1.9-current/2014.05.19
-COMMENT= Husky full featured highly portable FTN Tosser
+MAINTAINER?= osharoiko@gmail.com
+COMMENT?= Husky full featured highly portable FTN Tosser
+DISTNAME= husky-all-1.9-source-20140519
+
+.if ${PORTNAME} == "husky"
RUN_DEPENDS= hpt:${PORTSDIR}/news/husky-hpt \
htick:${PORTSDIR}/news/husky-htick
-MASTERDIR= ${.CURDIR}
-
NO_BUILD= yes
NO_INSTALL= yes
+.endif
+
+USES+= alias gmake tar:tgz
+
+HUSKY_ROOTDIR= ${WRKDIR}/husky
+PATCH_WRKSRC= ${HUSKY_ROOTDIR}
+WRKSRC= ${HUSKY_ROOTDIR}/${COMPONENT_SUBDIR}
+PKGDIR= ${.CURDIR}
+
+USERS= fido
+GROUPS= fido
+
+pre-build:
+ ${LN} -sf ${HUSKY_ROOTDIR}/huskybse/huskymak.cfg ${HUSKY_ROOTDIR}
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|g++|${CXX}|' \
+ ${HUSKY_ROOTDIR}/huskymak.cfg
.include <bsd.port.mk>
diff --git a/news/husky/Makefile.local b/news/husky/Makefile.local
deleted file mode 100644
index a0c90a6802ea..000000000000
--- a/news/husky/Makefile.local
+++ /dev/null
@@ -1,32 +0,0 @@
-# vim:filetype=make
-# $FreeBSD$
-
-PORTVERSION= 1.9.20140519
-PORTREVISION= 2
-CATEGORIES= news mail
-
-.if ${PORTNAME} == "husky-smapi"
-PORTEPOCH= 1
-.endif
-
-MAINTAINER= osharoiko@gmail.com
-
-MASTER_SITES= SF/husky/husky/1.9-current/2014.05.19
-DISTNAME= husky-all-1.9-source-20140519
-
-HUSKY_ROOTDIR= ${WRKDIR}/husky
-PATCH_WRKSRC= ${HUSKY_ROOTDIR}
-WRKSRC= ${HUSKY_ROOTDIR}/${COMPONENT_SUBDIR}
-PKGDIR= ${.CURDIR}
-
-CONFLICTS= ${PORTNAME}-[0-9]*
-
-USERS= fido
-GROUPS= fido
-
-USES+= alias gmake tar:tgz
-
-pre-build:
- ${LN} -sf ${HUSKY_ROOTDIR}/huskybse/huskymak.cfg ${HUSKY_ROOTDIR}
- @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|g++|${CXX}|' \
- ${HUSKY_ROOTDIR}/huskymak.cfg